2001 Ford F-150 5.4 Rough Idle

Posted in the Top Stories Forum

First Prev
of 2
Next Last

Since: Nov 08

Nashville, TN

#1 Nov 1, 2008
I have a F150 5.4. I rarely drive it. It only has 80k miles. Drove it and it started to stumble. It felt like the transmission. Had it checked out. Not the transmission. Engine light not on. The engine is smooth at speeds about 70. Some told me it was the EGR so I replaced it. Still stumbling. Does anyone have any idea what could be the problem? Thanks in advance

Since: Oct 08

South Bay, Fl.

#2 Nov 1, 2008
Maybe your fuel pump. My dodge did 'bout the same. Hope this helps.

Since: Dec 07

Ashburn, VA

#3 Nov 1, 2008
Darkness125 wrote:
I have a F150 5.4. I rarely drive it. It only has 80k miles. Drove it and it started to stumble. It felt like the transmission. Had it checked out. Not the transmission. Engine light not on. The engine is smooth at speeds about 70. Some told me it was the EGR so I replaced it. Still stumbling. Does anyone have any idea what could be the problem? Thanks in advance
When you hit 50,000 miles did you replace the muffler bearings?

Since: Oct 08

South Bay, Fl.

#4 Nov 1, 2008
Darkness125 wrote:
I have a F150 5.4. I rarely drive it. It only has 80k miles. Drove it and it started to stumble. It felt like the transmission. Had it checked out. Not the transmission. Engine light not on. The engine is smooth at speeds about 70. Some told me it was the EGR so I replaced it. Still stumbling. Does anyone have any idea what could be the problem? Thanks in advance
Cut off your Catalytic Convertor you'll defiently get better fuel mileage. All it does is restrict your engine anyway.

Since: Nov 08

Nashville, TN

#7 Nov 1, 2008
Cropduster wrote:
Maybe your fuel pump. My dodge did 'bout the same. Hope this helps.
Thanks I will see about the fuel pump and filter.

“Free money is a myth”

Since: Aug 08

Chattanooga, TN

#8 Nov 1, 2008
O2 sensor,look,listen and feel for vaccuum leaks on the engine,and last but least,dump 4 bottle of rubbing alcohol in your fuel tank and leave the cap off overnight...will remove any water that may have seperated from your gas,and if you have an inline fuel filter...remove and replace.

now....you owe me $120(laughing)

“deo confidimus.”

Since: Oct 08

vancouver.

#9 Nov 1, 2008
..........

sounds like a fuel problem alright...maybe a fuel mangement problem causing a too rich mixture....check a sparkplug,should be dark brown if it's getting a proper fuel mix....light brown or black..no good.

.....when did you change the sparkplugs last? 10,000 miles is all i give mine.

start with the cheapest and simplest causes....like the other posters said:.. fuel filter...get the fuel pump tested...

how old is the gas? you say you hardly drive it.....gas can go bad in 6 months.

Since: Nov 08

Nashville, TN

#12 Nov 2, 2008
johnny canuk wrote:
..........
sounds like a fuel problem alright...maybe a fuel mangement problem causing a too rich mixture....check a sparkplug,should be dark brown if it's getting a proper fuel mix....light brown or black..no good.
.....when did you change the sparkplugs last? 10,000 miles is all i give mine.
start with the cheapest and simplest causes....like the other posters said:.. fuel filter...get the fuel pump tested...
how old is the gas? you say you hardly drive it.....gas can go bad in 6 months.
Original spark plugs. The manual said I didn't need to a a tune up for 100k miles. I asked the dealer about the tune up and they said the manual is correct. I think is very odd. I have always done tune ups around 10k - 12k miles. I never fill the tank. I only put a quarter tank of gas every time i drive it. I pretty much run it out when I use it.

I think I am going to go ahead and do a complete tune up, change the fuel filter, check the pump.

“deo confidimus.”

Since: Oct 08

vancouver.

#13 Nov 2, 2008
Darkness125 wrote:
<quoted text>
Original spark plugs. The manual said I didn't need to a a tune up for 100k miles. I asked the dealer about the tune up and they said the manual is correct. I think is very odd. I have always done tune ups around 10k - 12k miles. I never fill the tank. I only put a quarter tank of gas every time i drive it. I pretty much run it out when I use it.
I think I am going to go ahead and do a complete tune up, change the fuel filter, check the pump.
i also own a ford f-150 ....

my fuel pump quit in the middle of a shopping center parking lot 3 days ago ....i had been at the bank and was on my way to an important meeting...

the only one who came over to help me push the truck out of the way, was a women who came out of the barber shop wearing a buckskin jacket,cowboy hat, and cowboy boots....a texan perhaps?..

she took off so fast i never found out..

i changed the fuel pump 2 days ago,had to drop the tank....a b*tch of a job...
the shop wanted $300.00...freakin bandits...

try and get a look at those plugs..they tell alot about your fuel mixture...
i know they use platinum tipped plugs that are supposed to get 100,000 miles now....but i don't like them,they tend to foul easier, and the vehicle can even refuse to start up sometimes..
i changed mine to the standard autolites.

Since: Nov 08

Nashville, TN

#14 Nov 2, 2008
johnny canuk wrote:
<quoted text>
i also own a ford f-150 ....
my fuel pump quit in the middle of a shopping center parking lot 3 days ago ....i had been at the bank and was on my way to an important meeting...
the only one who came over to help me push the truck out of the way, was a women who came out of the barber shop wearing a buckskin jacket,cowboy hat, and cowboy boots....a texan perhaps?..
she took off so fast i never found out..
i changed the fuel pump 2 days ago,had to drop the tank....a b*tch of a job...
the shop wanted $300.00...freakin bandits...
try and get a look at those plugs..they tell alot about your fuel mixture...
i know they use platinum tipped plugs that are supposed to get 100,000 miles now....but i don't like them,they tend to foul easier, and the vehicle can even refuse to start up sometimes..
i changed mine to the standard autolites.
Thanks for the advise. I let you know the outcome

“deo confidimus.”

Since: Oct 08

vancouver.

#15 Nov 2, 2008
Darkness125 wrote:
<quoted text>
Thanks for the advise. I let you know the outcome
10-4 ...be good to know.
C D Noble

Oklahoma City, OK

#16 Dec 28, 2008
F150, 2001 Triton engin rough idle Check engin light. 140K, New tuneup
Jack Reagan

United States

#17 Dec 31, 2008
Hey this same thing happened to my F150 at about that many miles. It started cutting out and acting really wierd. I couldn't figure out what was wrong with it, I was at the point of trading it in when I talked with my dad and he recommended me cleaning a few things. I did one at a time and found out that it was a small valve located on the EFI that was causing the problem. Take off the cover and look on the right side. you will see a valve with an external wiring harness plug on it. Remover the wiring cannon plug, and then remove the two bolts holding the valve on the EFI. Becarefull not to damage the gasket so you can reuse it. Once the valve is removed gt some WD40, a wire brush (gun cleaning kit will probably work best), and some carb cleaner. Use the WD40 to break up the sluge and deposits caused by dirt and grime and the wire brush to knock off all the sluge and polish the surfaces at the same time. Use the carb cleaner to clean the valve. Inspect the spring for wear and rigidity and also inspect for cleanliness. Then all you have to do is reinstall the valve and it will have cost you less than $10 assuming you don't already have this stuff in your garage. That valve controls the idle of your vehicle and removing that sluge should fix your problem.
Darkness125 wrote:
I have a F150 5.4. I rarely drive it. It only has 80k miles. Drove it and it started to stumble. It felt like the transmission. Had it checked out. Not the transmission. Engine light not on. The engine is smooth at speeds about 70. Some told me it was the EGR so I replaced it. Still stumbling. Does anyone have any idea what could be the problem? Thanks in advance
john

San Antonio, TX

#18 Dec 31, 2008
Try running some higher octane fuel and adding a fuel system cleaner like gumout. Run this mixture at highway speeds for as long as you can (preferably 1/2 tank). Also, add some "stabil" to your gas when not planning to drive for a while. The stabil will prevent your stored fuel from varnishing in the lines, injectors, etc.
Blockslinger

Waterford, OH

#19 Mar 11, 2010
This same thing is happening to my f150. Its at the shop being pressure tested right now. Gonna try the same thing Jack Reagan did. Hopefully thats all i need.
josh

O Fallon, MO

#20 Jul 24, 2010
my truck is doing the same thing. I will try what jack said. I have replaces lines. iac iat maf pcv valve.
josh

O Fallon, MO

#21 Jul 24, 2010
by the way where is that valve located at on the engine?? valve on the efi
WhiteNationalist

Denver, NC

#22 Jul 24, 2010
Take off your air cleaner. Under your throttle body you will see a little U shaped rubber hose. This is the PCV elbow. You probably need to replace that. When they get old they tend to crack or close under pressure, causing a rough idle, and rough running. Its a very common problem. I would check the O2 sensors also.

Its it throwing an engine code?
Juan

San Antonio, TX

#23 Dec 9, 2010
Mine did the same thing and i just changed the pcv valve and cleaned the iac now it is running fine
Ryan

Auburn, NY

#24 Mar 19, 2011
Did what you said runs like a bat out of hell, but now it has a high idle I think I'm going to try to reset the computer tomorrow

Tell me when this thread is updated:

Subscribe Now Add to my Tracker
First Prev
of 2
Next Last

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Top Stories Discussions

Title Updated Last By Comments
Jehovah's Witnesses are true disciple of Jesus ... (Mar '07) 2 min Student 40,223
Prove there's a god. (Mar '08) 6 min Hidingfromyou 830,361
Poll If you're Christain what kind are you? (Oct '07) 40 min Justice League 3,955
Poll Is homosexuality a sin? (Oct '07) 55 min Paul Porter1 99,270
News Roman Catholic church only true church, says Va... (Jul '07) 1 hr oxbow 585,785
Poll Was 9/11 a conspiracy?? (Oct '07) 1 hr AussieBobby 270,830
News Blaming Israel for carnage (Jul '06) 1 hr Gas Woman 121,731
Why Should Jesus Love Me? (Feb '08) 9 hr dr Shrink 611,943
More from around the web