Northjeep

Caribou, ME

#208 Aug 20, 2012
I got the O2 sensor replaced and I haven't had a problem for 2 weeks
Kevin

Ellicott City, MD

#209 Aug 21, 2012
97 straight 6 jeep limited. Stalls, backfires...then wont start..replaced the crank shaft sensor..cleaned the fuel injectors...still doing it..I have read 2x about the screws on the ECM being too long and now I see that someone used plastic ties...and now fuel injector cleaner...anyone have any other suggestions....my jeep is so nice, but I can't sell it to someone like this..
Just - Tone

Marriottsville, MD

#210 Aug 22, 2012
We had a friend do some data loging last night on the g/f's GC. Looks like it's the CPS and Idle Air Control Valve. O2 sensors are working 100% perfectly per data logs. Looks like I have some work to do this weekend!
David NY

Bronx, NY

#211 Aug 29, 2012
Steve wrote:
I have the exact same symptoms with my 98 GC. It will start and then after, just as you said, 10 to 30 seconds it will start to stumble and hesitate and even backfire if you try to stomp on it. This lasts anywhere from a minute to 5 minutes on mine, then goes away. Last week it simply wouldn't start at all and I replaced the Crankshaft Position Sensor and that cured that, but I think that was unrelated to the running issue. Who knows! And ideas out there would be appreciated. I'm just afraid that one of these days it will turn worse and leave us stranded.
Steve,
Did you engine try to stall will you were driving on highway. That what mine would do. Lose power then regain it. It would stall at low speeds or when your crawling in traffic. It also backfire once. I know i had an error code tell me it was the speed control.
But that did make much sense. I'm curious about the crankshaft position sensor you replace and what was the cost to replace it. Did it cure your problem
Thanks
BowlingDj101@yahoo.com
JeepHater

Saint Petersburg, FL

#212 Sep 10, 2012
I'm going through pretty much the same issues described in other posts... 97 GC 4.0/auto stalls and then won't start back up for approx. 2 minutes.. or,it sputters/spits/dies while you're driving down the road. I have dumped more money in this POS than I have in any other car that I've ever owned (and I've owned a lot)and I've only had it for 2 years (put 20k miles it-it now has 125k). Parts I've replaced include: basically the entire cooling system - water pump (twice), radiator, stat, hoses... Both O2 sensors, Crankshaft Position Sensor, fuel pump and sending unit, various other sensors and suspension parts.
Current issues (besides dying sporadically)include: Both headlights bulbs keep blowing out (tried resealing lenses with silicone-still keep blowing out), AC only blows on 1st 3 speeds/not on high (not good for living in FL), the paint is flaking off in big chunks.. leaving huge primer spots (factory paint defect), all of the door lock motors are stripped and not working, the instrument lights flicker on and off at night... I'm sure that I'm missing quite a few other things wrong with it, that I've just learned to live with.

As for the stalling issue, I can move the wiring harness that's closest to the engine on the PCM and cause it to stall, so I'm pretty sure it's a bad connector or loose connection (whether in the harness or inside the PCM itself).

I've decided that the BEST RESOLUTION to all of the issues above is to take the following steps:

Step 1) Remove the radiator cap
Step 2) Drive a FORD up under the radiator cap
Step 3) Replace the radiator cap :-)

I have a 97 Expedition with 187,000 miles on it (I put 120k on it) and.. knock on wood.. have NEVER had any issues with it. The paint still looks good, it runs like a top and I wouldn't be afraid to jump in it right now and start off on a cross-country trip in it.

The Jeep.. not really confident that I'll even make it home from work today.:-(

jgc

Santa Ana, CA

#213 Sep 11, 2012
i have a Grand Cherokee 98. while im driving it stops on me its happend several times now.. what could be the problem ?
Dalton

Saint Louis, MO

#214 Sep 17, 2012
What exactly was your Jeep doing? I'm having issues with my 98 ZJ and I'm wondering if replacing the PCM like you did would really solve the problem...
Littlet10

Northampton, MA

#215 Oct 4, 2012
Try this take zip ties and put over the 3 plugs that go into control board. but before you do that loosen the 2 screws 2 full turns each that are under the 3 plugs. An engineer figured this out and has worked for me and many others.
Cathy

Lehigh Acres, FL

#216 Oct 13, 2012
I have a 2003 Jeep grand cherokee. This is the third time with the stalling problem. Have replaced crankshaft sensor twice, fuel sensor, just 2 days ago the mechanic told me it was the battery cables not being tight enough and had it on the diagnostic system, etc., nothing shows up! The very next day the engine light came on and now it is doing the same thing. Sick of it, and when I have it fixed, or if, I should say, it will be history!
jeepers

Phoenix, AZ

#217 Oct 15, 2012
I have a 97 jeep grand Cherokee , 4.0 it stalls when its cold or warm , no check engine light, catalytic converter makes a rattling noise, changed fuel pump already, no different, gonna try the screw and pin trick first before putting more green into it. Thx
joe m

Salt Lake City, UT

#218 Oct 22, 2012
98 Jeep Grand Cherokee. 5.2 L. Intermitant idling problem. Stalls at stop signs. Rplcd plugs and wires. Seems to be worse. WILL NOT IDLE. With acceleration enough to keep running in park, I noticed RPM would increase slightly and drop back and repeat. Help!
sharon

Atlanta, GA

#219 Oct 24, 2012
Jennifer wrote:
I also have a 98 Jeep Grand Cherokee and I have spent over $1,000 in the last 30 days because I have the SAME stalling issue - I have had the coil replaced twice, ignition sensor once, the fuel pump relay switch, the PCM (from the dealer) and wires repaired/replaced and STILL it won't work!!! Just stalls, doesn't matter if I am driving or at a light...just stalls. It is sad because I like my Jeep - if anyone figures out the real problem, please let me know...
Try camshaft sensor or crank sensor..hope it work
Scott

Newburgh, IN

#220 Oct 27, 2012
I tried a new ECM, didn't work, tried the screw thing, didn't work. Replaced the Crankshaft position sensor, took care of the problem. I would definitely try that before buying a new ECM (PCM)
Leo

Austin, TX

#221 Oct 27, 2012
The prOblem is surprisingly easy to fix. A few hours and a little patience and attention to detail. I fixed two of these jeeps with tese problems. I will do a write up on PDF and email it to anyone that wants it.

I will set up an email in case I get spammed just for this tonight and will respond again.

Btw, the main culprits are the ECM and the wire harness connectors to the ECM. you have to open the ECM and resoldered the solder joints from the back of the board where they separate from vibrations. There is a good write up on this on the jeep forum.

The next culprit is with the wire harness connectors becoming oblong and not having a consistent solid connection witht the pins. These need to be replaced of individually crimped after disassembling the connector. This is a pain in the rear but it worked on my 97 like a charm.
allan mcleod

Thornhill, Canada

#222 Oct 27, 2012
Hi-please send me pDF on fix solution.
allan
Leo wrote:
The prOblem is surprisingly easy to fix. A few hours and a little patience and attention to detail. I fixed two of these jeeps with tese problems. I will do a write up on PDF and email it to anyone that wants it.
I will set up an email in case I get spammed just for this tonight and will respond again.
Btw, the main culprits are the ECM and the wire harness connectors to the ECM. you have to open the ECM and resoldered the solder joints from the back of the board where they separate from vibrations. There is a good write up on this on the jeep forum.
The next culprit is with the wire harness connectors becoming oblong and not having a consistent solid connection witht the pins. These need to be replaced of individually crimped after disassembling the connector. This is a pain in the rear but it worked on my 97 like a charm.
allan mcleod

Thornhill, Canada

#223 Oct 27, 2012
Hi-please send me PDF on your fix for my POS that quits while driving.
Only fix now-is to turn off engine-even while driving-turn key back on-then keep driving for another 20 minutes!!
allan
Leo

San Antonio, TX

#224 Oct 27, 2012
I will post links to the jeep forum on how to fix this tonight when I get home.
Joe M

Salt Lake City, UT

#225 Oct 27, 2012
joe m wrote:
98 Jeep Grand Cherokee. 5.2 L. Intermitant idling problem. Stalls at stop signs. Rplcd plugs and wires. Seems to be worse. WILL NOT IDLE. With acceleration enough to keep running in park, I noticed RPM would increase slightly and drop back and repeat. Help!
Engine light came ON and test at local parts dealer indicated the EGR (Exhaust Gas Regulator) was defective. Rplcd it and trouble cleared!
Joe M

Salt Lake City, UT

#226 Oct 27, 2012
joe m wrote:
98 Jeep Grand Cherokee. 5.2 L. Intermitant idling problem. Stalls at stop signs. Rplcd plugs and wires. Seems to be worse. WILL NOT IDLE. With acceleration enough to keep running in park, I noticed RPM would increase slightly and drop back and repeat. Help!
The Engine light came on and a test at the local parts store indicated the EGR (Exhaust Gas Regulator) was bad. I rplcd it and trouble cleared!
Mark M

Buda, TX

#227 Oct 28, 2012
this is exactly what mine does 2001 Grand Cherokee, ordering the PCM Board it is electrical my difference is I get the P0700 code, with the engine light on. But I do not think it has anything to do with the trans. per the code. will post my results after installation.
Markus wrote:
1998 Jeep Grand Cherokee 4.0L 4x4
Performed Full tune up 12/2010:
spark plugs/wires, distributor cap/rotor, air filter
Plus replaced:
O2 sensors, crank position sensor, MAP sensor, ignition coil, and fuel pump assembly
I have removed and cleaned IAC valve however may still be sticking.
Pending issues:
Stalling while idling/stalling while driving, sometimes random with no warning, other times bucking/shuddering/backfiring then stall. RPM’s drop to 0 Seems to be soon after start up, and again after reaching operating temp. Trying to re-start, sometimes fires right back up, other times will take several cranks, smell gas fumes, and sometimes seems to blow excess back out of the intake!? Seems by popping it in neutral sometimes will save it from stalling. This happens once - several times a day. Located vacuum leak at Speed control servo (note: cruise no longer works)
Oddities:
1.Sometimes hear clicking in or near glove box (relays?) 2.Lights alternate flashing/horn. Once or twice while driving, several times late at night just sitting in driveway. 3.Radio will not lock on a channel, but cycles continuously. 4.Fog lights short out (when wiggle the headlight switch assembly, dash dimmer, or in auto position) 5.Transmission would not engage and/or sluggish (2 or 3 random times in last winter, 2010 but not since)
Concerns:Aftermarket alarm system or headlight switch may be faulty, if it is found to be cause of cutting off engine I would like it completely removed from vehicle and put back to stock OEM alarm.
I believe of all the parts replaced, and yet stalling remains, points to: faulty alarm system, possibly ground points, ignition switch, IAC, relays… I don’t know.
Keeps tripping code: PO108, MAP BARO circuit high and PO351, A Primary/Secondary Ignition Coil Malfunction.
What causes these codes to trip at time of bucking/shuddering/backfiring/ stalling?? Otherwise, a great running Jeep, strong motor, and smooth ride… I need the stalling fixed as it is VERY dangerous to drive.

Tell me when this thread is updated:

Subscribe Now Add to my Tracker

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Mesa Discussions

Title Updated Last By Comments
New recorded gangs in Arizona.... (Jun '07) 2 hr drdee 1,948
how many nurses have had lost there license bec... (Aug '07) 11 hr 31 years an RN 2,207
Powerful Lobbying firm to host fundraiser for L... 13 hr Henu 7
Arizona Woman Dies From Traumatic Head Injuries... Fri failHard 1
Tempe Music Thread Thu Musikologist 1
East coast mobusters in east valley Dec 16 ajay1974 4
Jimmy Merle Vañater A.K.A. James or ltaly Dec 16 Concerned for oth... 1
Mesa Dating
Find my Match
More from around the web

Mesa People Search

Addresses and phone numbers for FREE

Mesa News, Events & Info

Click for news, events and info in Mesa

Personal Finance

Mortgages [ See current mortgage rates ]

NFL Latest News

Updated 11:57 am PST

NBC Sports11:57AM
Ryan Lindley will start regardless of Drew Stanton's status
NBC Sports 1:25 PM
Philip Rivers is probable, but Allen and Mathews out
Bleacher Report 1:34 PM
Hyde and Borland (Ankles) Ruled out vs. Bolts
NBC Sports 3:32 PM
Seahawks road favorites over Cards on SNF - NBC Sports
NBC Sports 4:01 AM
Chargers say Philip Rivers's injuries won't affect him today