HP Photosmart 2575 All in One Scanner...

HP Photosmart 2575 All in One Scanner Problem/Error

Posted in the Hewlett Packard Forum

First Prev
of 3
Next Last
Milosz

Devizes, UK

#1 Oct 7, 2007
Hello
I got HP Photosmart 2575 All in One and I am having some difficulties with the scanner. The problem is that it seems like the scanner in the printed is not detected. Funny thing is that I can us ethe copy option which scans the documents and prints it but "Scan to" option is not avaible anymore. If I go to my HP Digital Image Monitoring software and click on either "Scan image" or "scan document" I get this error window : "An error occured communicating with the scanning device. Please ensure that the scanning device is connected properly and try again.". Yes it is connected properly, witha proper USB cable in a proper USB port 2.0. I can print files properly. So the printer works. The other thing I noticed was an Network Icon "wired network - no connect" which wasnt there before. I dont know if this has sommething to do with the scanner problem but anyway.
Scanner worked before now it doesnt. I went to restore factory defaults but still nothing. I even reinstalled all HP drivers and software and installed it gain.
This is my Second printed from HP, first one broke which was a previous model. Now this one seems to be breaking.... I am not a type who breaks thing I take care of my equipment with most care possible, I dont like things breaking and getting them back to store.

I would really love to get this problem fixed soon as possible and any help would be usefull.

Thank you
Milosz
Robin

Gwinn, MI

#2 Dec 19, 2007
I have the same problem. Did you get it fixed?
nete

Tampere, Finland

#3 Feb 26, 2008
I do have exactly the same problem. It is really funny that it can't detect the scanner although earlier it could and everything was fine. Then one day, PUFF! Nothing. It says only that I should put some option on but I can't figure put that from where.

This is sad since the biggest reason for this was that i needed scanner.
Jill

Aberdeen, UK

#4 Apr 6, 2008
Am having the same problem the HP photosmart software recognises the printer as a printer and can print of images but can't recognise the scanner. The scanner shows up in control panel devices but on the software it can't be found. I am using an all in one F380. Its really strange I don't think the automatic updates on the software are working either as every time I request it nothing happens.
amy

Colchester, CT

#5 May 27, 2008
I am having a problem where the screen is black. I can't see anything. Any suggestions? It has been like this for about 3 months
amy

Colchester, CT

#6 Jun 12, 2008
MY SCREEN IS BLANK ON MY HP PHOTOSMART 2575 ANYONE KNOW HOW TO FIX THAT?
Frank

Caplan, Canada

#7 Jul 21, 2008
Exact same problem here, still searching. Scanner worked fine till a couple of weeks...now I cant scan from computer but I can print. I can also copy directly from the unit so the scanner hardware works. Seems like a driver problem?
len

Klamath Falls, OR

#8 Jul 23, 2008
my scanner is leaving a black line going diagonal on the paper. is there any way to fix that?
Johan

Amsterdam, Netherlands

#9 Oct 29, 2008
If you are using the printer by ethernet or a router, it is easy to fix the problem. Reset to factory settings, note the given IP address, and enter it in your computer or router. I don't know if this solution works also for the USB port, but you may give it a try...
Emily

Mount Laurel, NJ

#10 Jan 27, 2009
hi mine had a similar problem, and I simply went on the the HP website (I had an HP Photosmart 2575 All in One) and downloaded the software again. It is now better than before. it was also the same in the way it was working one day, and broken the next. Somehow the installation had been messed up, and I had to fix it. The CD did not work, but the website did. Good Luck!
Lena

Midway City, CA

#11 Jan 30, 2009
Hey, I have the exact same problem with my printer where i need to copy it in order to scan it. Unfortunately, it also printed the document and does not give me the choice of forwarding the scanned copy onto someone else.
Jan

Mijdrecht, Netherlands

#12 Feb 6, 2009
I have the exact same problem, but deleting the software and re-installing doesn't give me the solution... anybody else?
Mac

Cedar Falls, IA

#13 Mar 11, 2009
I have the HP 2575 also and attempted to copy a page today. I got a blue screen error: 0x07674dd6 and 1895:lib_barracuda.c The printer is frozen and I cannot get rid of this error. I have tried shutting off & turning it back on but the printer is still frozen. Any ideas?
Eric

Flint, MI

#14 Jul 30, 2009
Need help with "carriage is bloced" or "carriage won't move" error messsages. This carriage hoolds the print cartridages. It went kaput all at once.
Johnson

Camberley, UK

#15 Nov 7, 2009
Having the same problem with scanner on Hp photosmart 2575. printing and photocopying is fine, but when selecting 'start scan' on the printer it says 'refer to device documentation to torubleshoot'... any ideas what to do?
TA-spokane

Spokane, WA

#16 Dec 10, 2009
yep same thing, think I'll try to download from web site a reinstall.
aja

Trenton, NJ

#17 Dec 24, 2009
I have this problem too. First I clicked help and disable all smart friends. Then I put usb connect to other place with 2.0 speed.
MMP
#18 Mar 2, 2010
I have an Hp 2575 all in one printer. My problem is that whenever I copy something I get a half inch solid black vertical line down the left side of my page. My scanning and printing from the computer are fine. I have cleaned the glass, ran the test pages and don't know what to do. Can someone help please.
tom

Plymouth, MN

#19 Jun 30, 2010
e: Photosmart c4280 error "usb not connected"
Options
06-30-2010 08:46 PM

Here is a work around

OK Folks, the HP software does not work with Snow Leopard.

If you use the Preview program from Apple it should work fine in preview to scan it to PDF or Jpg... at least it does for me. I couldn't save it at first and selected it and opened pages and then chose the save function from preview and it worked fine. There are hundreds of postings about this problem on other tech forums, It's a Shame the HP people haven't figured out yet they have a problem...They of course already have our money and are making new scanners that work with Snow Leopard. I'll be impressed if they fix this problem, it's been out there a while.
Tom
tom

Plymouth, MN

#20 Jun 30, 2010
I also found this... I can't verify if it will work with the New Updates on Leopard OSX
Re: Photosmart c4280 error "usb not connected"
Options
05-06-2010 03:33 AM

This message when you press the scan button means that the HP software is not installed or not working properly.

Check for a Hewlett-Packard folder in Applications. If the folder is there, run the HP Uninstaller program.

Now download the software package for Mac 10.4 from here:

http://h10025.www1.hp.com/ewfrf/wc/softwareDo... ;...

When the software is downloaded, install it.

Tell me when this thread is updated:

Subscribe Now Add to my Tracker
First Prev
of 3
Next Last

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Hewlett Packard Discussions

Title Updated Last By Comments
News HP to cut 11,000 to 16,000 more jobs (May '14) 8 hr Human 110
News Pick for Medicare post faces questions on India... Feb 15 RustyS 1
News Reward offered in rash of burglaries (Sep '09) Nov '16 nairy 41
Computer and laptop can't recognise HP Photosma... Aug '16 tamsin28 1
News A Look at the Linux Foundation's Collaborative ... (Aug '16) Aug '16 Kevin 1
Have U ever thought of buying a hidden camera? (May '12) Jun '16 Jason 4
News Ted Cruz to name Carly Fiorina as VP (Apr '16) Apr '16 Cruz 2016 7
More from around the web