capitan

Hollywood, FL

#43 Nov 4, 2010
Why does my 3406E pass oil to the respiratory system??
omar

Cairo, Egypt

#44 Nov 29, 2010
I want to buy oil cooler,excavator part,Komatsu part product you are selling, please contact me !
Rodney

United States

#45 May 7, 2011
I drive a 96 freightliner with a 3406E, was pulling a light load and the eng. warn light came on, the temp. went to 230 and I pulled over to inspect; when I popped the hood, there was sludge all over the motor and on the oil fill plug... was told the oil cooler was bad, and im trying to see what options my boss have, no steam from the stack and im stumped on what all has to be done to the truck...
fly

Chesapeake, VA

#46 Jun 26, 2011
Mechanic wrote:
The only 2 things that will give you this is either a bad oil cooler or a blown water pump seal.Depending on the amount of oil in the coolant is were it determines what went bad. Since you already changed the oil cooler it takes a while to get all the oil out of the coolant. you need to keep an eye on the oil level. if its going down and there is still oil in the coolant then your culprit is the water pump.
i had oil going into radiator on my 3406e,caterpillar pressurized engine found nothing,i changed oil cooler then ran it for good distance and now i have water in oil, what gives
Sid

Calgary, Canada

#47 Jul 10, 2011
I have oil in my coolant system and there also looks like i have cooland in my oil. I have a green gel looking substance on my coolant resivour cap. I am also getting the same substance coming out of my blow by and steam is coming out of my oil filler tube. The antifreeze level is down my oil pressure is slightly above normal. the oil level seems to be normal and no signs of coolant on my dipstick but i dont know why steam is comong out of the oil filler tube I have no idea whats going on any ideas anyone
Sid

Calgary, Canada

#48 Jul 26, 2011
Turns out it was the oil cooler changed it and everything is fine
john

Pittsburgh, PA

#49 Aug 12, 2011
if it is fuel in the coolant,
couldnt that be the injection cups in the head leaking? i had to have mine replaced once.
Nick

Brooklyn, NY

#50 Sep 17, 2011
Im havin the same problem as Sid posted on june 10, 2011 after a valve adjustment (cat acert c15 mxs).. Hey Sid was the oil cooler the only problem?
Sid

Calgary, Canada

#51 Sep 19, 2011
Yes Nick the oil cooler was the only problem changed it and did a coolant flush and a fresh oil change and everything was fine.
luis

Union City, NJ

#52 Sep 30, 2011
you see oil in coolant system you have need check heat 100% need new one
DJW

Laconia, NH

#53 Dec 2, 2011
If you have the old style cam sensor, pull it. The tip is a plastic plunger. If it got pushed in you wont get cam signal and injection will be disabled. Pull the plunger out and reinstall. (Old style sensor only)( New style is shimmed)
TruckerDave

Blairstown, NJ

#54 Feb 10, 2012
Mechanic wrote:
The only 2 things that will give you this is either a bad oil cooler or a blown water pump seal.Depending on the amount of oil in the coolant is were it determines what went bad. Since you already changed the oil cooler it takes a while to get all the oil out of the coolant. you need to keep an eye on the oil level. if its going down and there is still oil in the coolant then your culprit is the water pump.
Are you saying a water pump seal on a 3406E can put oil in coolant?
dean

Fairmount, GA

#55 Apr 2, 2013
i have c16 with oil in coolant changed oil cooler still have oil in coolant

“Cat & Cummins ECM programs”

Since: Jun 12

Marion, IN

#56 Apr 4, 2013
dean wrote:
i have c16 with oil in coolant changed oil cooler still have oil in coolant
How well did you "clean" the cooling system after replacing the oil cooler? All the hoses, tubes & heater cores become coated with oil when coolers fail. We fill the engines with plain water & add a bottle of Dawn dish soap, the let them run for a couple hours outside to "wash" the cooling system out. Drain the water, refill with clean water, run it up to operating temp so the thermostats open to flush all the hoses out. Then drain the water, refill with antifreeze mix & add a bottle of Nalcool.

There aren't many places for oil to get into the cooling system, without the coolant mixing back into the oil system. You've already changed the part that fails the most. Since oil is at a much higher pressure than the coolant, it can force it's way into the cooling system, usually inside the oil cooler. Sometimes the oil gets past the internal seal on the water pump, but it's a rare occurrence. The only other place would be the head or head gasket, where oil is under pressure and can "force" it's way into the coolant.

You have no signs of coolant in the oil? How much oil are you adding to the truck?
Dale

Sunset, LA

#57 Jul 11, 2013
how to tell if it oil cooler or water pump causing oil in raditor
raymond foster

Summersville, WV

#58 Sep 19, 2013
I have 1999 kenworth with a cat what is arattick injector balance

“Cat & Cummins ECM programs”

Since: Jun 12

Marion, IN

#59 Sep 20, 2013
raymond foster wrote:
I have 1999 kenworth with a cat what is arattick injector balance
??? I don't understand your question, sorry :-(
J Hill

Wills Point, TX

#61 Oct 17, 2013
I have a 86 Pete with 3406 b-model. I found oil in my radiator. And water in my oil pan. Lots of white smoke coming from stacks. I assume I have a blown head gasket. Could this cause the oil in my radiator??
Ken

Marion, IN

#62 Oct 18, 2013
J Hill wrote:
I have a 86 Pete with 3406 b-model. I found oil in my radiator. And water in my oil pan. Lots of white smoke coming from stacks. I assume I have a blown head gasket. Could this cause the oil in my radiator??
Yes, it could. It may be the head gasket has failed, the head has cracked, or a cylinder liner has a crack or hole in it. You won't know for sure until you tear it down.

I would leave the coolant in it, drain the oil & drop the oil pan. Then I would connect a "blow-up kit" to the radiator & pressurize the cooling system. You will then be able to see where the water is leaking into the oil before you pull the head.
rick

Mount Vernon, WA

#63 Jan 7, 2014
adjust sensor turn all the way in and back it off one turn

Tell me when this thread is updated:

Subscribe Now Add to my Tracker

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Caterpillar Discussions

Title Updated Last By Comments
Increase maximum RPM in C15 Sun SuperTruck 1
water leaking out of radiator cap (Jul '11) Sun P_SELVAM 7
Cat engine 3126 (Oct '06) Jan 24 mullins2014 680
how to hack caterpillar ecm (Nov '08) Jan 21 davewilson 48
Caterpillar C15 Engine TPS error code (May '09) Jan 21 junktrucktrucking 56
6 nz Jan 19 dan 1
Roll coal in c12 &c15 Jan 18 Cavill 1
More from around the web