Cat engine 3126

Since: Jul 08

Location hidden

#105 Jul 16, 2008
Mark Evans wrote:
<quoted text>
I have a no start cat model 3126. Dope it and it runs and performs well. Starts sometimes without "help". No access to engine service manual. Any help would be appreciated.
Are there any active faul codes present? you could be a little more specific. you could have low actuation pressure. Mileage?
Wilson

Sandersville, GA

#106 Jul 26, 2008
I bought a 3126 cat 300hp. I'm going to put it in a truck and need to know what I must do to just let it idle to check the engine out. It is not in the truck. I can hook the turbo through the cooler and back to the engine intake. Connect the fuel up and fill the engine with water and anti freeze and connect out to the return. I just want to run for a few minutes (2 or 3 minutes). Where do I hook the electrical up to the control bos (computer). I can hook the starter up and get it going with power on to the starter lug.

Since: Jul 08

Location hidden

#107 Jul 26, 2008
Wilson wrote:
I bought a 3126 cat 300hp. I'm going to put it in a truck and need to know what I must do to just let it idle to check the engine out. It is not in the truck. I can hook the turbo through the cooler and back to the engine intake. Connect the fuel up and fill the engine with water and anti freeze and connect out to the return. I just want to run for a few minutes (2 or 3 minutes). Where do I hook the electrical up to the control bos (computer). I can hook the starter up and get it going with power on to the starter lug.

you need to build a wiring harness to power up the engine ECM (electronic control module). i need the engine serial number in order to tell you the correct pins. also you need the correct socket connectors in order to couple the wires to the ECM pins.
George

Sharpsburg, GA

#108 Jul 27, 2008
I have a 3126 cat engine. In the morning it is very hard to start but once it does it takes a long time to warm up. has hesitation plus sluggish power any ideas
R L Edson

Temple, TX

#109 Jul 28, 2008
I have a Caterpillar 3126B engine in a FL-70 Freightliner truck, chich won't start. Was running fine 2 weks ago. Spins over good but no start. The first component downstream from the fuel tank is the water separation filter and it has no fuel in it. This leads me to believe there is some sort of restriction, OR whatever method Cat uses to get the fuel from the tank, thru the filter, then to the injector pump, may have failed. Does this system use suction from the injector pump or is there an electric or manual assist pump?

Since: Jul 08

Location hidden

#110 Jul 29, 2008
Indeed sounds like your tank suction line has a restriction of some sort. or there's an air leak on your suction line, which would cause the fuel to drain back to the tank after running the engine. at first you should check that all fuel suction line connections are tightened and sealing properly. replacing the o-rings is recommended. if the connections are ok then you could apply a little pressurised air on the suction line to blow the possible restriction back to the tank. when doing this remember to open the tank filler cap first. the third possibility is that you may have a broken transfer pump shaft. the fuel transfer pump (the small unit where the fuel suction line and the pressure line (other end connects to the cyl head side) connects to) is located at the rear of the actuation pressure pump (HEUI pump), and is driven by the HEUI pump shaft. unfortunately some 3126B's, depends on your engine configuration, dont have any serviceable parts for the pump so in worst case you need to renew the entire transfer pump. the engine should also have a manual priming pump, located on the filter housing. hope this helps, good luck!
andt

Basseterre, Saint Kitts and Nevis

#111 Aug 7, 2008
i have a 3126 thats hard to start in mornings have to dope it to start when start it misses untill it clears up then run with a slight miss when accelarate ichange all filters blow out fuel lines and ck for leaks every thing seem to be alright please help me
CCF

Meadville, PA

#112 Aug 7, 2008
Hello. Ihave a 99 Sterling witha 3126. The problem is it will run fine then just go into a limp mode and engine light comes on. Sometimes it will just start working fine again or you must turn it off and start it back up and it will run again fine. It has flash codes 15 and 19 which are both injection actuation codes. Any ideas?
calvin branch

Wanganui, New Zealand

#113 Aug 12, 2008
have a kenworth with cat electronic engine which runs very hot.rad cleaned out and flow checked,all ok. anyone got ideas
michael illis

Philipsburg, Sint Maarten (Dutch part)

#114 Aug 12, 2008
Brian wrote:
I can help you with info on CAT 3126's, please contact via email- [email protected]
<quoted text>
hi sir we are experiencing some problems with our 3126 cat engine it all started out with hard starting now it is not starting anymore can help with this problem sir

Since: Jul 08

Location hidden

#115 Aug 16, 2008
andt wrote:
i have a 3126 thats hard to start in mornings have to dope it to start when start it misses untill it clears up then run with a slight miss when accelarate ichange all filters blow out fuel lines and ck for leaks every thing seem to be alright please help me
i suppose your engine is mechanical right?
you could be having a faulty injector. it's been like that since when? did it have any service to the valvetrain then? does the engine have excessive blowby? when the engine missfires it smokes white right?

Since: Jul 08

Location hidden

#116 Aug 17, 2008
To all recently posted:
Please try to describe the symptoms you're havin in more detail. like under what conditions (rpm, coolant temp, under/off load, etc...) the symptom occurs. also you could mention the tests you've allready tried to discover the cause. mentioning all such things might speed up the answering process.
len

Truro, UK

#117 Aug 19, 2008
i have a c12 2003 cat which smokes(blue) when pulling away,also has oil dripping from exhaust (after turbo) any ideas .i have changed the valva stem seals this had made no difference
len

Truro, UK

#118 Aug 19, 2008
oh also engine is a 450 bhp model and has done 430000 kms has always been fully serviced and has never missed a beat,is in a eight wheel tipper truck please help

Since: Jul 08

Location hidden

#119 Aug 19, 2008
len wrote:
i have a c12 2003 cat which smokes(blue) when pulling away,also has oil dripping from exhaust (after turbo) any ideas .i have changed the valva stem seals this had made no difference
as i see it, there's only two options that may cause this... either you have a leaking turbo shaft seal, which i believe is causing this, or you have a severely damaged cylinder. since you didnt mention you'd be having a rough running engine or misfiring i believe the problem is the turbo.

the quickest method to make sure is to remove the exhaust coupling from the turbo outlet and check if there's any drain or spatter marks of oil downwards from the turbo shaft. if there's no visual signs of marks of drainage, the oil originates from the cylinder(s). hope this helps. please let me know the results.
viperbluelx

Dalton, GA

#120 Aug 20, 2008
We have a 99 Chevy 6500 with Cat 3126. It started to surge at idle but never stalled. We had to shut it off and it hasn't started back since. Is there a way to manually retrieve the codes and read them by check engine light flashes? We were told that was possible through the cruise control switches but it doesn't have cruise.
turbo

Brooklyn, NY

#121 Aug 22, 2008
Stevie wrote:
I work in a corp fleet department every 3126 we have has giving us problems they has giving us job security. I need some info on the wiring and fuel systems. I have one that will start on either and run at 1000 R.P.M but goes dead at anything under [email protected]
first thing I would check is any fuel restrictions,blow out your fuel line from water seperater to tank and remove and clean bottom bowl on seperator . If that fails you than you probably need an injection control pressure valve (ICP) ITS LOCATED AT THE HIGH PRESSURE OIL PUMP AND LOOKS LIKE A STARTER SOLENOID
turbo

Brooklyn, NY

#122 Aug 22, 2008
I just started an IN-FRAME ON A fl70 W/ A 3126
WHEN i PUSHED UP THE PISTONS EVERY TOP COMPRESSION RING SNAPPED IN HALF "is this common" This is my first 3126 non-sleeve eng rebuild
and would also like to know if you have to Hone the cylinders"they all have a vertical groove about an eight of an inch wide,its not deep ,but you can feel it.note if your reading this the engine had 135,000 miles ,low comp,burning 2 quarts of oil in 100 miles and serious blow-by
turbo

Brooklyn, NY

#123 Aug 22, 2008
John wrote:
I have a 2000 fl60 with a 3126 cat engine
it uses about 1gallon of oil every 100 miles
no one can tell me what to do.
Cat said it would be about 2000.00 to 6000.00
to fix ? Help Me Please
Cat tested the injector in the truck tested OK
replaced the injector orings slowed down a little but using 1 gal every 100 miles mooe when working
Thanks John
pull out your dipstick , is it blowing smoke in your face with eng. running, do you have blow-by?
excess blow-by in the 3126 is almost always caused by oil burning through bad rings and creating excessive crankcase pressure I am currently rebuilding a 3126 with the exact same problem, excess blow-by and high oil consumption w/135,000 miles on it , go figure. some of these 3126 engines are great and some are not. They do keep me busy in the shop.

Since: Jul 08

Location hidden

#124 Aug 23, 2008
turbo wrote:
I just started an IN-FRAME ON A fl70 W/ A 3126
WHEN i PUSHED UP THE PISTONS EVERY TOP COMPRESSION RING SNAPPED IN HALF "is this common" This is my first 3126 non-sleeve eng rebuild
and would also like to know if you have to Hone the cylinders"they all have a vertical groove about an eight of an inch wide,its not deep ,but you can feel it.note if your reading this the engine had 135,000 miles ,low comp,burning 2 quarts of oil in 100 miles and serious blow-by
yes you need honing. every time you replace any piston rings you need to hone first. hard honing is recommended at this point when you can feel the grooves. hard hone it within the spec first and then finish the surface with flexhone. i cant tell why all top rings failed though...

Tell me when this thread is updated:

Subscribe Now Add to my Tracker

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Caterpillar Discussions

Title Updated Last By Comments
oil in water catpiller c15 acert (Apr '09) Fri Dewman 71
cat c15 motor - coolant circulation problem (May '11) Thu Brigida 46
Fuel pressure /miss Thu Robert 1
3406 serial number location (Aug '08) Dec 7 sara 32
Greyish green sludge everywhere Dec 6 Camohunter0330 1
cat 320 hyd problems (Sep '09) Dec 6 Jonathan paloma 60
cat 3406e diesel specs (Feb '07) Dec 5 wtrackerman 134
More from around the web