Cat engine 3126
Per

Linköping, Sweden

#464 Mar 7, 2011
IAP= injection actauation pressure, ECM thinks the oil pressure to the injectors aren't what it demands.
It could be a bad high pressure pump,solenoid, sensor, or a leak in the system.
You really need to hook it to a computer to check it out.

Fuel filters can't affect it.

You squeeze a small tab and pull to release connectors.
The IAP sensor is located next to to valve cover near the front, 3pole brown,green,white
trashman77

Commack, NY

#465 Mar 11, 2011
i have a 1998 cat 924f 4 cyclinder pay loader. i have an revolving issue with a fuel problem. first off the fuel im using is excellant red dye for off highway use. i've changed the fuel filter, all rubber and steel lines going to and from the fuel tank, injection pump, pressure regulator valve, i even had the injection pump itself rebuilt. the engine still loses a prime when it shuts down. It had a separate priming pump but recently it started to leak so i tried to replace it. Caterpillar told me its been discontinued, so i had to use a retrofit block off part from cat. now i cant even prime the system to start. when i do get engine to run its strong and has no smoke (probably because of rebulit injection pump. anyone one have a solution, before i set it on FIRE...
Gclein

Fenton, MI

#466 Mar 11, 2011
2000 C7500 chevy Cat 3126 towed in for no start hook up laptop with ET using nexiq magickey to communicate engine runs remove ALDL connector from under dash engine dies reconnect it runs again upon further research only the nexiq magickey box need be hooked up to make truck run (unplug laptop truck will still run)ET says ECM volts KOEO 12.9 KOER 11.6 Dash reads 14 dvom at batteries is 13.88 obvious voltage drop to ECM is there a common ground or powerv wire i should look for I have no wiring diagrams for this truck so after all this im flying blind
Scott

Galesville, MD

#467 Mar 15, 2011
The truck I'm working on is a 2003 sterling with a Cat 3126, serial number HEP23039. The truck has 15,751 miles and 2155 HRS. The issue is, it cranks, but will not start. The only symptom prior to the problem was an occasional miss at idle. Both fuel filters have been changed and there seems to be good fuel flow out of the of the bleed vent on the upper filter when cranking the engine.
Jrepp

United States

#468 Mar 19, 2011
steve rober wrote:
I'm having problems with a cat 3126. It is an oil use issue. It's fine and then about half way to oil change it uses a gallon of oil almost overnight. Any suggestions are welcome.
Steve, had the same prob. Injector replaced and was fine for a while then came back. Turned out one injecter was bad from manuf... replaced that one and prob solved. G,luck
Jrepp

United States

#469 Mar 19, 2011
Here we go. I get an engine light and the protect feture comes on at about 3000 miles after oil change. Sometimes sooner sometimes later. Speed drops light goes out and I roll on. Happens a few times an hr more or less. Seems to happen more at lower speeds. Sparatic at first then persistant as time goes on. Injectors are new and our michanic just can't figure it out. Says its a short or oil contaminated. Using rotela at speedco. AND WHY IS IT SO HARD TO FIND A GOOD MECHANIC IN OHIO! They break more than they fix!
steve28

Canada

#470 Mar 19, 2011
I do have problem with my GMC truck 2000 model with cat engine 3126b.difficault starting in the morniny but if i pluge it on a power over night ,no proble starting.
steve28

Canada

#471 Mar 19, 2011
can any one tell me what the problem is or do you have cat 3126b nozzle or heui pumpe
Ted C

Chicago, IL

#472 Mar 22, 2011
eric wrote:
i have a 3126 cat in a forestry truck.problem is i am losing oil, cannot see any visual leaks and no smoke out exhaust. any suggestions?....ive gone thru 6gal of oil in 1 1/2 weeks
It is on or more of your Injectors! I know but my cat did the same thing.
andrew smith

Chepachet, RI

#473 Mar 23, 2011
98 cat 3126 codes 253 and 022 elapsed time and ext crank blow by pressure out of calibration changed ecm and still same problem any answers
steve28

Canada

#474 Mar 24, 2011
any body know why my GMC truck with (heui)3126b cat engine problem.It never start but if I plug it in for 8 hours it start and run very well.I have being to cat company many time with the same problem I end up with much bill from them.
Lewis

Bend, OR

#475 Mar 26, 2011
I am parting out a 2000 3126 serial # 8YL50090 250HP Hi Torque. Many good parts, and a few bad ones.
Good Ones:
HEUI Pump
ECM
5 Injectors (one bad one)
Block, and Crank
5 good pistons and rods,(one bad one)
Air Compressor
Valve components
Turbo Charger & manifold
Pac Brake
Contact me at [email protected]
iceman1956

Elizabethtown, NC

#476 Apr 18, 2011
I have a 2000 FL60 freightliner cat engine 3126. Want start without spraying it ,no power, be going down the road running 70 mph all of a sudden it will cut back to an idle and start running about 10 mph for maybe a mile or might even go ten miles and all of a sudden it will pickup speed and take off again. anyone have any ideas on this problem.
towangel

Virginia Beach, VA

#477 Apr 20, 2011
Rich wrote:
I am in the same market. I am looking at a Kenworth T300 'bobtail' truck. It is a 2002 Cat 3126 and it has an Allison 3060, six speed auto trans, 4:63 rear end. They rate the motor at 275 hp. I need to pull a 12,000 pound trailer (not 5th wheel). Do you think this cat has enough to do it> I am presently using a 2500 Dodge with a 5.9 cummins,,,,,,I am really putting the hurt on it.
Ihave a T-300. It will pull good downhill.
Lewis

United States

#478 Apr 21, 2011
I pulled a 10,000 lb trailer for 200,000 miles behind my FL70 with a 250 HP 3126 Hi torque 800 ft.lbs. CGVW was about 37,000 lbs. The trailer made little difference. These engines are under powered but it will do the job. Your 275 HP has 860 ft. lbs of torque and should do a little better job. I just installed a 330 HP / 860 torque, and am looking forward to maybe going up the pass a little faster!
Brad

United States

#479 May 4, 2011
I have a 1999 Sterling with 9000hrs a 3126b engine. At times when I am driving the truck looses all engine power with no warning signs. Sometime the truck will restart back up other times it will not. When the truck won't start I do not have my engine warning light and wait to start light displayed on the dash. The truck has no power issues when running, it's either on or off. Any ideas or help with a possible solution to this issue would be appreciated.
Tom Towing

Anchorage, AK

#480 May 18, 2011
Rich wrote:
I am in the same market. I am looking at a Kenworth T300 'bobtail' truck. It is a 2002 Cat 3126 and it has an Allison 3060, six speed auto trans, 4:63 rear end. They rate the motor at 275 hp. I need to pull a 12,000 pound trailer (not 5th wheel). Do you think this cat has enough to do it> I am presently using a 2500 Dodge with a 5.9 cummins,,,,,,I am really putting the hurt on it.
the Cat has more then enough power but the Allison trans suck I had one in my Rollback wrecker with a small car on the back it was hard to pull a hill
captcjp

Marrero, LA

#481 May 20, 2011
I have cat 3126 that will crank but will not start flash code on check engine light is 39 fuel actuation pressure system fault can any body help??
Hap Queen

Waynesville, NC

#483 May 31, 2011
i have a problem with my cat 3126 1998 modle. truck wont start replaced huey pump and replaced all injetcor o rings.still can not get fule truck will not run if you have in idea email me at [email protected]
wayne d

AOL

#484 Jun 7, 2011
i have a c7 3126 freightliner just changed cups due to diesel in coolant, know it runs rough at idle blows white smoke no active faults just critical logged event injection actuation pressure flash code 39 could this sensor or valve make this run like that or did they miss some injector failure

Tell me when this thread is updated:

Subscribe Now Add to my Tracker

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Caterpillar Discussions

Title Updated Last By Comments
3406E Engine prefix is 6TS Thu Philip Pitre 1
cat 320 hyd problems (Sep '09) Wed hunter 46
cat 3116 engine fuel filter runs dry and engine... (May '12) Aug 31 scoutman 91
2002caterpillar Aug 28 jim 1
cat 311 fuel pump problem Broken bolt Aug 26 Alex 1
3406 serial number location (Aug '08) Aug 25 Happy 28
Cat 420d backhoe Aug 24 Brad 1
More from around the web