Cat engine 3126
JAMES

Youngstown, OH

#335 Jan 1, 2010
also my 3126b only carries 15lbs at most of oil pressure @ idle when @ operating temp
alex

Far Rockaway, NY

#336 Jan 4, 2010
I have a cat 3126 1999 on a school bus. its starts but when u put it on drive the engine shakes anybody has an idea whats wrong..
Jason

Mount Laurel, NJ

#337 Jan 6, 2010
I have a 2000 FL70 with a 3126 Cat. Recently the fuel tanks needed to be replaced due to serious Rot. After replacing the tanks, i was wondering what needs to be checked in order to be sure that the tanks rust did not infiltrate and contaminate the entire system. I am sort of a rookie, so as much detail would help. I'm not sure if it is an a or b model. but I will find out. you can e-mail me at jtryan21@gmail.com and i will get all information and help directly to my phone!

PLEASE HELP!!! Don't have the money for another shop Bill
TRUCK TECH

Livonia, MI

#338 Jan 21, 2010
THIS 3126 IS IN A GMC 8500 2000 I UNPLUG THE ECM AND PLUG IT BACK IN IT WILL START AND RUN FINE FOR ABOUT 2 MIN THAN DIE..... I NEED HELP!!
Tim Kress

Redondo Beach, CA

#339 Jan 21, 2010
we have a 2001 FL70 with a Cat 3126 which we purchesed in 2007. I can't even begin to tell you how much we've spent on repairs. Since we've owned it we've replaced the injectors --TWICE-- Cat wouldn't stand behind any warranty. Just recently we've replaced the high pressure fuel pump and the turbo. We are still experiencing intermittent power loses and no one can seem to figure it out. My mechanic says there are no codes coming up so he figures it must be mechanical.
Does anyone have any ideas? We run a fleet in Southern Calif. and do our maintanence on a regular basis. We gone to changing the oil on this truck every 7 -8000 miles.
This engine is the biggest piece of junk I've ever owned. I don't think it would even make a good boat anchor. I'm at my wits end.
If you can be of any help, please e-mail me back at tim@kressxpress.com.
Appreciate your time.
Jerry

Henderson, NV

#340 Jan 31, 2010
My 3126 is using oil. About 2 qts every 3500 miles. Everyone says its the HEUI pump. Wheres the pump mounted and can I change it myself? Truck starts and run excellent with alot of power.
JORGE JASSO

Chicago, IL

#341 Feb 2, 2010
I HAVE HAD A 2000 F650 WITH THE 3126 I TOOK OFF THE BED, SHORTENED THE DIFFERENTIAL AND INSTALLED A FIFTH WHEEL TO PULL A TRANSPORT TRAILER WITH 4 CARS ALL OVER THE USA AND I WOULD NOT GET ANYTHING ELSE !!! HOWEVER, I SPEND MY MONEY ON THE BEST OILS AND ADDITIVES FOR MY TRUCK, WHEN I AM HOME FOR A COUPLE OF DAYS I DRAIN TILL THE LAST DROP OF DIRTY OIL AND GET OEM FILTERS.
Allan

Surrey, Canada

#342 Feb 8, 2010
Have a Daemon RV with a caterpillar, 1998, deisel engine, 275 horse power.....not turbo. Not able to find the oil sending unit location, can anyone help?
Wayne

Halifax, Canada

#343 Feb 10, 2010
CatTech wrote:
any electronic Caterpillar engine questions i can help
I have a98 fl80 with a cat 3126 that has a bad throttle delay. I would also like to know if the low oil pressure an high temp can be disabled as this is a firetruck
Wilson

United States

#344 Feb 24, 2010
I have a 1999 3126B cat engine. It is out of a motor home and I put it on an engine stand. No water in engine.It runs when it is warm, a mimute. but as it got colder it was harder to start. It got down in the 50s and it won't start. I got the codes. 15,17,39, 21,25,27. Checked what I could. Got 5 volts and all sensors that 5 volts called for. There must be something when it gets cold that is causing the problem. I'm thinking of ether to see if it will start. Disconnect heater and shoot a little in to see if starts. I'm told by cat that ether isn't necessary till freezing. Can you help.
Meridian1

Schenectady, NY

#345 Feb 25, 2010
Just purchased a 2000 CCC garbage truck with a CAT 3126. When we went to check it out the first time, diesel was mixing with the coolant and spraying out of the radiator cap along with a severe lack of power. Mechanic at purchasing location changed injectors, cups, and O-rings, flushed system and changed all filters and fluids. Now, after driving truck 900 plus miles home, appears to be burning anti-freeze constantly. So, what is the cause?? Head gasket?? Cracked head??
Austin

Spring Hill, FL

#346 Mar 16, 2010
We have a 1997 (3126) were their any recalls on that year or did the problems start after that year. The 3126 only caries 20 to 25 lbs oil pressuer when warm. We checked it with an external guage tap, Is this normal? 25,000 miles Thanks
witsonstt

Houston, TX

#347 Mar 28, 2010
where are the sensors on the 3126 engine
Rick

Bristol, VA

#348 Mar 29, 2010
2000 sterling with a 3126 cat, alllison auto, single axle truck. When driving on interstate and pulling a hill, engine warning light comes on and computer powers engine down to about 30mph. You have to cut engine off and restart to reset fault and takes off and runs normal again for another 5 or 10 miles then same thing all over again. Temp stays in 200 to 210 range, oil preasure is around 30psi, coolant fan is not kicking into high so I dont think its a heating problem. You can back out of the fuel as you progress up the incline and it wont fault out? I filled the colant bottle which was low when I got the truck and checked all the fuses, had one missing that read hot air intake and I replaced it but dont think that would have anything to do with this problem. I just purchased truck an drove it home so I dont know any history on it. It has 124,000 actual miles on truck and engine.?????
bpe

Marlow, OK

#349 Apr 1, 2010
I am working on a 2000 3126 out of a freightliner schoolbus. The engine had excessive blowby that smelled like antifreeze and the engine was missing. Pulled the head and did not find bad head gasket but #5 piston had no soot. No noticible water in oil but there was a fair amount of oil in the water. Not sure how oil got into the antifreeze. Could the head be cracked or is there something else I should look for.
pricky ricky

United States

#350 Apr 1, 2010
Wonder how much work in would be to replace 5.9 ltr Cummins With a 3126 cat in a dodge dually p/u?? Would it be a major pain in the a**!?!
Marc

Philadelphia, PA

#351 Apr 8, 2010
I have a 1983 Mack and I wanted to know if its possible or how hard it would be to put a 425 CAT motor in it.
you can email me at junebug6771@yahoo.com
THanks
tool guy

Tacoma, WA

#352 Apr 12, 2010
my 3126 engine bent 4 rods and i replaced them and it still runs like shit and has no exceleration
tool guy

Tacoma, WA

#353 Apr 12, 2010
my cat motor is putting out white smoke and iam not sure what the problem is any ideas
tool guy

Tacoma, WA

#354 Apr 12, 2010
has anyone have any sugestions what might have caused this to happen

Tell me when this thread is updated:

Subscribe Now Add to my Tracker

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Caterpillar Discussions

Title Updated Last By Comments
The new C15 acert engine (Jan '06) Mon Otrdriver2002 823
m315 Jul 4 simone 1
cat 3116 engine fuel filter runs dry and engine... (May '12) Jul 2 hfsmithjr 88
cat 3406e diesel specs (Feb '07) Jul 1 catmando 117
cat 320 hyd problems (Sep '09) Jun 24 Stephen Mwaura 44
Firmware Uodate?? Jun 23 Budlink 1
cat c15 motor - coolant circulation problem (May '11) Jun 23 Eddie32332 33
More from around the web