Annoyed

South Yarra, Australia

#1 May 21, 2009
I bought a secondhand Cox ride-on mower at 700 hours. Motor is 12.5 Hp Briggs & Stratton. After 17 Hours, broke conrod, counterbalance on crankshaft, the camshaft and damaged the sump. Mechanic who disassembled engine has no idea why. Oil was clean, not short of oil, and didn't overrev.Is this a common problem. Mechanic advises that rest of engine is in near perfect condition, rings OK, not burning oil. Now my Cox dealer who sold me this timebomb wants me to contribute to the large repair bill.
Does anyone know why an engine in supposedly good condition would self-destruct? These engines are supposed to be good for 1200 hours.

Tell me when this thread is updated:

Subscribe Now Add to my Tracker

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Briggs and Stratton Corporation Discussions

Title Updated Last By Comments
Can't find any I'D marks on my engine Oct '17 Christanner1 1
Briggs 11.5 HP Powerbuilt 210000 series vacuum ... Aug '17 AJP 1
Briggs 20 ho ohv intex Aug '17 Greywolf 1
8HP engine surges and the dies Jul '17 JohnDeere108 1
b&s motors Jun '17 jim 1
Motor stalls after running ten minutes. May '17 Woodsy 1
News Acton's longstanding shop for power equipment (Apr '17) Apr '17 Halton UK 1
More from around the web