ansys plugin error
First Prev
of 3
Next Last
johndoe

Alcalá De Henares, Spain

#1 May 23, 2009
Has anyone come across this error in workbench 2 (ansys 12 final)?:

Plugin error: Geometry interface not found.
Unable to attach to geometry file.

When I create some new geometry or import a step file everything works fine until I try to mesh it and apply the loads, then the error message pops up. It looks like the geometry is not attached to the simulation, so even the license is working the ansys workbench is unusable.
The problem is not related to the interface with external CAD programs because it also happens with its internal designmodeler geometry.
rdd

Mumbai, India

#2 Jun 14, 2009
same problem here.I guess it has to do with problem in running mechanical editor script in WB2.May be internet explorer settings have to be changed in advanced settings tab.So far no success .
Eric

Mannheim, Germany

#3 Jun 17, 2009
I have also the same problem. Does anybody manage to resolve it?
rdd

Mumbai, India

#4 Jun 20, 2009
The workbench works fine on one machine but I got that "Unable to attach to geometry file"error on another machine with a different configuration(chip,motherboard ,etc).ANSYS inastallation guide says if the workbench scripts are not able to run due to internet explorer settings or other third party programs(antivirus etc),the work bench won't work.

I set the same internet explorer settings on the two machines.The mechanical editor starts but the error "Unable to attach to geometry file" still appears!

Anyone found the cure for this ?
rdd

Mumbai, India

#5 Jun 21, 2009
Well, I found the solution to all problems of the kind:

"Plugin error: Geometry interface not found.
Unable to attach to geometry file.
"
be it with design modeler geometry or imported geometry from CAD programs.

You need to install the ANSYS as ADMINISTRATOR only.
Any other user even with administrative powers is of no use.

login as administrator and install the program.

In internet explorer settings,in advanced tab, tick mark the two tabs with "Disable script debugging".
Thats it! enjoy!
rdd

Mumbai, India

#6 Jun 21, 2009
If you still face problems,copy the geometry file to default project directory
C:\Documents and Settings\xxx\My Documents,
attach geometry and then refresh the project,and then edit mechanical editor.
ndim

UAE

#8 Jul 3, 2009
rdd wrote:
If you still face problems,copy the geometry file to default project directory
C:\Documents and Settings\xxx\My Documents,
attach geometry and then refresh the project,and then edit mechanical editor.
Can I ask you to have a look at my issue please,

hi,

I can't find all the analysis systems in the tool-box of the workbench, I can only find 3. Does any body knows why?? Also, whenever I start WB it pops an error "unable to connect to solver manager?"
jens

Erbendorf, Germany

#9 Jul 14, 2009
I have the same problem....

"I can't find all the analysis systems in the tool-box of the workbench, I can only find 3. Does any body knows why?? Also, whenever I start WB it pops an error "unable to connect to solver manager?""
blaufuch

Korea

#11 Sep 8, 2009
I solve that maybe..
um.. I try reinstall in administrator..
but didn't solved,
my case was only linebody in DesignModeler...
sorry~ My English is not good
In conclusion, project>>Geometry> >Property>>Check LineBodies, and Refresh Project, Update Project
please Someone refine this article.
will be help to my english study.
Do-NL

Rijswijk, Netherlands

#12 Oct 5, 2009
Yo
Maybe another solution of the attach geometry problem: you need an internet connection. In my case I received the error when internet is switched of, and when I turn on internet the problem seems to be solved.
CFX User

Edmonton, Canada

#13 Dec 31, 2009
Hi;
None of the above helped me out the problem.
Any more comments?
Thanks
Adam

Lodz, Poland

#14 Jan 6, 2010
I think this problem is somehow linked to .Net framework 2.0 sp 1 installation. This is one of ansys prerequisites. I tried to install the whole package several times and I always got the same error in the Ms .Net 2.0 sp1. Ansys seemed to be installed correctly but i couldn't import any geometry in WB.
I solved the problem in a very brutal but efficient way - I have reinstalled the whole system and now Ansys works perfectly.
I advise considering this solution.
jack

Dublin, Ireland

#15 Feb 10, 2010
just reinstalled it as had been done before and its now working.. search me.
Jake

Madison, WI

#16 Feb 26, 2010
I had the same problem. I turned off User Account Control during the install and that fixed the problem. Once ANSYS was installed, I was able to turn UAC back on and ANSYS worked fine.
johndoe wrote:
Has anyone come across this error in workbench 2 (ansys 12 final)?:
Plugin error: Geometry interface not found.
Unable to attach to geometry file.
When I create some new geometry or import a step file everything works fine until I try to mesh it and apply the loads, then the error message pops up. It looks like the geometry is not attached to the simulation, so even the license is working the ansys workbench is unusable.
The problem is not related to the interface with external CAD programs because it also happens with its internal designmodeler geometry.
Alberto

Brignoles, France

#17 Mar 26, 2010
rdd wrote:
In internet explorer settings,in advanced tab, tick mark the two tabs with "Disable script debugging".
Thats it! enjoy!
I installed Ansys on a virtual machine, with no access to internet.
...so, I fear I can't use your suggestion "disable script debugging".
What else can I do?
some1solver

New Malden, UK

#18 Apr 14, 2010
problems with geometric not found:
reinstall ansys 12 with geometric selected (lowest)>
tick the pro-e and nx, even if u dun hv it install>
nxt screen, tick d box tat say reconfigure later after intall workbench>install>done >
restart>problem solve>able2work wit geometric.

dun need2delete d license manager while reinstalling workbench.

~gud luck~
Murr_01

Aberdeen, UK

#19 May 31, 2010
I also have similar same problem. I started with ansys 11, upgraded to 12.0 both worked fine. Recently updraged to 12.1 when the problem started ERROR :AnsysWBU.exe encountered a problem UNABLE TO START THE MECHANICAL EDITOR. uninstalled Ver 12.0 and 11 no change. Now I can't reload any of these previous ver's, all come up with the same error. un-installed and Re-installed Ver 12.1 with admin rights and with antivirus uninstalled, Firewall switched off, changed graphics card driver to a previous version at ansys request. nothng fixed the problem. I'm running windows 7 64 bite on a gigabyte x58 extreme MOB with 12 Gbite ram an FX5600 graphics card, nothing else special. any further suggestings?
bob

Rosice, Czech Republic

#20 Jun 2, 2010
Hi Murr_01
I had same problem. After problem ansyswbu.exe is done by Enviroment variables - there is wrong path. Probably you installed Ansys on root folder.
What should help to you:
1. Uninstall
2. Install Ansys to program files folder
3. check enviroment variables Computer-properties (you have to set up path to ansys 121 folder
Juzer

Mumbai, India

#21 Jul 13, 2010
im getting an error in ANSYS 12.1 on windows7, 64-bit

Plugin error: Geometry interface not found.
Unable to attach to geometry file.

Does anyone have a solution to this..??
Please let me know..
im able to create the geometry but while it shows an error when I take it for meshing...Please help me out.
HZs

Budapest, Hungary

#22 Aug 22, 2010
Juzer wrote:
im getting an error in ANSYS 12.1 on windows7, 64-bit
Plugin error: Geometry interface not found.
Unable to attach to geometry file.
Does anyone have a solution to this..??
Please let me know..
im able to create the geometry but while it shows an error when I take it for meshing...Please help me out.
I solved it (I built up the geometry in the DesignModeler, and the Mechanical Model didn't start. Error message: "Plugin error: Geometry interface not found" ). The solution:
1. Run the "CAD Configuration Manager 12.1".
2. Mark the "Workbench and ANSYS Geometry Interfaces"
3. Press "Next" button.
4. Press "Display Configuration Log File" button
5. Press "Configure Selected CAD Interfaces" button
6. Press "Exit" button

Run the Workbench, and it works.

HZs

Tell me when this thread is updated:

Subscribe Now Add to my Tracker
First Prev
of 3
Next Last

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

ANSYS Discussions

Title Updated Last By Comments
ANSYS workbench toolbox (Jul '10) Sun hem 48
ANSYS 12.1 license (Apr '10) Jul 1 kfkdf 98
preserving original elements while assembling m... Jul 1 Anonymous 1
FEA-Determine wrapping pressure of multi-layers... Jun 28 ttry 1
How to model wave propagation in Ansys Jun 20 Anonymous 1
Ansys 12 crack on WinXp (Nov '09) Jun 19 Arjun 80
thermal cycling in ansys (Jun '12) Jun 15 navz 2
More from around the web