I知 having problems using the UART DM...

I知 having problems using the UART DMA in the interrupt mode

Posted in the Altera Forum

quyetln

Vietnam

#1 Mar 31, 2008
I知 having problems using the UART DMA in the interrupt mode. I知 avoiding the process of reading the UART byte in the RX channel as they arrive. Instead, the DMA has been set to trigger after 16 bytes so that the interrupt for every byte wouldn稚 delay the processor.

I would like to know if there is a way to fire an interrupt on every DMA FIFO full. Please find the code attached and let me know of what I知 doing wrong. Also, I would like to know if there is a interrupt driven UART DMA example available.

Tell me when this thread is updated:

Subscribe Now Add to my Tracker

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Altera Discussions

Title Updated Last By Comments
News Altera to switch 14nm chip orders back to TSMC,... (Mar '14) Mar '14 dvmoo7 1
News Dividend Changes on the Week: Crane, MHI Hospit... (Nov '12) Nov '12 Harry 1
News Chipmakers say higher taxes will cost jobs (Mar '09) Mar '09 Is The Coffee On 1
EPC1 with UP2 (Feb '09) Feb '09 loki_dre 1
News Zacks Analyst Blog Highlights: LSI Corp., IBM C... (Dec '08) Dec '08 MECHERI LYESS 1
Byteblaster Programmer (Mar '07) Nov '08 Karpol 5
JTAG & AS programming error (Apr '07) Aug '08 SCN 3
More from around the web