1998 Jeep Grand Cherokee-Stalling pro...
98gcherokee

Memphis, TN

#292 Oct 12, 2013
bill2bull wrote:
I have been a mechanic for 25 years. One of the most common problems on these Jeeps is the harness at the PCM. Use a couple of plastic zip ties and tie the harness up so it is not hanging on its own weight. This usually fixes the stalling issues as ong as there are no fault codes.
Do you have pictures showing how to tie the harness? In lieu of that, can you describe the process of tying the harness? Do I need to remove the covers off the PCM? Do I insert the plastic ties inside the gel protecting the PCM?
Dave

Mansfield, TX

#293 Oct 12, 2013
jGC 1998 stalling prob I started truck and wiggled wires on pcm truck started trying to turn off than died I zip tied connection truck is running for now I think bad pcm wiring
Harness
Dave

Mansfield, TX

#294 Oct 12, 2013
1998 jeep grand cherokee To zip tie pcm unplug neg battery term. Remove the radiator over flow bucket remove the 3 bolts on pcm get long zip ties you might half to zip tie two together go around back of pcm to front go around pcm body and over pcm plug connector than tighten the hell out of it do all three plugs if you can go from side to side also than screw pcm back in reinstall over flow bucket and plug battery back in start
You will know right off the bat if it is pcm before you do all this start jeep than wiggle pcm connectors if truck dies it is pcm connection prob DBC
Pete DeVries

Rockford, IL

#295 Nov 27, 2013
Stalling and no codes solution. Take out the PCM. Take out the 2 screws and pry back the tabs that hold the cover on the lower portion. You'll need to pry the cover off carefully as its held in with jell inside but just keep going from side to side prying and it will come off. After you have the bottom plate/cover off you'll have exposed a multiple pin connector. Go to Radio Shack and get a can of contact cleaner (about $14) and spray both the male and female connectors. Good idea to also spray it on the PCM's 3 other outside connectors at the same time. Put the thing back together and your problem is fixed.
joe

Washington, DC

#296 Dec 27, 2013
It is not your harness it is the pcm. This us whst you need to do and it will work. Take the antifreeze Reservoir out. Then unplug the pcm.next unbolt it ( 3 bolts), now you notice there it's two plates on the front, take the two torque screws out that everybody says to unscrew out all the way. Now u need to "carefully" pull off the covers. One of them has a plug inside that connects your harnesses . Be carfull with that when taking it apart. You will then see on that plug in part there is solder points on it THAT IS THE PROBLEM!!!! now re-solder on every single connection. It usually the one of the first 3 that lose connection. But just do them all. Then put hot glue over all your solder points. Put it back together and your stalling problem is over I guarantee. So do this before spending any money on a crank sensor or any other sensor. And you'll thank me !!!:-)
Ryan

Antioch, CA

#297 Jan 1, 2014
I've battled this issue for years and spent thousands on the tune up stuff I should've been doing all along. NOTHING WORKED.
I took the PCM apart, replaced the two hex head screws that hold the cover on with shorter ones and BAM! No more stalling! For a couple months. Then it was back to it's old quitting ways.
So I jiggled and jostled the PCM with car idling and it would stutter, stall, cough, fart, etc. I took one LARGE LOOONNG ZIP TIE and went around the entire PCM & all 3 wire plugs/connectors on the front and it's been several months without a stall. I even wedged some plastic blocks between the zip tie & back of plugs to make sure they were held firmly to the PCM.
My first attempt merely plugged the connectors back in upon reassembly, which just bought me some time before they wiggled loose again.
BIG zip ties can be found at your local hardware store in the electrical isle, typically. If not, slice up a bicycle inner tube (the long way into strips not rings) and stretch that around the mess nice and tight and tie off. Now it's off to the radiator store!
ATX

Texarkana, AR

#298 Jan 2, 2014
It is most definitely the PCM. I had to replace it twice in a couple months because I tried to go with a refurb model first. I strong recommend staying away from the refurb.
jessica

Aurora, CO

#299 Jan 30, 2014
We own a 1998 jeep grand Cherokee laredo. And we were having problems for at least 6 months. We replaced so many parts, tune ups everything. We were already frustrated cuz it would drive for two days good then the stalling would start for a day or two and it was fine again. We couldn't drive on the highway cuz we never knew when it would turn off all of a sudden. So I came on this sight and saw all of the comments from different people who own a 1998 jeep. And saw about the pcm that they shortage out and cause the truck to turn off and we decided to replace the pcm and its been about 4 weeks that we haven't had the stalling problems. So thank you everyone for ur comments, cuz so far our problem was fixed. Thought I would share, to see if I could help anyone.
misty

League City, TX

#300 Feb 7, 2014
alan wrote:
i have 93 jgc that runs like a deer after cold starts no probs. but once its hot and i turn the engine off it has trouble restarting sometimes (rough idle/stall). the hotter the conditions, the longer i run it, the worse it gets. ive read all the blogs but still dont get a clear picture of what the problem or solution could be. who knows? cause my mechanics sure dont.
this sounds like a thermostat problem
David

Tulsa, OK

#301 Feb 12, 2014
I have a 98 jgc and for some reason when i start it up i have to keep on the gas and hold it at like 2000 rpms which seems like forever before it will sit there and idle by itself but then once i get it moving and stop again it will stall out occasionally or on the times it dont ill put it park then when i go to put it back into drive as soon as it kicks in it will stall. So i wondering if anyone has had simular problems and might know what the problem could be? Thanks.
Lee

Huntersville, NC

#302 Feb 17, 2014
have a 98 jeep grand Cherokee larado with 5.2liter how can you elimininate the fuel tank pressure sensor and keep check engine light off?
Dillon

Owego, NY

#303 Mar 1, 2014
HRP wrote:
I had the same problem for my Jeep Grand Cherokee 1998 6 cyl. I replaced all possible sensors, cables, spark plugs, distributor cap, etc. at one point the backfiring was so bad that the mufler exploded. Twice, changed the catalitic converter and the oxigen sensor. Finally tried the PCM screw treatment, Nothing worked, The last try before throwing the car away was to try and exchange the PCM. I bougth a refurbished one from a Floride Co. on Ebay. AND FINALLY, the problem is solved. Have not have the problem recurr since changing the PCM.The car runs like new.
My advise, then, is to change the PCM as soon as the problem shows up. IT is not the sensors, THE PCM GOES BAD>!!!
Good luck everybody
what is the PCM bc my jeep sometime stalls out and sometimes is hard to get started back up
justin

United States

#304 Mar 13, 2014
To everyone with this issue they need to get a tech to look at the pickup assembly in the distributor if the pcm don't fix your issue. I just spent 6 hours diagnosing this after the pcm was replaced. Found the pickup assembly in the distributor was broken and corroted.. New distributor installed and started up like a new rig.
D Piper

Kenner, LA

#305 Mar 17, 2014
I have a 1998 Jeep Grand Cherokee, I have replaced the fuel pump and filter, crank shaft censor, spark plugs wires and plugs, relays, ignition coil pack(module), fuses, distributor, oil sensor just to name a few. This jeep only runs for a day after each tow/visit to a so called mechanic. HELP!!!
Utesinutah

United States

#306 Mar 23, 2014
I have a 97 jeep grand 4.0... As nd lets just say im gona try the ecm its on the passenger side behind the coolent overflow with 3 plug outlets looks like a motum for u guys who dont n, but ya I changed ignition coil still nothing so I hope the ecm cuz I would like to start and go not start and stop.. I love my jeep so much it runs like a beast but crysler really did some sloppy shit it sounds like..was this ever recalled?? Im gona do mine ill post with the update and no im not buyin a new one im tryn screws zipties l if no change im gona salder the structure on mobord
JTE

Maple Grove, MN

#307 Mar 31, 2014
Here's my suggestion. If it ain't broke don't fix it. You all buy all this stuff not knowing if it's actually the cause of the problem and then your upset when your problem is not solved? Insanity at it's finest. Sensors throw codes in cars, sensors also wear out, now I don't know about you but If my truck is running fine, I'm certainly not about to go buy ignition coils because the computer tells me too...or anything else for that matter. Same with oil changes 3,000 miles? I think not I got about 9 to 12k usually depending on how hard ive driven. The truck will clearly let you know when the oil is old, it feels, sounds, acts, and drives different.
sandra

Tampa, FL

#308 Apr 4, 2014
Just bought 99 jeep grand cherokee limited edition 4.6 engine..drove fine today while driving Iit just shut off no warning..started right back up but shut off again few minutes later..any ideas??
To Stelios

Hyden, KY

#309 Apr 24, 2014
Stelios wrote:
<quoted text>The bad coil damaged the PCM, change the PCM the spark plugs, distributor cap and rotor, and spark plug wires you'll be fine.
I have been trying to figure out what is wrong with my Jeep forever and just parked it but I think you have it right. The Jeep used to have a delay when you would take it but if you laid the gas down, it would take off and run fine after sometimes backfiring. Then there came a day out of the blue that it just doesn't want to run period. If I go a mile down the road, I am lucky to make it back. It has had a new fuel pump and new spark plugs and wires, new battery. But I have another question. It has a sound in the back end that sounds like it is on the passenger side that is pretty loud but what surprises me is that it has been running with this noise for YEARS...like before 09, I know, but just a quick note...I don't go out a lot. My bf thinks it's my rear end and I had friend that had to change his. Do you have any idea on this problem or have you ever had this problem?
Hey David

Hyden, KY

#310 Apr 24, 2014
David wrote:
I have a 98 jgc and for some reason when i start it up i have to keep on the gas and hold it at like 2000 rpms which seems like forever before it will sit there and idle by itself but then once i get it moving and stop again it will stall out occasionally or on the times it dont ill put it park then when i go to put it back into drive as soon as it kicks in it will stall. So i wondering if anyone has had simular problems and might know what the problem could be? Thanks.
Do you put your foot on the gas when you try to start it? I noticed that if I didn't do that, it would idle on it's own but if I gave it any gas at all with my foot, I had to set there and babysit it. I am getting ready to put a PCM in mine though because everyone is having problems with theirs stalling and I'm having the same problem now, which occurred shortly after the idling deal I just described. Now it is stalling BAD and it has a new fuel pump, new plugs and wires, etc. I have read these post and this sounds like what it is so by all the reading, go to AUTOZONE. They are at least 2/3 less there and have a year warranty. GOOD LUCK! I know I need it.
To Stelios

Hyden, KY

#311 Apr 24, 2014
Sentence was supposed to say *take off*, not *take it*...lol

Tell me when this thread is updated:

Subscribe Now Add to my Tracker

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Scottsdale Discussions

Title Updated Last By Comments
Help wanting to attract and to find milfs. 10 hr Colchonero11 1
I'm a young guy looking for a MILF (Sep '12) 10 hr Colchonero11 6
Kiersten ? 11 hr Someone 2
McCain: Trump may be end of ME 15 hr TrumpGuy 1
News Kid Charged After Flashing Genitals in Yearbook... 20 hr Lawrence Wolf 15
New recorded gangs in Arizona.... (Jun '07) Thu BBOY 2,062
William Wayne Macumber (Jun '10) Wed whoszat 35
More from around the web

Personal Finance

Scottsdale Mortgages