1998 Jeep Grand Cherokee-Stalling pro...
Ralphie

Denver, CO

#250 Jan 26, 2013
Hello evry1,i hav a 98jeep gc limitd 5.2v8 w/217+miles latly its ben actn wierd she starts up fine all gauges workn fine bt sept the Voltage Gauge it wil only go a lil pass9 aftr 10min it wil drop& chek g. lite wil com on kep n mind iv alrdy had bttry&altrntr testd both good, chekd all wires tht i cud c no shorts,cleand terminals frm bttry real good,funy thng is no CEL(ChekEngnLite)wil com on,frm wat i red(tryd screw thng no prblm ther) has me leaning towards the CPScrank,or CamPS, r thy the same?last bt not least the infamous PCM/ECM, is it bttr 2gt a diffrnt1 or can i reflash my original-1? tht it has if ne1 has a solution or advise pleez dnt hold bak,i luv this Jeep& hate2c my "suzie" act this way lol
\,,,,\
0!!!!!0
@)--*-@)
Ralphie

Denver, CO

#251 Jan 26, 2013
O 1 mor thing i keep gttn a "rear lamp failure"mess, so i replaced all 3 bulbs on both sides so i knw ther good bt this only happns when i put it n drive,duz any1 no if ther a switch conectr/wires/ground tht kud b goin bad n tht area?
\,,,,\
0|||||0
@)--*-@)
THOMAS BRIOTO

Brooklyn, NY

#252 Jan 30, 2013
Damin wrote:
Replaced the PCM no problems since thank god hope it stays running well.
HI WHERE I CAN BUY A PCM PERSONALY, WHERE I CAN GO TO LOOK FOR IT PLEASE
THANKS
THOMAS BRIOTO

Brooklyn, NY

#253 Jan 30, 2013
HI I NEEED TO CHANGE THE PCM FOR MY JEEP BUT I DONT KNOW WHERE I CAN GO TO LOOK FOR IT
Nathan

Snover, MI

#254 Feb 3, 2013
I'm looking to purchase a 1998 jeep grand cherokee with a 199,000 miles for 1,800.00 it is an excellent shape but since reading about all these problem's or issues with stalling.. should I buy this vehicle mind you I test drove it, and didn't notice this issue as of yet.. thankyou feedback is most appreciated going to be picking this up in a week or 2
Ralphie

Denver, CO

#255 Feb 9, 2013
THOMAS BRIOTO wrote:
HI I NEEED TO CHANGE THE PCM FOR MY JEEP BUT I DONT KNOW WHERE I CAN GO TO LOOK FOR IT
go 2 any napa or autoprts store if thy hav1 u can buy1 for arond$170-$210 or a junkyard($30-$45) ; u pullurself triky part is findn1 w/same specs. as ur jeep
bt thn u hav2 tak it 2a dealrship or som1 tht knws how2 "reflash/progrm" it to ur vehicle givn thm the vin# year,mak&model &mileage thers2 co. n florida tht do this 1.auto computr xchange 2.4got the name bt its n jacksonville fl. jus google pcm repair i jus sent mine(original1) off 2 florida mak sure thy rebuilt it, nsted of remanufctrd1 u mite hav2 pay a lil xtra4 parts it neds nside pcm bt its worth it soon as i gt mine bak wil post results gluk w/urs
Stephen Cotner PE

Irvine, CA

#256 Feb 10, 2013
Stelios wrote:
<quoted text>Vehicles are way past warranty period and do not post a danger to life.
. I'd say that the engine shutting off at 65 mph on the freeway does post a danger. Chrysler should be held liable.
Joe from new castle

United States

#257 Feb 15, 2013
Tennessee Jenn wrote:
I have a 99 Jeep grand cherokee. Replaced all the sensors here, as well as cursed a few mechanics. Finally, after more than two weeks of getting stranded, I can post the solution here... IT IS THE CATALYTIC Converter..


what brings you to this conclusion jenn? I checked mine and it looked good, no clogs and no burn.. Just before all this happened I did get some nad gas " I THINK?"
Ros

Los Angeles, CA

#258 Feb 21, 2013
I am having problems with my 98 Jeep G.C. My car does not want to pass the smog I have taken it to the dealer and they had advised me, that my OBDII is working find. I have taken it to the smog check station and they can not read nothing in their computers what can I do.Please Help I would really appreciate it thank you.
Alphonzo

Tampa, FL

#259 Mar 20, 2013
So I am having the same issue as everyone else. I finally had to replace my engine after 240,000 miles. I never had any issues with the Jeep before this replacement so that was my thought about putting an new engine in. Engine when it runs runs great. I have replaced most of the same items that everyone else has. I was wondering if becasue it is a different engine do I need to flash the EMC. Could this be why it keeps stalling or should I replace the EMC. Any help would be great as I already have $2000 in all the new parts and engine.
eric from mississauga

Mississauga, Canada

#260 Mar 20, 2013
i have a 98 GJC 5.2 L V8. Jeep starts on first turn but stall immediately when I take my foot of the gas. If I keep my foot on the gas for 3- 5 minutes till the engine warms up, the problem goes away and it drive fine.
Audrey

Hayward, CA

#261 Mar 21, 2013
Cawmic wrote:
I have a 1998 JGC Laredo 6 cyl auto 4X4, 170km. The jeep starts perfectly and idles fine after about 10-30 seconds of driving, the jeep starts to sputter and appears to want to stall but doesn't. It does this most times but not every time, after about 10 more seconds, the problem is gone and works great until you shut off the vehicle it sits for 10 - 15 minutes, starts all over again. No codes and no check engine light. I recently replaced the speed control sensor to correct another problem would this be related? Any help? Would be greatly appreciated
Email is [email protected]
My jeep same year, started out the same as yours and now is stalling altogether. This is my first time looking into matters myself. I am going to try the suggested part because it seems to be the common denominator.

Since: Mar 13

Tampa, FL

#262 Apr 10, 2013
Alphonzo wrote:
So I am having the same issue as everyone else. I finally had to replace my engine after 240,000 miles. I never had any issues with the Jeep before this replacement so that was my thought about putting an new engine in. Engine when it runs runs great. I have replaced most of the same items that everyone else has. I was wondering if becasue it is a different engine do I need to flash the EMC. Could this be why it keeps stalling or should I replace the EMC. Any help would be great as I already have $2000 in all the new parts and engine.
Just an update for anyone that might be having some of the same issues. I did replace the computer and the first one was bad because someone returned it and already had the vin# burnt into it. Brought it back got another and its been in 2 weeks know and running great.
I would start there if your having the same problems because it is only going to get worse and cost money on parts that are good.
devin baker

Florence, KY

#263 May 16, 2013
Nelson wrote:
My Problem my truck just turned off out of the blue. I was using it just fine worry free. I pulled up to a gas station and it just shut of on me without any warning. After that, It wouldn't start up again. It would crank over, but not start. I do my own mechanical work so the first thing i checked was the fuel pressure. Pressure was good. I changed the spark plug cables and distributor cap/rotor because there was no current. No luck. I installed a brand new crank sensor and a pick up coil. no luck I the found t burn out resistors. I replaced them and BINGO!!, for now...? The truck started and ran fine, but 15 - 20 minutes later it started misfiring and getting lazier and stalling more and more until it died on me. Would not turn on after that. 1 hour later, it would turn on with no problems at all. 15 minutes after, same thing would happen. I ordered a new computer after checking the fuel pump and making sure the fuses were the correct amps. Still no luck. Please help. anyone out have any suggestions?
.

Its your wiring had it done an its like new
kicker the fordlover

Rome, GA

#264 May 24, 2013
JeepHater wrote:
I'm going through pretty much the same issues described in other posts... 97 GC 4.0/auto stalls and then won't start back up for approx. 2 minutes.. or,it sputters/spits/dies while you're driving down the road. I have dumped more money in this POS than I have in any other car that I've ever owned (and I've owned a lot)and I've only had it for 2 years (put 20k miles it-it now has 125k). Parts I've replaced include: basically the entire cooling system - water pump (twice), radiator, stat, hoses... Both O2 sensors, Crankshaft Position Sensor, fuel pump and sending unit, various other sensors and suspension parts.
Current issues (besides dying sporadically)include: Both headlights bulbs keep blowing out (tried resealing lenses with silicone-still keep blowing out), AC only blows on 1st 3 speeds/not on high (not good for living in FL), the paint is flaking off in big chunks.. leaving huge primer spots (factory paint defect), all of the door lock motors are stripped and not working, the instrument lights flicker on and off at night... I'm sure that I'm missing quite a few other things wrong with it, that I've just learned to live with.
As for the stalling issue, I can move the wiring harness that's closest to the engine on the PCM and cause it to stall, so I'm pretty sure it's a bad connector or loose connection (whether in the harness or inside the PCM itself).
I've decided that the BEST RESOLUTION to all of the issues above is to take the following steps:
Step 1) Remove the radiator cap
Step 2) Drive a FORD up under the radiator cap
Step 3) Replace the radiator cap :-)
I have a 97 Expedition with 187,000 miles on it (I put 120k on it) and.. knock on wood.. have NEVER had any issues with it. The paint still looks good, it runs like a top and I wouldn't be afraid to jump in it right now and start off on a cross-country trip in it.
The Jeep.. not really confident that I'll even make it home from work today.:-(
I drive a 04 Ford Explorer Sport Trac and my girlfriend drives a 99 JGC. Personally ? The Jeep drives really sweet but my Ford I wouldn't trade for anything..........
Sherri

Santa Ana, CA

#265 Jun 9, 2013
My 1998 Jeep Grand Cherokee has been stalling since 2008. The car stalled on the freeway (like it ran out of gas....very quietly). It was scary as I was going 60 mph when it happened. I replaced the Crank sensor and PCM box at the dealer (3 times to get it right in 2 months!). Worked fine for a couple years until 2010. Stalled on the freeway! Very Scary stuff here. Had the PCM box replaced again, still stalled on the freeway. Now they say it's something else, but that didn't work. Runs very rough now, but when the box was first put in it ran like brand new. Can't get anyone to get this right. Now car is in my driveway, not able to drive at all as it just stopped working altogether until I can find out how to fix this ongoing problem. Dealer doesn't know, either. Very dangerous problem. I saw on the news recently that they want a recall on this, but mfg. is rejecting. Someone is going to get hurt with this car!!!
Jeremie

Houston, TX

#266 Jun 23, 2013
I have a 1993 4.0l jeep grand cherokee limited that is slow to accelerate, anyone help,I've replace almost everything
kickerthefordlov er

Chesapeake, OH

#267 Jun 24, 2013
Sherri wrote:
My 1998 Jeep Grand Cherokee has been stalling since 2008. The car stalled on the freeway (like it ran out of gas....very quietly). It was scary as I was going 60 mph when it happened. I replaced the Crank sensor and PCM box at the dealer (3 times to get it right in 2 months!). Worked fine for a couple years until 2010. Stalled on the freeway! Very Scary stuff here. Had the PCM box replaced again, still stalled on the freeway. Now they say it's something else, but that didn't work. Runs very rough now, but when the box was first put in it ran like brand new. Can't get anyone to get this right. Now car is in my driveway, not able to drive at all as it just stopped working altogether until I can find out how to fix this ongoing problem. Dealer doesn't know, either. Very dangerous problem. I saw on the news recently that they want a recall on this, but mfg. is rejecting. Someone is going to get hurt with this car!!!
. I READ HERE ON THIS FORUM THAT THERE IS A GROUNDING ISSUE WITH THE MAIN COMPUTER. ELIMINATE ALL GROUNG AS TO HOW THE BOX FITS IN ITS HOLDER BY USING FLAT RUBBER. AND REPLACE THE CRANK SENSOR AGAIN. IT'S BEEN A MONTH NOW AND MY 99 HAS NOT STALLED YET ! Knock on wood
shyboysracing

Weiser, ID

#268 Jul 14, 2013
98 grand cherokee limited, 4.0l Where is the pcm located? Thanks
Bob

AOL

#270 Jul 20, 2013
Matt wrote:
i have a 98 jeep grand Cherokee and i just replaced the crank position sensor and just as im getting ready to pull out of the mechanic shop it stalls. driving it and speeding and slowing down doesn't stall now. i stopped at the store real quick let it run and when i jump into it and put it in reverse it stalls. it seems like its working much better but it stalls still!!!!!!!!!! someone have any idea what i could do to fix this? i have read about the ecm screws but i have no idea what the ecm is, can anyone tell me where to find it and what it looks like on a 4.0?
Engine Control Module or PCM same thing. Computer.
http://autocomputerexchange.net/skin/frontend...
Go to that link and you will see what it looks like. Its on the drivers side all the way towards front under hood mounted on fender well, has 3 large plugs into it and 2 screws one each side. Hope U have it fixed by now LOL. I have same problem with my 98 Jeep Classic 4.0 inline 6 cyl. An idiot designed those damn things! Everyone goes thru hell trying to find the problem! Should be a recall at Chrysler! I love my Jeep but most non Jeepmechanics are dumb as hell about Jeeps they put all kinds of parts even catalytic converters on the cost a $1000.00 or more when its usually the computer or the Crank Position Sensor on drivers side of bell housing in a little hole in the bell housing tiny little thing with one wire and one screw holding it in. GOOD LUCK!!!:) Bob in Raleigh,NC

Tell me when this thread is updated:

Subscribe Now Add to my Tracker

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Scottsdale Discussions

Title Updated Last By Comments
learn to code this summer! 1 hr Jjjj 2
Frito lay lies to customers and employees (Dec '15) 1 hr guest 68
News Sources: KTVK drops 'Good Morning Arizona' pers... (Mar '09) 2 hr Augie 898
Married Flirting ;-) Mon Augie 4
Frito lay tostitos fiesta bowl fails Jun 27 guest 3
News Arizona poll worker: System blocked some ballot... Jun 27 Loco 3
News A big chunk of Donald Trumpa s supporters were ... Jun 27 Go Blue Forever 1

Scottsdale Jobs

More from around the web

Personal Finance

Scottsdale Mortgages