Courtney

Jonancy, KY

#82 Aug 4, 2013
It's the ignition coils. Had the same problem.
Steven wrote:
I am also having some of these issues with my 03 trailblazer. The check engine light came on today and then starts flashing around 35 mph. I can tell at least one cylinder is not firing. I have not had the reduced power issue yet. After reading am the posts on this forum I am not sure where to start with fixing it. This is the first issue I have had since I bought it 5 years ago. It only has 114,450 miles on it. I haven't spent any money yet but if there is a law suit I am in.
Jeff

Belleville, MI

#83 Aug 8, 2013
I also have a 2003 Trailblazer with all of the same problems that everyone is talking about If anyone wants to start a lawsuit lets get together and do it Email Me cbolt9154@yahoo.com
perla

San Antonio, TX

#84 Aug 10, 2013
I hv a 2003 trailblazer LS and servive engine light turned on recently...I wz advized 2 change the oxygen sensor hope it does the trick. Though I m interested on that lawsuit please contact me my email tiny2prl@hotmail.com
shelia

Northport, AL

#85 Aug 11, 2013
Carrielgagne wrote:
I have a 2003 Chevy Trailblzer that has been nothing but problems. I just spent $1,253 on it with 3 differnt mechanics that can not fix the problem. The reduced engine power ligth comes on and I lose power. I have to pull over, put hazzards on and turn off car and re-start it. I can't even pull out of my driveway w/o this happening. Please help! I have been pulling over every trailblzer I see on the road and most have the same problem. I am ready to start a class action lawsuit. I replaced the gas pedal sensor, the camshaf sensor, throttle body unit, computer, fan clutch, fuel filter, mechanics have checked every wire and they still cannot fix. I have about 6 others phone numbers with the same problem. Any help from anyone would be greatly appreciated. If you are having these problems, please email me: carrielgagne@yahoo.com. Please put Chevy Trailblazer in the subject. Lets get our vehicle fixed or be compensated for the Lemons that we all have. By the way all the trailblazers I have pulled over are from 2002 to 2007 and all have similar problems. Please HELP! if you know what will fix it, please also let me know. I'm very frustrated!
I have a 2004 trailblazer that was doing the same thing and I replaced the coil packs and spark plugs...so far so good
shelia

Northport, AL

#86 Aug 11, 2013
I have a 2004 trailblazer that was doing the same thing and I replaced the coil packs and spark plugs...so far so good

Im in on the lawsuit if you start one....bamagrl8@live.com
troy

International Falls, MN

#87 Aug 12, 2013
My son has a 2002 trailblazer he was driving o the highway it died on him and would not restart change the fuel pump starts now but has no throttle we pulled it about 5 miles put a scanner on it said the cc. pedal pos. sensor was bad replaced that but codes will not clear wiring is good to the ECM is there a way to check to see if we need to get a new ECM any help would really help. Thanks
Joel

Brooklyn, NY

#88 Aug 12, 2013
Had the same problem ...and it was just a fuse... Saved a lot of money
tanyanika moran

Los Angeles, CA

#89 Aug 14, 2013
I have a 2002 trail blazer it also has the reduce engine power light as well as the sevice engine light. I had a lot of work done since march and today I'm still having work done on it for the samething. I am very interested in that class action lawsuit please email me at
Moran.tanyanika@yahoo.com
Nicole

Flowery Branch, GA

#90 Aug 20, 2013
I have a 2003 trail blazer too and have been having the same problems for years no one has been able to figure it out and now with all the work it's started do the same thing!!!!!
darian

Muskegon, MI

#91 Aug 26, 2013
2002 trailblazer and i have the same issues please send me the law suit info darianbutler94@gmail.com
kevin

United States

#92 Aug 28, 2013
I have a 2003 trailblazer I'm having trouble with my tachometer, gas gauge,oil,temp gauge,battery gauges
bill white

Collierville, TN

#93 Aug 30, 2013
I've read your complaints, and I have the same problems....throttle body replaced twice, fan clutch twice, mechanics scratch their head, dont know what the problem is. You'd think by now GM would know something! Did someone mention LAW SUIT?
Tyrone Knoxville TN

Knoxville, TN

#94 Aug 31, 2013
I have an 02 Trailblazer and its having the same issues as everyone elses vehicle. About a year ago the reduce power light came on it stayed on for three days then when i took it to the shop it stopped without getting anything fixed. A year later now the problem has started back. Its hard to trust mechanics because I've seen theis problem go away on its own. Any info about that lawsuit would be great because it seems like it could be a defect in these vehicles.
bill

Collierville, TN

#95 Aug 31, 2013
"srvice engine soon" , and"reduce power" lights come on, e transmission locks in third gear and will not go over 45 mph. sometimes I can turn the engine off and can get home but would not want to drive on freeway. Does anyone have a solution to this poblem? GM headquarters nor local dealership or local hops have not a clue! please postan answer if you have one. Thanks
p.s. I have replaced throttle body twice...no real codes storedin the vehicle computer.
bill

Collierville, TN

#96 Aug 31, 2013
try checking the air filter for dirt and check to see if exhaust is coming out good, you might have a stopped up cattillac converter. as for the windows, you might have a ground problem
Ronald Willard wrote:
I have a 2003 trail blazer check engine light stays on. Now none of my windows would work turned it off then all the window's worked except the driver's window rain storm rolling in then I hit the lock button as it locked the door's the drivers window went up an inch. I then tried the window button again nothing the only way I could get my window up was to continuously push the lock button the window went up an inch every time I hit the lock button got it rolled up right before the rain storm hit it has 171,000. Miles I just paid after taxes and ins.and plate's $4,600 for this truck I really like it but I want it right when things are right it's a nice truck I am guzzling gas also as far as power I drive like a grandpa. To many bills for a ticket so I don't really tromp on the gas but I'm getting very bad gas mileage
Lamar

Woodbridge, VA

#97 Sep 2, 2013
Hello to all of you trailblazer owners, I have a 2003 trailblazer and just like you all, my check engine light as well as the reduced engine power light come on and my trailblazer looses power and will not go over 50 miles per hour. I have taken it to the Chevy dealership and they cannot figure it out. All the mechanics want to replace this or that, 02 sensor, fan clutch, air intake sensor, throttle body. I only have 147, 000 miles on my trailblazer, I have used synthetic (Castrol) oil since I have owned the vehicle, I have every service record since I bought the vehicle new. I have yet to see a recall for the engine, but I am hoping that there is one. Please, anyone with the information on the law suit please let me get some information so I can get on board with the lawsuit. willssg@hotmail.com
Denise laJoye

Marquette, MI

#98 Sep 3, 2013
My 2002 Trailblazer just lost power today, right after reduced power light came on. I have replaced so many things on this car, it's ridiculous. The engine blew at 97,000 miles and Chevy wouldn't help, at all. It's on it's 2nd transfer case, among $3000 of other work. If there is a class action lawsuit, please e-mail me and let me know. lajoyes@att.net
Denise laJoye

Marquette, MI

#99 Sep 3, 2013
I have had nothing but problems with my 2002 Trailblazer. The engine blew at 97,000 miles. I have replaced the transfer case and the transfer case control module. Numerous sensors. Batteries. About $4000, since I bought it in 2003. Now the reduced engine power light came on and it died. I just called GM and was told, sorry, there is nothing they can do. No recalls at all on my vehicle. If there is a lawsuit, please let me know ... I'm in.
lajoyes@att.net
Nathan

Apollo, PA

#100 Sep 4, 2013
Same issue here. Send me the lawsuit info please. nbarr17@gmail.com
2003 TB CFL

Longwood, FL

#101 Sep 4, 2013
Oddly, I also have a 2003 TB w/184K miles and do not have the Limp mode issues but totally the opposite. I have read about all the fan clutch replacements and such and had a transmission code along with a P1482 code. I replaced the tranny control solenoids and cleared the engine light, fixed the tranny issues but still had the P1482 w/o an engine light. Since I had the original fan clutch, I replaced it and the water pump, both which did not have anything wrong since the vehicle still roars, now worse at 1300 RPM, 45 mph, no check engine light and no OBD codes when I scan it. Any help out there??

Tell me when this thread is updated:

Subscribe Now Add to my Tracker

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Oceanside Discussions

Title Updated Last By Comments
Help me get dripping wet I dare you (; Jan 26 backwoods_princess 1
3 'Ts' of a good real estate video Jan 23 Angela K 1
Making a change in career by typing from home Jan 21 ash760 1
Seattle man arrested after bragging online abou... (Jun '14) Jan 15 footbawlhockey 34
Men like Elliot Rodger are not owed anyone or a... (Jun '14) Jan 15 lawlslomao 59
Girl, 15, Arrested For Online Threats That Clos... Jan 12 Serenee 2
Great new Dog Groomer in Oceanside! Jan 11 patty_mcclure 1
Oceanside Dating
Find my Match
More from around the web

Oceanside People Search

Addresses and phone numbers for FREE

Personal Finance

Mortgages [ See current mortgage rates ]

NFL Latest News

Updated 5:48 am PST