Ask the Auto Doctor

Full story: Independent Record

Dear Doctor: I own a 2003 Lincoln LS with only 4,700 miles. The "service parking brake" message appears and the electronic park brake light stays on.
Comments
1,441 - 1,460 of 1,511 Comments Last updated Mar 22, 2014
Gerri

Suffolk, VA

|
Report Abuse
|
Judge it!
|
#1457
Oct 21, 2011
 
I am thinking about buying a 1995 Buick Lasabre that has leaking valve cover gasket. Would this be expensive to repair?

“Treat each day as your last, ”

Since: Sep 07

Location hidden

|
Report Abuse
|
Judge it!
|
#1458
Oct 23, 2011
 
Ok, for starters, I'm assuming it's a 5.3 v-8 and it's just front wheel steering without the hydro boost assist. Does your truck have a rack and pinion, I haven't seen one yet but they're out there. See how important it is to give it all up when posting?

Now for the first possibility, high mileage and dirty power steering fluid.(Low pressure from the PS pump may be the results of dirty or contaminated fluid, which could cause the pressure relief valve to stop functioning)

If this is the case the pump will have to be replaced and the system flushed. When the steering is stiff, can you bring the rpm's up a little and make the power steering work?

Second thing, we'll need more info if this don't help.
GMC wrote:
My truck is truning hard to the right but not the left and one person says power steering other says rac and pinion ! its 2004 GMC 4 wheel drive. When your going 5 miles hour or faster its easy. its makes a noise like power steering.

“Treat each day as your last, ”

Since: Sep 07

Location hidden

|
Report Abuse
|
Judge it!
|
#1459
Oct 23, 2011
 
Gerri wrote:
I am thinking about buying a 1995 Buick Lasabre that has leaking valve cover gasket. Would this be expensive to repair?
It could be the valve cover gaskets, but more common is the rear lip of the oil pan. GM's got bulletins on this leak, they say top silicone the pan because of the uneven surface on the pan.

You'll have to have it checked better to isolate the real cause. The valve cover gaskets pay 2.4 hours to do both, the book time fro an oil pan gasket is 1.5 hours.
Good Luck
Winnie

Warminster, UK

|
Report Abuse
|
Judge it!
|
#1460
Nov 3, 2011
 
My car makes a loud squeeking noise when i drive it in wet and or very cold weather for around 20 mins (after being parked/un-driven)in the lower gears. Any ideas? The MOT passed in June so in theory should be fine?!
james

Plainview, NY

|
Report Abuse
|
Judge it!
|
#1461
Nov 12, 2011
 
why when i fill up my gas tank does the gas spurt out and the pump keeps shutting off
james

Plainview, NY

|
Report Abuse
|
Judge it!
|
#1462
Nov 12, 2011
 
why when i fill up my gas tank gas spurts out and the pump keeps shutting off?
Gilbert Gonzales

San Jose, CA

|
Report Abuse
|
Judge it!
|
#1463
Nov 15, 2011
 
I have a 1993 olds cutless serpreme that dies out. It won't hold it's charger of 14v. I believe it's the alternator. Could a short some where cuase it to?
Sparks

Farmington, MI

|
Report Abuse
|
Judge it!
|
#1464
Jan 10, 2012
 
I have a 96 Chevy 3/4 ton pickup. Runs rough and has no power. I just changed the distributor new plugs and wires. When I drive the thing across town shut it off it takes about 30 seconds to start running like it should. Within that time it sputters and backfires through the exhaust. The dist gear was worn on one side like the cam gear was bad. It has a 454 big block in it and I'm getting spanked by little Toyota trucks. Need to find the mystery power again that it had back on the day. Any ideas
Frank

Dover, NH

|
Report Abuse
|
Judge it!
|
#1465
Jan 10, 2012
 
Brian Pomona California wrote:
I own a 2000 Chevrolet Suburban and last year, I had the parking brake pads replaced. This year, I had a Chevrolet dealership check the parking brake again and when the mechanic looked at the parking brake, the mechanic noticed a broken seal at the rear axle. I was told that I needed rear brakes replaced because it was affected by the leak in the seal, but I was also told I needed new parking brake pads again. Is there anybody else having problems with parking brake pads? I don't beleive it's normal for the parking brake pads to wear out so soon.
They are saying your parking brake shoes are affected by the oil seal leak too I would bet. These are closer to the oil leak and would be hit first with oil. If they are just oil soaked clean them with brakeclean and reuse. Its just an E-brake.
Auto Doc

Lindsborg, KS

|
Report Abuse
|
Judge it!
|
#1466
Jan 11, 2012
 
Winnie wrote:
My car makes a loud squeeking noise when i drive it in wet and or very cold weather for around 20 mins (after being parked/un-driven)in the lower gears. Any ideas? The MOT passed in June so in theory should be fine?!
It could be your belt slipping!
Auto Doc

Lindsborg, KS

|
Report Abuse
|
Judge it!
|
#1467
Jan 11, 2012
 
Sparks wrote:
I have a 96 Chevy 3/4 ton pickup. Runs rough and has no power. I just changed the distributor new plugs and wires. When I drive the thing across town shut it off it takes about 30 seconds to start running like it should. Within that time it sputters and backfires through the exhaust. The dist gear was worn on one side like the cam gear was bad. It has a 454 big block in it and I'm getting spanked by little Toyota trucks. Need to find the mystery power again that it had back on the day. Any ideas
A bad timing chain. The chain is stretched, and the cam timing varies as the chain slackens and stretches as the lifters travel on the cam. This is usually most noticeable when the engine is hot. This is why it's wearing out the gear. HOpefully this helps.!
Kyle

Chico, CA

|
Report Abuse
|
Judge it!
|
#1468
Jan 17, 2012
 
I have a 1996 Dodge Dakota SLT Pickup Truck V-6 Automatic 4 wd that turns over, but won't start. When I turn the ignition key, only the digital radio clock comes on, but the red ignition lights do not turn on. The engine turns over, cranks real well, wants to start but I'm guessing is not getting fire into the spark plugs? Three yrs. ago, I had the ignition replaced. The day it quit, the red ignition lights and clock did all turn on, I started it up fine, then the engine died. I restarted and drove a ways, turned it off. Tried to restart an hour later and it would turn over, but not fire up and start.
Frank

Dover, NH

|
Report Abuse
|
Judge it!
|
#1469
Jan 17, 2012
 
Kyle wrote:
I have a 1996 Dodge Dakota SLT Pickup Truck V-6 Automatic 4 wd that turns over, but won't start. When I turn the ignition key, only the digital radio clock comes on, but the red ignition lights do not turn on. The engine turns over, cranks real well, wants to start but I'm guessing is not getting fire into the spark plugs? Three yrs. ago, I had the ignition replaced. The day it quit, the red ignition lights and clock did all turn on, I started it up fine, then the engine died. I restarted and drove a ways, turned it off. Tried to restart an hour later and it would turn over, but not fire up and start.
I had one of these rot out the coil. I put new one on and fired right up.
Beastie boy

United States

|
Report Abuse
|
Judge it!
|
#1470
Jan 20, 2012
 
I have a 94 vw jetta g3. My problem is when my 5 speed is in neutral my idol bounces up and down, ranging from 500 to 2000 rpms. Usuall the fuel filter is only effected when driving. Why would it do this in neutral...
mike

Malden, MA

|
Report Abuse
|
Judge it!
|
#1471
Feb 7, 2012
 
2001 blazer 4.3 won t stay in 4wd light flashes then goes back to 2 hi
gary lynn

Chattanooga, TN

|
Report Abuse
|
Judge it!
|
#1472
Feb 16, 2012
 
my air bag lite stays on my 02 vw bug
gary lynn

Chattanooga, TN

|
Report Abuse
|
Judge it!
|
#1473
Feb 16, 2012
 
air bag light stays on 2002 vw bug

“Treat each day as your last, ”

Since: Sep 07

Location hidden

|
Report Abuse
|
Judge it!
|
#1474
Feb 17, 2012
 
james wrote:
why when i fill up my gas tank gas spurts out and the pump keeps shutting off?
Jimbo, there's a vent valve in the rear of most cars that is run by the computer system. When the tank gets filled the valve is open and lets the air out of the tank as you fill. When the system is running the valve is closed, that way when you tip your car over no fuel spills from the tank. It's probably got a check engine light on too.

People, when you post tell people what you drive, makes a big difference when you ask a question. Thanks
isabel

El Segundo, CA

|
Report Abuse
|
Judge it!
|
#1475
Feb 27, 2012
 
i need a good mecanic and cheap in the los angeles, california area please anyone
i'm having problems with my lincoln ls 2005
check engine light came on flashing
X the Eliminator

United States

|
Report Abuse
|
Judge it!
|
#1476
Feb 27, 2012
 
I just had my 1971 Volkswagen Bug serviced, and at first it drove fine. Recently, if I'm approaching a stop and put it in neutral, the car dies before I halt completely. I then must restart it, but even then it's sometimes difficult.
I can counter this problem occasionally if I keep my foot on the clutch and alternate between gas and brake when stopping, but even then I must roll through the stop. We have to get it re-registered in a week so I have to fix this before then. Any help is greatly appreciated

Tell me when this thread is updated: (Registration is not required)

Add to my Tracker Send me an email

Type in your comments below
Name
(appears on your post)
Comments
Characters left: 4000
Type the numbers you see in the image on the right:

Please note by clicking on "Post Comment" you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

•••
•••
•••
•••

Monterey Jobs

•••
Enter and win $5000
•••
•••

Monterey People Search

Addresses and phone numbers for FREE

•••

Monterey News, Events & Info

Click for news, events and info in Monterey
•••

Personal Finance

Mortgages [ See current mortgage rates ]
•••