Ask the Auto Doctor

Dear Doctor: I own a 2003 Lincoln LS with only 4,700 miles. The "service parking brake" message appears and the electronic park brake light stays on. Full Story
eddie

Rochester, NH

#1437 Jun 8, 2011
93 chevy cavalier. Runs while parked. Drove short distance it started idling high, when I shut it off it wouldn't start,dead battery.I charged battery, it would turn over but wouldn't start. Couple days later it started.couple days later it wouldn't start. Again ,days later it started.I drove it short distance and it started idling high,when I turned it off it wouldn't start, battery dead. If it does start it runs good while parked, as soon as I drive it a short distance the same problem occurs. Idles high, then battery dies....please help....going insane in ct. Thanx
Big herm

Villa Park, IL

#1438 Jun 21, 2011
I have a 04 Mercury Marquis my EATC control deos"nt work. when i run my A/C. it runs up top thru the defrost and thru the floor vents . I had it inpected at Joe Rizza in north riverside, I WAS QUOTED A PRICE OF $721.00 FOR THE PART . my question is"can i purchase that control for a better price? somewhere in the neiborhood of $200/$300 range.
rice a roni

San Francisco, CA

#1439 Jun 22, 2011
My 1996 Honda civic makes a farting sound every time I press on the gas. Also now I'm hearing rattling from my wing on the back, I'm thinking of returning that to Autozone and get a neon kit.
carlos

United States

#1440 Jul 2, 2011
I bought my son a nice 1972 chevy truck with a 402 in it it start's up fine but after it's been running 4 a while it start's running slugish im getting ready to replace the plug's and spark plug wire's someone tell me what's going on how can i fix it myself.
Bev

Dayton, OH

#1441 Jul 10, 2011
The air conditioner doesn't see4 to pull any moisture out of the air and therefore isn't cool.

The fan speed only works on 3.
stephany

Canton, MS

#1442 Jul 11, 2011
I have a 2002 Lincoln ls v8 just all the sudden it ran hot while I was stopped at a lite so I changed the tjermostat I also had itburbed well it ran hot again so changed the water pump and fuel filter didn't work . When my car is stopped at a lite or something the air blows hot as I an driving it starts to blow cooler can that have somethin to do with the overheating please.help can't afford to put extra money on things it dnt need
car-ma

Hayward, CA

#1443 Jul 13, 2011
Stepany- Make sure that your electric radiator fan is turning on (usually between 200F to 220F). The problem might be that a Coolant Temp/ Fan Switch is bad. There is a possibility that the fan motor is toast or a the fan's relay isn't working properly.

Bev- Take your vehicle to a shop that can properly inspect and charge the AC system. A blower motor resistor (the switch) should fix your fan problem.

Carlos- DO A FULL TUNE UP (filters and ignition)! Buy a $20 book on your Chevy that outlines the basics of maintenance. You have a motor that is real easy to work on and I bet you and your son can crank it all out in a afternoon. Check your transmission and differential fluids, Grease the chassis and drive line while you are under there..
stacia

Taft, CA

#1444 Jul 21, 2011
sharon wrote:
my passat park light stays on
maybe you need some brake fluid?
robert

Manchester Township, NJ

#1445 Jul 29, 2011
how do i tunn off the maintence light on a 2007 corolla
robert

Manchester Township, NJ

#1446 Jul 29, 2011
how do i turn off my maince light with out a obd
GARY BRYANT

Fayetteville, TN

#1447 Aug 2, 2011
I have 2002 Ford TAURAS 3.0 OHV engine ,we are having problem with the car running HOT we have replaced the water pump,the radiaor,the thermostat and flushed the water system and it still is running HOT on the highway!!PLEASE HELP

“Treat each day as your last, ”

Since: Sep 07

Location hidden

#1448 Aug 4, 2011
GARY BRYANT wrote:
RUNNING HOT
Hi Gary,
Been doing this for a long time Gary, and I'd say by what you've just been through, it should've taken care of the problem. But on the other hand, it's a Ford and they blow head gaskets. When the gasket rots out like it sounds what you have happening, it blows compression (air) into the cooling system past the bad spot in the gasket. Then the cooling system will air lock which stops the normal coolant flow or circulation through the radiator "overheat"

Now, today's technology has come up with some pretty cool (pun intended) stop leak, it makes a mess out of the coolant, looks wise but doesn't seem to plug up the heater cores anymore. It may take care of the issue for a short period of time, or like I've seen many times, years.

Good Luck and let me know what happens.
gixonek

Howell, MI

#1449 Aug 11, 2011
nicole wrote:
i have a 1996 chevy blazer 4 door 4x4 and we are having problems with it it olny goes 5 miles an hour and we have taken it to the transmission garage they said they couldn't find any thing wrong with it and when they had to on the mechine thats tells whats wrong with it it said it was misfire #3 and need a mass air flow sensor o2 sensors and a s3 what ever that is we have done the tune up we have actulley done 2 with in 8 months on it but it stiils say it needs done we change the o2 sensors befor we took it to the garage and still came up that we just took it to another garage to put the mass air flow sensor in it and still nothing they put a used on in it when we thought it was a new one they didn't tell us my grandpa and his neighbour looked at it and the garage that put the mass air flow sensor said it was are transmission and needed tuned up again i was like we have had 2 tune ups with in 7 months it can't be that so we don't know what to do the wanted to charge me 450.oo to do a tune up that is carzy and 1500 for a transmission ir they any recalls on anything for my blazer and could you think of anything that it would be thank you
change ur fuel filter...
gixonek

Howell, MI

#1450 Aug 11, 2011
GARY BRYANT wrote:
I have 2002 Ford TAURAS 3.0 OHV engine ,we are having problem with the car running HOT we have replaced the water pump,the radiaor,the thermostat and flushed the water system and it still is running HOT on the highway!!PLEASE HELP
bad headgasket...
Patrick

Jonesborough, TN

#1451 Sep 11, 2011
I have an 04 Trailblazer with 4.2. It has a whine that sounds electrical. However, replacing the alternator did not make a difference. I have never heard a water pump make this type of noise. I have no leaks or overheating issues. Whine increases an decreases with acceleration and deacceleration. Belt is new. Power steering it not the problem. Fan clutch works fine and it whines whether engaged or not. Any ideas I haven't thought of? I am a Master ASE technition that has never had this particular problem I could not find.
JOHNNY C

Fremont, CA

#1452 Sep 13, 2011
I have a 2005 Buick LaCross (automatic) and the problem is SOMETIMES (about 25%of the time) the shifting is very hard, other times it is smooth as can be?

I had the transmission fluid pressure drained and fill with fresh fluid last week. Today it started shifting hard again.

What do you suggest?

Thanks so much!
eddie g

Cerritos, CA

#1453 Sep 24, 2011
I have a Ford Crown Vic 1999 with 60,000 original miles and once a week trying to get it out of the garage is a nightmare. Car starts fine but when I put it gear it stalls. The rest of the week its fine.

Need some advise!

“Treat each day as your last, ”

Since: Sep 07

Location hidden

#1454 Sep 29, 2011
Patrick wrote:
I have an 04 Trailblazer with 4.2. It has a whine that sounds electrical. However, replacing the alternator did not make a difference. I have never heard a water pump make this type of noise. I have no leaks or overheating issues. Whine increases an decreases with acceleration and deacceleration. Belt is new. Power steering it not the problem. Fan clutch works fine and it whines whether engaged or not. Any ideas I haven't thought of? I am a Master ASE technition that has never had this particular problem I could not find.
I have two master tech's working for me and I have never, and I mean never heard one of them say "I can't" or see them replace a part on a guess, makes me wonder about your certification.

Well, it don't matter and I won't worry about that right now, you need help, I'll give you a few pointers. Stethoscope, remove the serpentine belt and listen, this will eliminate the timing chain components, When the belt is off, spin the water pump, belt pulleys and new alternator by hand ( engine off !) This should send you in a direction anyways, Good luck ASE guy...
Vito enke

United States

#1455 Oct 16, 2011
I have a f150 300 when warm sputters at idle why if I switch to my rear tank dose no do it
GMC

United States

#1456 Oct 18, 2011
My truck is truning hard to the right but not the left and one person says power steering other says rac and pinion ! its 2004 GMC 4 wheel drive. When your going 5 miles hour or faster its easy. its makes a noise like power steering.

Tell me when this thread is updated:

Subscribe Now Add to my Tracker

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Monterey Discussions

Title Updated Last By Comments
Messianic Jews say they are persecuted in Israel (Jun '08) Jan 22 JOEL 71,538
Multiple suspects in custody for Seaside shootings Jan 15 Anonymous 1
Peninsula high school students arrested in 'fig... (Sep '09) Jan 7 trey 108
Other border states shun Arizona's immigration law (May '10) Jan 6 colton case 9,053
Kristen Scannell Saratoga Springs NY Adds New H... Dec '14 Kristen Scannell ... 2
Carmel River diverted to allow dam removal, pre... Dec '14 Clint 1
Calif. cop may be fired for giving suicidal stu... Dec '14 John Smith 1
Monterey Dating
Find my Match
More from around the web

Monterey People Search

Addresses and phone numbers for FREE

Personal Finance

Mortgages [ See current mortgage rates ]

NFL Latest News

Updated 9:10 pm PST