Toyota Highlander Radio Problem

Toyota Highlander Radio Problem

Posted in the Toyota Highlander Forum

First Prev
of 3
Next Last
Wayne

Montréal, Canada

#1 Aug 2, 2010
My 2009 Highlander Radio works properly when the weather is warm. When it gets colder, it will not go on or if it does, it will not change stations and does not function well at all. It can be on FM mode but play AM stations. Very strange things, like the CD coming out by itself. They have changed the radio once already and claim this is an isolated case. Unfortuately, it does not do this all the time and generally, when the truck warms up ( on the way to the dealer the problem goes away so they argue the radio is fine. Has anyone had a similar issue?
pat o

Mesa, AZ

#2 Aug 10, 2010
I don't have that problem, but for about a year now the volume knob doesn't work properly. If I turn it, the volume may go up OR down. There is absolutely no logic to it. Of course this 2005 Highlander is out of warranty, but this is an irritation- it does have other real problems too!

Since: Nov 10

Rochester, NY

#3 Nov 13, 2010
Wayne wrote:
My 2009 Highlander Radio works properly when the weather is warm. When it gets colder, it will not go on or if it does, it will not change stations and does not function well at all. It can be on FM mode but play AM stations. Very strange things, like the CD coming out by itself. They have changed the radio once already and claim this is an isolated case. Unfortuately, it does not do this all the time and generally, when the truck warms up ( on the way to the dealer the problem goes away so they argue the radio is fine. Has anyone had a similar issue?
My 2009 Highlander is having the exact same problem. Dealer has ordered another radio. Hope this is the solution.
David

Hampton, VA

#4 Mar 3, 2011
My 2009 Highlander Radio has been change at 7716 miles because the volume knob was not working properly. Now the ASL is not working.Took it in on Mar.3,2011.Was told that the dealer would call the factory on this problem and run the tech through the operations to fix this problem.
June

Atlanta, GA

#5 Mar 30, 2011
I'm having the same issue. When the truck has been on for about 10 minutes the problem corrects itself. The problem: turn on the truck, radio starts to eject CDs and the display is off. The radio will come on once all the CDs are removed but I can't change stations or use any of the preset channels. Clicking a preset button will attempt to eject another CD. The display will remain off throughout the whole process. I just have to leave it alone while I wait for the display to come on.
Very odd. I'll do more research and contact Toyota.
Mel

Memphis, TN

#6 Jul 31, 2011
My 2009 Highlander has had the same type of problems. The first time it occurred during the winter of 2010 and now again the summer of 2011. They replaced it last year and I was wondering if it was actually changed out because it's happening again.
It seems to occur during extremem temps rather cold or hot. My vehicle is still under warranty and I'd like to get to the bottom of it soon.

Arlington, TN
Sarah J

San Diego, CA

#7 Sep 26, 2011
Looks like this is a common issue with the Highlander radio. My radio will do odd things like turn itself off, eject the cd, and not allow me to change stations and/or adjust the volume. I had this same issue "corrected" last year, but it's happening again.
MIKE

New Cumberland, PA

#8 Oct 19, 2011
My 2010 Highlander same type of problem, No screen
display every time you turn it on or off starts
shooting out CD. Dealer has ordered a new unit
hope this one works.
Mike B

Saint Paul, MN

#9 Nov 14, 2011
In the past two weeks, my 2008 Highlander began having the same problem. Starting the car in the morning with the outside temp droping into the 30s the CD player ejects all CDs, the radio is stuck on one station and the display is off. As the car warms up, the radio starts allowing channel changing, the display slowly returns to normal and the CD player operates. Has someone come up with a solution that does not involve replacing the radio system?
Karen

Columbus, NE

#10 Jan 16, 2012
I could not get my radio to work this morning in my 2010 Highlander on the way to work, so I googled and found these reports. Amazing this is happening to others. My Highlander displays the volume and stations, but no sound. CD seems to work except for the volume.
Patrice

Wilmington, NC

#11 Jan 25, 2012
Im having the exact same problem with my radio its annoying trying to drive and catch cds that are spitting out.....
Wayne wrote:
My 2009 Highlander Radio works properly when the weather is warm. When it gets colder, it will not go on or if it does, it will not change stations and does not function well at all. It can be on FM mode but play AM stations. Very strange things, like the CD coming out by itself. They have changed the radio once already and claim this is an isolated case. Unfortuately, it does not do this all the time and generally, when the truck warms up ( on the way to the dealer the problem goes away so they argue the radio is fine. Has anyone had a similar issue?
Tom Washington Pa

Washington, PA

#12 Feb 20, 2012
MIKE wrote:
My 2010 Highlander same type of problem, No screen
display every time you turn it on or off starts
shooting out CD. Dealer has ordered a new unit
hope this one works.
I'm having the same problems with my 2009 Highlander..display will not work..can't chamge stations...and CD chnager does not work...
Bryan

Jacksonville, FL

#13 Mar 2, 2012
I also have a 2009 Highlander and my radio does something similar, though apparently independent of temperature. It will either come on with no display and if you hit either the AM or FM button the CD ejects itself, and still no display. Or more frequently the display will go to all mostly solid black figures and you can't tell what station you are on, and it won't let you change stations. I found if I completely shut off the car and restart (may take a couple of trys) the display will clear and things will be fine for a day or so before it starts over.
Don -Gresham Oregon

Portland, OR

#14 Apr 5, 2012
I to am having the same problem. We are on our 3rd radio. Also does anyone's RDS (tex) feature work? the station and song name should display on the screen when you press the button. Our radio will go off, eject CD's and at times the screen will just go black and you can't change channels.
Phil

Toledo, OH

#15 Apr 7, 2012
Karen wrote:
I could not get my radio to work this morning in my 2010 Highlander on the way to work, so I googled and found these reports. Amazing this is happening to others. My Highlander displays the volume and stations, but no sound. CD seems to work except for the volume.
My 06 Highlander does the same thing... Have you found out what causes this problem?
Chris

Austin, TX

#16 May 9, 2012
I have a problem that my Highlander radio will not switch to AUX. I press the AUX / CD button and it only goes to CD. Everything else seems to work fine but it just won't switch to AUX mode for me to listen to my Iphone.
Nick

United States

#17 Jun 6, 2012
Having the volume knob issues with my 2010 Highlander's 6 disc changer. Sometimes the volume knob works, other times when I turn it up or down nothing happens. What's odd is I can then turn the car off, turn it back on and sometimes it works fine, or works for a certain amount of time then stops again.

Just started noticing it happening this spring @ 45k miles so I'm out of warranty.
Joe Burlington VT

Burlington, VT

#18 Jul 25, 2012
My 2008 hylander's radio has these symptoms. At any time while driving the radio will show what looks to be in a bar graph mode. It continues to play but you cannot tell which station you are on. While attempting get station info back my cd player will open and eject a disk. When I try to switch modes it switches but the bar graph will remain on the screen. While continuing to drive sometimes it will change back to normal. At other times it will completely go blank but continues to play. The problem seems more prevalent lately. It seems to return to normal when i turn off the vehicle for awhile. I haven't reported this to my dealer as I'm sure they will tell me it is out of warranty and I would have to buy a new radio? Can anyone advise possible solutions other than investing in a new radio which may not solve the issue as reported in others above?
Lee - Upper Marlbobo MD

District Heights, MD

#19 Jul 31, 2012
2010 Highlander - no display on radio - mainly static - occasional weird station pops up and plays (no display though).
It worked briefly this a.m., then went to change Bass - stopped working. No display again (lit up briefly with nonumbers). Crazy - have appointment with dealer. Have Platinum plan - have to read gobbledegook to see if covered.
stangcbr

Panama City, FL

#20 Sep 8, 2012
pat o wrote:
I don't have that problem, but for about a year now the volume knob doesn't work properly. If I turn it, the volume may go up OR down. There is absolutely no logic to it. Of course this 2005 Highlander is out of warranty, but this is an irritation- it does have other real problems too!
I just fixed eratic volume problem: Here is how:

1) Pull off bezel around radio and A/C controls.
2) Pull out radio and A/C assembly (6 x 10mm bolts and wires harnesses)
3) Remove the radio from the assembly (9 x 8mm bolts) and pry out of metal brackets. You have to pry the metal brackets away from radio since there is an alignment pin on each side.
4) Pry off the front face of the radio using flat head screwdriver and a little force. When I say face, it includes everything including display, aesthetic plastic bezel and cover, knobs, buttons, etc)
5) Remove circuit board (5x small philips screws, if I remember the quantity right)
6) Pull off the volume knob.
7) Drip generous amount of rubbing alcohol into and around the potentiometer and repeatidly turn it multiple times. You could probably use electric spray cleaner too. Both will wick their way into the part.
8) Use compressed air to blow out and dry up any remaining cleaner. Ensure all is nice an dry before powering up.
9) Reassemble in reverse order and test.

Mine worked like a charm. I will just have to see how it holds up over time. Good luck!

Tell me when this thread is updated:

Subscribe Now Add to my Tracker
First Prev
of 3
Next Last

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Toyota Highlander Discussions

Title Updated Last By Comments
highlander tail/brake light problem (Jul '07) Jul 22 Dave- St Louis 152
Need 2012 Highlander rear control knob Jul 22 Burger 1
2008 Toyota Highlander VSC and ABS light Jul 2 mzjessecantu 1
Highlander door lock actuator (Aug '10) Jun '16 Ben 141
Mass airflow sensor unplugged... Jun '16 Djpikey5 1
2006 Highlander Hybrid AM radio static May '16 Ira 1
News Fuel-sipping electric now fun to drive Mar '16 Solarman 1
More from around the web