2006 Forester - Check Engine light on and Cruise Control light blinks

Posted in the Subaru Forester Forum

Comments (Page 4)

Showing posts 61 - 80 of375
|
Go to last page| Jump to page:
Tim Thielke

United States

|
Report Abuse
|
Judge it!
|
#64
May 27, 2009
 
Check engine light and flashing cruise control light. Was told last time it was fuel sensor on top of gas tank -$800 to fix. Reset computer and it was fine a while - but now doing it again. Not really excited about spending that kind of money to turn off a light - what is the fuel sensor "sensing" anyway?

“Life is good...”

Since: Dec 06

Location hidden

|
Report Abuse
|
Judge it!
|
#65
May 27, 2009
 
Mine has been fine since the tune up and new cataytic converter. Covered under warranty up to 80,000 miles.

It's so weird that all of us are getting different readings.
sue

United States

|
Report Abuse
|
Judge it!
|
#66
Jun 1, 2009
 
2009 outback (automatic)- 3000 miles - drove from ky to florida and the check engine and traction control lights both came on and the cruise went to flash. subaru dealer said i had a faulty gas cap, and it was replaced.......200 miles into my drive back to ky SAME THING. previous car was a 2001 outback(manual), and never had such problems?
Shelby

Danville, KY

|
Report Abuse
|
Judge it!
|
#67
Jun 14, 2009
 
I have an 09 Forester and I, too, have experienced the CEL and flashing cruise control light with decreased power. I immediately called the dealer and they told me to bring it in on Monday. The service manager told me that if the CEL is not flashing then it's not serious. Driving on the interstate at 25mph is pretty serious to me. In any case, after I shut off the engine and restarted the power returned but the lights remained on. After another restart two hour later, the lights went off. All was fine for one day (limited driving) on the second day the same thing happened again. First restart and the power returned...second restart and the lights were off. Very disconcerting for a vehicle that has 6,100 miles on it. Still have an appointment for Monday. I will advise how that goes...looks like I'm up for an oxygen sensor replacement.
Scott

Sioux Falls, SD

|
Report Abuse
|
Judge it!
|
#68
Jun 22, 2009
 
I have a 2005 Legacy turbo. Check engine and flashing cruise for no apparent reason, no rain and car ran fine. I disconnected the negative battery terminal for a minute and hooked it back up-no light "yet" but of course radio etc needed to be reset.

“Life is good...”

Since: Dec 06

Location hidden

|
Report Abuse
|
Judge it!
|
#69
Jun 23, 2009
 
Scott wrote:
I have a 2005 Legacy turbo. Check engine and flashing cruise for no apparent reason, no rain and car ran fine. I disconnected the negative battery terminal for a minute and hooked it back up-no light "yet" but of course radio etc needed to be reset.
When mine started to blink, my husband did this and it works for a while. The garage also reset it a few times.

Still working after converter replacement, 2000 miles later.
J in Maine

Rockland, ME

|
Report Abuse
|
Judge it!
|
#70
Jun 24, 2009
 
J in Maine wrote:
after warranty they will try and not honor the repair....they deny any problems.....this is very frustrating...no reply from corp office.....very disappointed with customer service....
<quoted text>
YES !! AFTER WARRANTY EXPIRES THEY WILL NOT HONOR ANY REPLACEMENT OF OXYGEN SENSORS...HAVE NOT HEARD FROM SUBARU USA AFTER SEVERAL EMAILS AND LETTERS. MY 05 SUBARU HAS 46K MILES AND I THINK WHEN IT HAPPENS AGAIN I WILL FIND A LOCAL GUY TO REPLACE THE SENSOR - WILL NEVER BUY SUBARU AGAIN, AM LOOKING AT HONDA CRV. CAN'T WAIT TO GET RID OF THE FORESTER - DEALER IN MAINE NOT HELPFUL AT ALL.
good luck all subaru owners!!
J
RubySubie

Nutley, NJ

|
Report Abuse
|
Judge it!
|
#71
Jun 25, 2009
 
just got a 2006 Forester, used, and my check engine light is on, and the cruise control light is blinking. In my manual, it says that this can happen if you hit the cruise control button while turning the ignition. It gave instructions on how to get rid of it, and that worked two or three times when the lights came on. Now, they won't go off, so I took it into a shop, and they said that I had a problem with the secondary air injection pump, that it locked up. Like a fool, I didn't purchase the warranty, and now they want almost $650 to fix it....

It seems as though this check engine/cruise control light situation is an issue for several people, has anyone else been told this diagnosis?
Outback 2006

Churchton, MD

|
Report Abuse
|
Judge it!
|
#72
Jul 1, 2009
 
I am having the same problem. My Outback has 144k and the Check Engine started lighting together with Cruise Control flashing few months ago. The dealer said the catalytic converter is bad and asked me for $900 to fix it. After three months passed I changed the catalytic converter. Guess what - no cheaper option - only original Subaru parts at a very high price. I went out of the dealer and after 40 miles the light is back on.
Thomas

Chatham, NY

|
Report Abuse
|
Judge it!
|
#73
Jul 18, 2009
 
ok i've read all the previous posts and have a similar situation. This is regarding a 2005 Forester with 95,000 miles on it, my daily commute is 70 miles round trip (all highway). the car recieves regular oil changes every 5000 miles w/ synthetic and gets a new air filter anually, I check and maintian all fluid levels regularly and wash the engine bay every spring without incident. The last few days have been very wet, flooding roads and torential rain in fact, last night on the way home I started up my drive which is a steep hill, The car's power seemed as if the ac was on so I applied the gas, the Check engine light started blinking as well as the cruise control light. the engine started skipping and sputtering the rest of the way even at idle. From what I've read so far it could be any number of things, though it seems most likely to be an electrical short or failure. IE: plugs, wires, wetness, MAF and possibly an O2 sensor. The engine seems dry so I am compelled to run a compression test to eliminate the possibility of a blown head gasket. these cars are also equiped with rubber gaskets sealing the valve cover from the spark plug port, if oil gets into the plug port it can short the plug out (this happened in my 99 Impreza RS at 100,000 miles)I checked this on the Forester and dosen't seem to be an issue yet. I have already checked the fuses (all ok) and will next try disconecting the battery and checking the gas cap (I did reciently refuel)to cover the basics. Troubleshooting is key with any problem and I will let you know later how I make out.

“Life is good...”

Since: Dec 06

Location hidden

|
Report Abuse
|
Judge it!
|
#74
Jul 18, 2009
 
I hope it's an easy fix. I'm thinking my problem started as an engine misfire, and maybe the oil shorted out the plug like you said. Then, it blew out the converter. Regardless, the tune up and new converter, knock wood, are still ok.
Norm

Granby, CT

|
Report Abuse
|
Judge it!
|
#75
Jul 20, 2009
 
2006 Forester with 31,275/ Good weather. Turned onto my road and it missed a couple of times. Next time I started it up CEL varied between solidly on and flashing. Cruise control light came on and stayed on. Very rough running. It is always gareged. Temperture has been ranging between upper 50s at night to lower 80 during day. Live in CT. Dropped car off at dealer and am waiting a diagnosis. I will let everyone know what the dealer says. This particular dealer does not have a good reputation. First time I have gone to him.
Thomas

Chatham, NY

|
Report Abuse
|
Judge it!
|
#76
Aug 8, 2009
 
Well after a turbulent week of family life work and car issues I still had a sputtering car. I replaced the valve cover seals and gaskets because they were beginning to show signs of leaking, which is common on Subaruís at 95000 miles. I also replaced the Plugs and plug wires and boy the plugs were shot,#1 & #3 had no electrode left. The car ran a little better but now had a pronounced skip (a misfire in one or two of the cylinders) I don't have the proper diagnostics tools to isolate electrical problems so I was relegated to a dealer visit that cost $90 and a very frustrating 2 days of no feedback. After 2 days I had no choice but to just go down to the dealer and make them show me what they had found so far. The technician said that the skip miraculously cleared up on the second day of fiddling with it and determined that the Ignition coil was no longer waterproof, he demonstrated this by squirting water on the ignition coil with a spray bottle and sure enough the skip returned. In short I waited 2 more days for the part, I replaced it myself in 20 minutes and it solved the problem. The check engine light and blinking cruise control light immediately stopped. My mileage went from 26 highway to over 29 highway in one tank of gas just because of the tune up, and the car has slightly more pep (slightly). Hope this helps you diagnose your problem, good luck.
2006 Forester

United States

|
Report Abuse
|
Judge it!
|
#77
Aug 12, 2009
 
Same thing happened to me after a long, heavy rain... check engine light and blinking cruise light. Normally, I have my car parked in the garage, but two days ago we had an awful thunderstorm with heavy rain that flooded out the end of my driveway and portions of the road. It does seem like there's a sensor issue brought on by heavy rains and moisture. Haven't taken the car in for repairs yet or to get another diagnosis.
alex

Saint Augustine, FL

|
Report Abuse
|
Judge it!
|
#78
Aug 18, 2009
 
I had the same exact problem occur in my 2006 Forester (low idle, check engine, flashing cruise, just changed battery). Was your problem resolved? If so, how?

“Life is good...”

Since: Dec 06

Location hidden

|
Report Abuse
|
Judge it!
|
#79
Aug 18, 2009
 
alex wrote:
I had the same exact problem occur in my 2006 Forester (low idle, check engine, flashing cruise, just changed battery). Was your problem resolved? If so, how?
Mine was resolved when they replaced the catalytic converter and did a tune up. Almost 7000 more miles and fine. If you have fewer than 80,000 miles, it's covered.
CCrider77

Torrance, CA

|
Report Abuse
|
Judge it!
|
#80
Aug 23, 2009
 
Another CEL + flashing CC light report. Ours is an 05 Subie Forester with 104,000 miles on it. It's a Southern California car and is rarely exposed to moisture or cold weather. It never goes off-road and we try to avoid hitting small animals with it...

Gas tank at ~3/4 full (or 1/4 empty if you're a pessimist), cruise control on, going 70 MPH when suddenly the cruise shuts off, light starts flashing and the car will not exceed 45 MPH. Apparently it went into "safe mode". The engine starts and runs fine. Fluid levels are correct, gas cap is tight, no unusual noises and the engine is bone stock. Air filter is clean too.

We're taking it to a trusted local mechanic for a diagnostic. I hope this isn't one of those "rinse and repeat" deals where we have to do this several times. I personally prefer my shampoo and conditioner mixed together.
George

Wheeling, IL

|
Report Abuse
|
Judge it!
|
#81
Aug 27, 2009
 
I have a 2005 forester w/ 58K miles. Every time we have any significant rain, the CEL goes on, the CC flashes and the engine idles rough. It has been doing this for about 8 months. I have not had the time to take it to the dealer for a checkup, but the problem seems to clear up once the car warms up (dries out?). That being said it is very annoying; if anyone has, encountered this issue and found a solution, or has encountered the problem and identified the cause I would love to know.

Thanks.
CCrider77

Moorpark, CA

|
Report Abuse
|
Judge it!
|
#82
Aug 27, 2009
 
CCrider77 wrote:
Another CEL + flashing CC light report. Ours is an 05 Subie Forester with 104,000 miles on it. It's a Southern California car and is rarely exposed to moisture or cold weather. It never goes off-road and we try to avoid hitting small animals with it...
Gas tank at ~3/4 full (or 1/4 empty if you're a pessimist), cruise control on, going 70 MPH when suddenly the cruise shuts off, light starts flashing and the car will not exceed 45 MPH. Apparently it went into "safe mode". The engine starts and runs fine. Fluid levels are correct, gas cap is tight, no unusual noises and the engine is bone stock. Air filter is clean too.
We're taking it to a trusted local mechanic for a diagnostic. I hope this isn't one of those "rinse and repeat" deals where we have to do this several times. I personally prefer my shampoo and conditioner mixed together.
Follow up - we drove the Subie to our local mechanic, he read the codes and it said it was due for an oil change - it was right! We were overdue on the oil change, our bad. So no biggie and all is well. On to the 200,000 mark...
Kens mom

Englewood, CO

|
Report Abuse
|
Judge it!
|
#83
Aug 27, 2009
 
I have 2006 Forester with 15K mile. Just had 15K maintenance on last Thursday, then Check Engine light and Cruise Control indicator came on 4 days after the scheduled maintenance.
Anyway, had the dealership checked it and I was told that
"Found faults for CAT converter, Replaced CAT Converter".

Tell me when this thread is updated: (Registration is not required)

Add to my Tracker Send me an email

Showing posts 61 - 80 of375
|
Go to last page| Jump to page:
Type in your comments below
Name
(appears on your post)
Comments
Characters left: 4000
Type the numbers you see in the image on the right:

Please note by clicking on "Post Comment" you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Other Recent Subaru Forester Discussions

Search the Subaru Forester Forum:
Topic Updated Last By Comments
lights stay on (Oct '09) Thu Damien 11
Warning lights problem 2009-Subaru Forester 2... (Feb '11) Apr 1 Martin Melbourne Aust 86
Engine light and flashing cruise control light Feb '14 Les 1
Subaru Forester won't start after "repair" for ... (Jan '11) Feb '14 Terry 10
My 2000 Forester will not start in single digits Jan '14 Jamie 1
06 Subaru Forester X Premium Overheats (Aug '06) Dec '13 ttrindadt 10
ASK THE AUTO DOCTOR: Good solutions available f... (Mar '09) Dec '13 liner 17
•••

Buy a New Car


Zipcode:
•••
•••
•••