Warning lights problem 2009-Subaru ...

Warning lights problem 2009-Subaru Forester 2.5 ltd

Posted in the Subaru Forester Forum

First Prev
of 7
Next Last
Patricia Rose

Lakewood, NJ

#1 Feb 4, 2011
Last night, three warning lights suddenly illuminated on my dashboard--check engine, cruis (flashing) and vehicle dynamics control warning light. Has anyone had this happen?
09 Subu Foro Dude

Harrison, AR

#2 Mar 19, 2011
Lots talk about it on this thread:

http://www.topix.com/forum/autos/subaru-fores...

My 09 is doing it also ~ dealer says they don't know ~ which amazes me since so many people across the board are having the same problem(s).

Good luck and post when/if you find something out!
Dil

Mississauga, Canada

#3 Apr 26, 2011
Usually most of case two ting effect this problem,
first one is just car computer give some mistake you can disconnect battery both cable (pulse and minus)
one night and morning put back,just like your desktop or laptop reset should be OK.
Second one is car O2 sensor has problem, because this O2 sensor watching inside exhaust gas's O2 gas concentration and give computer signal after computer adjust air and gas ratio to give to engine, if O2 sensor not working and computer can not get signal from O2 sensor and give alarm. This case high possibly need change O2 sensor.
Farrmer

Bella Vista, Australia

#4 May 21, 2011
2008 Forrester same as Patrica Rose - Happened twice and dealer changed the cat. converter. Next time had almost no power - they changed the "coil" this time after 30km at 100k cruise control dropped out and the three lights came on again - My wife is goinf to drive our 1989 Brumby until I (or someone) can prove that it will actually get somewhere.
M C R

United States

#5 Jun 23, 2011
My engine light came on again but I found out it will do that when my gas cap isn't on correctly. Once , I checked and tightened the cap it was fine.
mcr other than above I haven't had a problem with the engine light / cruise control since I disconnected the battery and reconnected it. Thank goodness for this web site --it saved me a lot of time and $
mcr
Dee

Palmyra, NY

#6 Aug 16, 2011
I have had this problem 3 times. The check engine light steady, cruise light flashing and traction control steady. Each time they can't find anything wrong, shut them off and a few days later they comes back on. This only started happening just after the car turned 60,000mi. Getting pretty annoyed!
Patricia Rose wrote:
Last night, three warning lights suddenly illuminated on my dashboard--check engine, cruis (flashing) and vehicle dynamics control warning light. Has anyone had this happen?
pacratt

Blue Island, IL

#7 Sep 26, 2011
I was driving to work when my cruise suddenly kicked off and the "Check Engine" light came on solid, while the "Cruise" light was flashing.
Over tis past weekend, I disconnected the negative battery terminal and left it sit for about 3-hours.
The warnings are gone and the cruise control works again, which means it was probably a sensor mis-cue.
I sugest this as the first step before spending $$ on diagnostics and unneeded parts.
Kari

Lafayette, IN

#8 Nov 16, 2011
My husband and I just purchased a used 2009 Forester 2.5x Premium with 36k miles last week and the Check Engine, Vehicle Dynamics, and Cruise Control lights are all on now. Ugh. I can't tell if the car is driving funny since I'm so new to it. We're going to get it checked out -- such a bummer to have this happen so soon.
Joan Pirrrotta

Pawtucket, RI

#9 Jan 26, 2012
This morning, thats exactly what happened to me driving to work. check engine, cruis (flashing) and vehicle dynamics control warning light. Did you get it fixed, what was it?
Patricia Rose wrote:
Last night, three warning lights suddenly illuminated on my dashboard--check engine, cruis (flashing) and vehicle dynamics control warning light. Has anyone had this happen?
09Subie

Saint Paul, MN

#10 Feb 6, 2012
Im having the exact same problem and they are saying its the spark plugs then the fuel injectors then that I need a tune up. Im at 37K and had it in the shop 3x in the last month. They dont know what it is but it feels like its trying to downshift when I give it gas, sometimes it feels like it doesnt want to get out of 1st gear. I am VERY unhappy to say the least!!
2011Forrester

Ashburn, VA

#11 Feb 13, 2012
This happened to me earlier this month; dealer here in Colorado says it is a software bug. We are scheduled to get a software patch later this month when the Subaru representative is in town (the local dealer is not allowed to apply software patches). The local dealer did clear the error codes.
Jay

Chicago, IL

#12 Feb 23, 2012
My 2011 Subaru Forester has 20k miles. Same thing happened to me today when I started it up to drive home from work. I called the dealer and he said to check the gas cap. I did and it wasn't tight- my son filled up the tank last. Waiting right now to see if that will make the traction and blinking cruise lights (and CEL) go away. I'll update later.
2009 forester

Toronto, Canada

#13 Mar 1, 2012
I am having same issue, check engine light and vehicle dynamics control steady and cruise flashing. Took in yesterday, said spark plug misfire, they replaced. Same lights came on again today. Back to dealer tomorrow.
At 58,000 km, warranty out soon.
Good luck everyone.
2010 Forester

Aurora, OH

#14 Mar 14, 2012
Same problem here - check engine light steady, vehicle dynamics control steady and cruise flashing. Why hasn't Subaru addressed this issue - it obviously spans a number of years and models. Wish I had known that before I bought the car. I also just had to have the tire pressure monitor system replaced on the front driver side because it was malfunctioning. Car has less thsn 17,000 miles on it. Not happy. How did Subaru get such good ratings for reliability?
Rob-2012 Forester-1600km

Barrie, Canada

#15 Mar 21, 2012
I left the dealership today after getting the winter tires taken off. Within 5 minutes of driving, the check engine light and the vehicle dynamics control light came on (steady), as did the cruise light (flashing). When I look at the other posts, I'm a little worried, as Subaru doesn't seem to know how to fix this. I'll take it in tomorrow and see what happens...
Ellen

Yonkers, NY

#16 Mar 25, 2012
I had this happen on my vehicle. The dealership told me something like it was a valve in the gas tank that needed to be replaced. That was about a year ago and the vehicle had maybe 30k miles. Now the lights are on again and the car has only 43k miles.
Ron Pyke

United States

#17 Apr 1, 2012
2011Forrester wrote:
This happened to me earlier this month; dealer here in Colorado says it is a software bug. We are scheduled to get a software patch later this month when the Subaru representative is in town (the local dealer is not allowed to apply software patches). The local dealer did clear the error codes.
Same thing for my 11 Forester yesterday (3/31/12) atop Vail Pass in Colorado. Had to be towed to Subaru dealer in Thornton. Check Eng, Vehicle Dyn, and Cruise lights all on. Let's see what service dept says Monday!
VERY frustrating, as car has <10K mi and I am 1000 mi from home. Had been told Subies are reliable.
Callum

Olathe, KS

#18 Jun 10, 2012
Same thing here - although it's more of an annoyance for my wife's 2009 forester. Dealer always says its the gas cap - but we're fully capable of twisting a gas cap correctly. I've read on other posts that the codes clear after 20 starts - but a tech told my wife to hold down the trip reset and turn the ignition on 3 times. That worked a few times in the past. This last time it didn't - the kicker was we were about to head out on a 3hr road trip with the cruise control was deactivated - not ideal.... I'll end up disconnecting the battery to let the ECU reset...
Frank

Berkeley, CA

#19 Jun 16, 2012
Obviously, Subaru has known about this for a number of years. My 2012 Outback has had the problem twice (at 300 and 3800 miles). Each time, they have asked me to check the gas cap (sound familiar?) and each time they said to take it to the service dept. There, they scan it and if nothing's wrong, reset the unit. I want them to fix it or take back the car.
Ellen

Passaic, NJ

#20 Jun 19, 2012
Same thing here - my 2009 subaru forester has only like 35000 miles on it and is due for a state inspection. Glad I found this information first before going into auto shop.

Tell me when this thread is updated:

Subscribe Now Add to my Tracker
First Prev
of 7
Next Last

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Subaru Forester Discussions

Title Updated Last By Comments
2006 Forester - Check Engine light on and Cruis... (Jan '07) Jul 26 Bernhardt 398
Engine swap Jun '17 Gary 2
2017 starlink radio removal Jun '17 Luvmysubie 1
2014 Subaru Forester Limited (Nov '16) May '17 fmhs 2
2001 Forester Problems - Need Advice! (Aug '07) Mar '17 Dave M 3
How do I get access to the Intake fuel filter i... (Dec '16) Dec '16 Kellyj86 1
burning smell from heater (Feb '09) Dec '16 Rebecca 8
More from around the web