Pontiac Grand Am: Problems & Solutions

Pontiac Grand Am: Problems & Solutions

There are 1294 comments on the Edmunds.com story from Jun 12, 2006, titled Pontiac Grand Am: Problems & Solutions. In it, Edmunds.com reports that:

Created by khudson33 in the Pontiac Grand Am Message Board. Your Host is pat What is this discussion about? Pontiac Grand Am, Sedan, Auto Repair # 25 of 34 HELP!!!! by littleone9 May 30, 2006 I've got a 99 ...

Join the discussion below, or Read more at Edmunds.com.

Mike

London, Canada

#582 Jan 7, 2008
i have a 93 grand am 3.3l V6.couple days ago i was driving home and it suddenly died ,i got it towed home and i started to check for the problem and i can't figure out what it might be.when i turn the ignition on everything works inside the car except the guage cluster dosent respond,the engine cranks but dosen't start ,after a couple atempts it starts and runs for couple minutes and than dies again,would anybody know what could be the problem.com uter???????
thegrayghost

Bluefield, WV

#583 Jan 7, 2008
I've go a 92' Grand Am.. It was turning over but wouldnt start. now my starter isnt enguaging. Got a new on, but still wont start.. what's the prob. some on please help me out on this one..
HDrider

Meadville, PA

#584 Jan 11, 2008
got a 94 grand am. what mileage can i expect
Belinda

Mendon, MA

#585 Jan 16, 2008
i have 1987 pontiac grand am 4dr 6cyclinder engine.service engine light is on and it telling me when we tested it,that it was the MAP sensor.but there is not one for this car. we checked everywhere. and called everyone.please help.
Ash

Greensboro, NC

#586 Jan 21, 2008
i have a 1999 Grand Am Pontiac the trac off button keeps coming on and it stalls after you hit 50mph it stops but it takes for ever for it to get there! The abs light was coming on but its not anymore the service engine light is still on though! can anyone tell me how to fix it please!!!
mike

Tillsonburg, Canada

#587 Jan 21, 2008
Mike wrote:
i have a 93 grand am 3.3l V6.couple days ago i was driving home and it suddenly died ,i got it towed home and i started to check for the problem and i can't figure out what it might be.when i turn the ignition on everything works inside the car except the guage cluster dosent respond,the engine cranks but dosen't start ,after a couple atempts it starts and runs for couple minutes and than dies again,would anybody know what could be the problem.com uter???????
nevermind of to junk jard it goes..........
Beth

Ellensburg, WA

#588 Jan 31, 2008
We just got a 99 Grand Am and sometimes it won't go into the off position on the ignition switch. We have to restart the car, put it in reverse then back into park, and then it comes out. What causes that
Debbie

United States

#589 Mar 10, 2008
I have a 99 grand am and it shakes after you hit 50 miles ,I put new ball joints and new tries and front end lined anymore can help please
jesse

United States

#590 Mar 10, 2008
Debbie wrote:
I have a 99 grand am and it shakes after you hit 50 miles ,I put new ball joints and new tries and front end lined anymore can help please
Youre frame is junk it was in a wrack
Stan

United States

#591 Mar 10, 2008
Debbie wrote:
I have a 99 grand am and it shakes after you hit 50 miles ,I put new ball joints and new tries and front end lined anymore can help please
youre car was in a wrack and the frame is junk
Stan

United States

#592 Mar 10, 2008
jesse wrote:
<quoted text> Youre frame is junk it was in a wrack
Mike youre car was in a wrack and the fram is junk
Kenny

United States

#593 Mar 10, 2008
thegrayghost wrote:
I've go a 92' Grand Am.. It was turning over but wouldnt start. now my starter isnt enguaging. Got a new on, but still wont start.. what's the prob. some on please help me out on this one..
try adding starter shims and check starter wirers
Debbie

United States

#594 Mar 10, 2008
Beth wrote:
We just got a 99 Grand Am and sometimes it won't go into the off position on the ignition switch. We have to restart the car, put it in reverse then back into park, and then it comes out. What causes that
my car did the same thing ,I went to a locked smith and got new keys made maybe that will work for you good luck
Steve

United States

#595 Mar 10, 2008
youre car was in a wrack and the fram is treek Layton utah
Kevin

Virginia Beach, VA

#596 Mar 18, 2008
Can anyone tell me where the map sensor is located on a 97 Grand Am SE 2.4L? My car is reading lean in bank one but is burning rich. I think the map sensor is reading a different manifold pressure. 8in vs 18in
Dan Amundsen

Saint Paul, MN

#597 Mar 19, 2008
I have a 95 Grand Am with the DOHC 2.3 L4 engine. Wondering why in the hell it is stalling constantly. It will accelerate, and then stall and die. You have to let it cool down for a couple hours before it will start back up again. Why is that? I know it constantly overheats, as 75% of these POS cars do... but why does it not start? and why does it run rough? Ive redone the head, gaskets, valves, radiator, intake gasket, exhaust gasket, thermostat, EVERYTHING... I wanna drive this car off a cliff. Please help me!
lowrunner

Kellogg, ID

#598 Mar 22, 2008
ok ! what i have is a 1996 pontiac grand am 2.4L dual overhead cam,electronic ignition.(IDI) "Intergrated Direct Ignition". System
its running very rough,getting bad gas milage. when i get off the freeway and come to a stop it stumbles and then picks back up. it does it at a stop light also,lacking power.

i hooked up my "OBD2" code reader, and it gave a reading of "P301" #1 cylinder Missfire Detected

#1) Replaced Plugs & Boots and coil housing

#2) i placed a ohm meter between #1 & #4 on the coil tower and it read 5.0 ohms the same between 2 & 3 and no reading between coil and cover Plate

#3) switched coils around to see if it was the coils. still shows #1 Missfire

#4) i checked my ignition module by connecting a test light (at the module) between bat. pos. terminal to the coil(Terminal A) and terminal B or C . when cranking engine light blinks. according to the book tt that should eliminate the module from being bad. but to check for open or shorted circuit in the coil wiring harness. i didnt do that. how do i do that? and where do i do that?

#4) put a ohm meter to no.1 injector, the reading was within specs described in book.

#5) i Disconected the electrical connector to the (IAC) "idle air control valve"started engine and pulled off each injector connector to the injector and there was a noticable difference in idle change


i didnt have a spark tester light so i couldnt test that
from what i described you have any advise or instructions besides "take it to the shop"

thank you
sz6vgh

United States

#599 Mar 25, 2008
Have a 97 Grand AM GT. 131500 miles. Drives great, but every once in a while on the expressway it will feel like it is binding down and the front of the car will vibrate. It only lasts for 4 or 5 seconds then goes away. This happens usually once or twice a day on a 70 mile commute. Any ideas?
ashlee

United States

#600 Mar 25, 2008
does anyone have a problem with starting your car when it is under a half a tank of gas. mine will run great and let you go all the way to empty but if you turn it off with uner a half a tank it acts like it is empty it is progressivly gettin worse it started at a 1/4 a tank and is now 3/4 a tank i have to keep it pretty much full all the time.
The Dude

Lead, SD

#601 Mar 25, 2008
Dan Amundsen wrote:
I have a 95 Grand Am with the DOHC 2.3 L4 engine. Wondering why in the hell it is stalling constantly. It will accelerate, and then stall and die. You have to let it cool down for a couple hours before it will start back up again. Why is that? I know it constantly overheats, as 75% of these POS cars do... but why does it not start? and why does it run rough? Ive redone the head, gaskets, valves, radiator, intake gasket, exhaust gasket, thermostat, EVERYTHING... I wanna drive this car off a cliff. Please help me!
Suggestion: Move to Arizona. There are steeper cliffs there.

Tell me when this thread is updated:

Subscribe Now Add to my Tracker

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Pontiac Discussions

Title Updated Last By Comments
1995 Pontiac Grand Am hard to start hit or cold. Jun 26 Romperroom1971 1
News Reports: 2004-2006 Chevy Uplander Sliding Door ... (Aug '07) Jun 6 mtzur 175
backfire thru front end. and misses May '16 buddybaker 1
Pontiac Grand Am 96 Apr '16 Karlina 1
my 1996 grand am instrument cluster gauges stop... (Sep '10) Jan '16 renownedd 2
Pontiac 2.4 thermostat change Jan '16 Gary Rummel 1
News 1967 Pontiac GTO Thom McAn Sweepstakes Car - Fu... (Sep '07) Oct '15 Michael Field 8
More from around the web