2000 Nissan Xterra engine stopped whi...

2000 Nissan Xterra engine stopped while driving...

Posted in the Nissan Xterra Forum

SkyDog

Nashville, TN

#1 Dec 17, 2009
Was driving to work one morning. Had filled up with premium, and had driven about 7 miles into work. The engine dies while I am driving. I cut across 4 lanes of traffic and get to the side of the road. Once there, the engine will crank, but not start. Mechanic says to take the distributor cap off and make sure it turns, thus indicating that the timing chain is still good, and distributor is spinning. Suggests to replace the Distributor cap, and it should work. I have checked the battery, every fusible link and fuse I can find. Fuel pump pressurizes, engine turns, but no go. Seems odd that it would do so while moving, without any prior indication. Could be Gas, but I put $20 worth in. If it was bad, wouldn't it sputter? Going to replace the spark plugs, wires, and distributor cap tomorrow. Any other ideas?
Mike

Baldwin, NY

#2 Jan 14, 2010
Hey man I had a similar problem on an 02 infiniti i35 and it was the cam sensor... may want to check that... does the overdrive light come on when the car is turned back on?
terry

New Kensington, PA

#3 Jan 27, 2010
skydog it coudl be your timing chain
tony

Linwood, NJ

#4 May 20, 2010
its your fuel sending unit or fuel pump both of which are located in your fuel tank.
shaggy

Roselle, IL

#5 May 14, 2012
2000 Nissan Xterra engine stopped while driving...
the engine will crank, but not start
jimmie

Athens, GA

#7 Aug 3, 2013
Or clogged fuel/gas filter?
Garrett Radinzel

Fort Dodge, IA

#8 Oct 23, 2013
same problem was driving and it killed I have no idea what is wrong I can hear fuel pump in gas tank and have no spark I believe I held on the the spark plug boot while I turned it over no shock!!! what could it be!!!
windie

Boise, ID

#10 Oct 19, 2015
SkyDog wrote:
Was driving to work one mmorning. Had filled up with premium, and had driven about 7 miles into work. The engine dies while I am driving. I cut across 4 lanes of traffic and get to the side of the road. Once there, the engine will crank, but not start. Mechanic says to take the distributor cap off and make sure it turns, thus indicating that the timing chain is still good, and distributor is spinning. Suggests to replace the Distributor cap, and it should work. I have checked the battery, every fusible link and fuse I can find. Fuel pump pressurizes, engine turns, but no go. Seems odd that it would do so while moving, without any prior indication. Could be Gas, but I put $20 worth in. If it was bad, wouldn't it sputter? Going to replace the spark plugs, wires, and distributor cap tomorrow. Any other ideas?
Try fuel sensor which is in gas tank

Tell me when this thread is updated:

Subscribe Now Add to my Tracker

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Nissan Xterra Discussions

Title Updated Last By Comments
02 Xterra will not start! Hellllllp (Jun '08) Apr '16 itisisaysme 53
News Nissan XTerra 2004 (May '09) Mar '16 manny 2
Have to brag on my 2001 xterra! Dec '15 Stacye 1
Nissan: Xterra AC units are designed to NOT tur... (Feb '08) Nov '15 Ivan 24
Starter problems (Nov '15) Nov '15 Toby 1
2003 Nissan xterra coolant leak (Jun '15) Jun '15 Taylorjmiller253 1
brakes and rotors (May '15) May '15 stitch 2
More from around the web