bobby

Altoona, PA

#1 Sep 4, 2006
Hi I own a 2003 pathfinder,3.5 v6 twice now out of nowhere the car has lost power stopped shifting right, and missing you can still get it to run if you floor it' Dealer say's no check eng. light can't do anything. also checked cat. cov. nothing wrong. anybody have any idea's
Mama Gorilla

Cut Off, LA

#2 Sep 13, 2006
No idea - here's MY dilemma:
I have an 01 Pathy that the "service engine soon" light is on steady. I had the exhaust replaced with a dual-exhaust FlowMaster, and althought it SOUNDS great, that danged light is still on. I still have my horsepower (sometimes when the A/C is on, it hesitates on the shift)... any thoughts?
Graham

Houston, TX

#3 Sep 15, 2006
O2 sensor is not reading (maybe not reconnected correctly after replacing exhaust?) or O2 system has not adjusted to new exhaust system yet. If the sensor does not go out after a few start/ stop cycles, then assume sensor is malfunctioning and replace. Go to a friendly car shop and ask them to read the codes on their diagnostic meter and repair accordingly.
Mama Gorilla wrote:
No idea - here's MY dilemma:
I have an 01 Pathy that the "service engine soon" light is on steady. I had the exhaust replaced with a dual-exhaust FlowMaster, and althought it SOUNDS great, that danged light is still on. I still have my horsepower (sometimes when the A/C is on, it hesitates on the shift)... any thoughts?
Mama Gorilla

Cut Off, LA

#4 Sep 15, 2006
Graham wrote:
O2 sensor is not reading (maybe not reconnected correctly after replacing exhaust?) or O2 system has not adjusted to new exhaust system yet. If the sensor does not go out after a few start/ stop cycles, then assume sensor is malfunctioning and replace. Go to a friendly car shop and ask them to read the codes on their diagnostic meter and repair accordingly.
<quoted text>
hey, thanks! the sensor came on before I had the exhaust replaced - the Pathy spent it's first 4 years in the salt, sand and snow (Maine) and is pretty rusted out underneath. I'd thought that the California emissions thing was the cause, so I had the exhaust replaced. When the light didn't go out after that, I was at a loss ... thanks again!
Johnk

Lake City, FL

#5 Dec 13, 2006
I have a 1999.5 Nissan Pathfinder. The oxygen sensor went out 3 months ago and was replaced. The check engine light came on again and the dealer said that was the second oxygen sensor, He said the pathfinder has 4 oxygen sensors. Is this true?
jon

Timmins, Canada

#6 May 11, 2007
yes the pathfinders have 4 o2 sensors 2 on each side 2 on the exhaust pipe and 2 coming off the manifolds
Charlie

Somerset, MA

#7 Jul 30, 2007
I have a 96 pathfinder,this is the problem no check engine light or anything like that but when the OBD is plugged in for inspection sticker, the cat converter, o2 sensors, and EGR are stuck in the "not ready reading". I just replaced the brain in the truck drove it for about 140 miles and I am still getting the same reading when the OBD is plugged in. Nissan won't help me. They told me to replace everything to fix problem and then said that might not fix it anyway, so they recomended that I just buy a new vehicle???????? This truck still has a lot of good miles in her (has about 127000 now), it is loaded,in great shape and has no other issues. I would rather just get the truck fixed. Can anyone help with this issue?
Ann Roosevelt N Y

Westbury, NY

#8 Oct 13, 2007
I have a 1995 Nissan Pathfinder I was experiencing a problem with the truck hesitating to go, smoking (thick black smoke) and spitting lots of carbon. I was told to change the EGR Valve, which I did. Four days ago I replaced the BPT valve and the truck has started hesitating and smoking again. Any suggestions why this might be happening.
Lindsey

Tulsa, OK

#9 Oct 17, 2007
I have an 04 Pathfinder and I am having the same issue as you Bobby!! I was at 10 mph reading 4grand on the RPMs!! Problem is I work for the dealership, in service no less and they are still giving me the run around! Earlier in the year my horn would randomly honk too!!
Rudy

Apopka, FL

#10 Oct 20, 2008
Hi i have 98 pathfinder 2wd. when driving over sixty and accelerate it goes slightly left.when i take my foot off the pedal it goes slightly right. got wheels balanced, new alignment. took it to pepboys for inspection to check the suspension, but everythink is ok, they said. I thought it might be the outer tie rod end. Any ideas? thanks
benc

Québec, Canada

#11 Mar 20, 2009
is a 1999.5 pathfinder is a go year
john r

Oakland, CA

#12 May 2, 2009
i have a 1995 nissian pathfinder.
has spark and fuel to the rail.plugs are not wet.
i drained out the old fuel and put fresh gas in it. any sugestions
chris

Saint Albert, Canada

#13 May 19, 2009
I have a 2003 pathfinder with a persistent "service engine soon" light. The vehicle is meticulously serviced and has only 130,000km (80,000 miles). The service code apparently indicated the need for a new catalytic converter, which I did (really expensive!). 2000km later the light comes on again, and the code indicates that the left cat converter needs replacing, but I am hesitant to do so. The vehicle is working fine, and I had the code re-set so the light is now off and has not re-appeared for 300 miles. You'd think if the problem were urgent that the light would come back on immediately after re-setting it? A few days before all this happened, my vehicle (which was in AUTO 4WD at the time) used 3/4 of a tank of gas to go 150 km, wouldn't go above 120km/hr, wouldn't drop below 3500 RPM, felt like the front diff was skipping and produced a burning smell. I stopped and put it into 2WD and the problem disappeared. Any thoughts on all this?
lisandro

Humacao, Puerto Rico

#14 Jun 20, 2009
my 95 pathy stock over parking side a can' move for several time try in lose the drive position, please help me what happing w my pathy....
lisandro

Humacao, Puerto Rico

#15 Jun 20, 2009
I have 95 Pathy stock a the parking try to lose for several minutes a move but lose time because in happing all day a night, please hep me.
ANDRES

Miami, FL

#16 Oct 3, 2011
On a 1999.5 Pathfinder, if the drain hose is clogged and no water is detected to come from it, does that mean that the a/c will not blow cold air? They replaced the expansion valve for the a/c twice, it cools perfectly for a day or two, and then it does not anymore. Anyone can tell me what is going on?? Thanks.
mark

China Grove, NC

#17 Mar 13, 2012
my 2003 pathfinder has same problem I spent a lot of time and money but still have the not ready code so they won't pass inspection did you get any answers or help
mark

China Grove, NC

#18 Mar 13, 2012
same problems with my 03 pqathfinder did you get any more help
josh az

Tucson, AZ

#19 Oct 15, 2013
Charlie wrote:
I have a 96 pathfinder,this is the problem no check engine light or anything like that but when the OBD is plugged in for inspection sticker, the cat converter, o2 sensors, and EGR are stuck in the "not ready reading". I just replaced the brain in the truck drove it for about 140 miles and I am still getting the same reading when the OBD is plugged in. Nissan won't help me. They told me to replace everything to fix problem and then said that might not fix it anyway, so they recomended that I just buy a new vehicle???????? This truck still has a lot of good miles in her (has about 127000 now), it is loaded,in great shape and has no other issues. I would rather just get the truck fixed. Can anyone help with this issue?
i have same issue on my 96. did you ever figure it out?

Tell me when this thread is updated:

Subscribe Now Add to my Tracker

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Nissan Pathfinder Discussions

Title Updated Last By Comments
1995 Nissan Pathfinder v6 Possible fuel problems (Apr '08) Feb 28 Anthony Glover 14
95 Nissan pathfinder Feb 9 eva 1
icon unav gps navigation system infiniti nissan... (Jan '12) Jan '15 morriswaller 28
Broken strut tower on driverside (Sep '09) Jan '15 Stanley 106
icon unav navigation touchscreen gps for all ni... (Apr '12) Nov '14 mabello 5
Pathfinder Fuel Gauge problems (Jan '08) Aug '14 B_A_Co 103
unav touchscreen navigation system icon nissan ... (Apr '12) Mar '14 Riderjonez 8
More from around the web