Comments
1 - 20 of 107 Comments Last updated Aug 6, 2013
First Prev
of 6
Next Last
PAUL

Pasadena, CA

#1 Nov 8, 2006
HI.. i have an 2003 Lincoln Navigator and my question is, is it normal to hear the air suspensions air compressor come on all loud? everytime i turn on the Navi, the loud noise of the compressor comes on. It is coming from the right front end almost behind the headlight. and it just doesnt come on then it also comes on when i come to a stop at a light but not all the time. This loud compressor noice comes on also at other times through the day? IS THIS NORMAL if so WHY IS IT SO LOUD? i would think that a luxury car like this would having such an annoying blarring sound when the compressor kicks on to fill the airbag suspension. Anyone with any clues please help....=(
Rich

Tolleson, AZ

#2 Nov 26, 2006
I just bought an 03 Navigator and noticed the same problem. I brought it back to the dealer and they said that was normal. I hope we can find some one who has a different take It's getting annoying.
PAUL wrote:
HI.. i have an 2003 Lincoln Navigator and my question is, is it normal to hear the air suspensions air compressor come on all loud? everytime i turn on the Navi, the loud noise of the compressor comes on. It is coming from the right front end almost behind the headlight. and it just doesnt come on then it also comes on when i come to a stop at a light but not all the time. This loud compressor noice comes on also at other times through the day? IS THIS NORMAL if so WHY IS IT SO LOUD? i would think that a luxury car like this would having such an annoying blarring sound when the compressor kicks on to fill the airbag suspension. Anyone with any clues please help....=(
buklan

Madison, WI

#3 Nov 28, 2006
I have an '03 Navigator as well and when I took it into the dealearship they told me that it is normal.
PAUL

West Covina, CA

#4 Feb 11, 2007
UPDATE:.. i took it back to the dealership and they said it was normal.. VERY VERY DISAPOINTING.!! makes me want to get rid of it and regret getting a navi , i should of gotten a escalade...=X
Lennyc

Puyallup, WA

#5 Apr 8, 2007
That doesn't sound normal to me. I've had my 03 Navi for a little over 7 months now and the compressor only comes on once as you turn the veh on for barely a minute as you are turning on the ignition but then my engine drowns out the noise once it turns.
Jimmy

AOL

#6 Jun 5, 2007
my front passenger side will not rise at all when my truck is started. has anyone else had this problem? the bottom of the wheel well is rubbing the top of the tire. is it a fuse maybe or could it be a bad shock all together. please help!!!!
03 NGATOR

Hedgesville, WV

#7 Jun 23, 2007
Jimmy, turn your steering wheel completely to the left, then shut off the engine. If you look under the passenger side wheel where the suspension is, you will see a height adjustment 4 inch arm probably unattached. Reattach it. It pops right back on. If this is your problem, like mine, it will fix the problem. This is the best that I can explain it.
robert

Acton, MA

#8 Jun 30, 2007
I have a 2003 navi and now my suspension doesnt turn on at all. i check all relays and fuses everything seems fine. I dont hear the suspension motor coming on. the switch is on also. anyone got any ideas
Ford Spark Plug Repair

Grand Rapids, MI

#9 Jul 3, 2007
Blown spark plugs are very common in the Navigator's aluminum cylinder head. Please visit www.pgsparkplugrepair.com to effectively and efficiently repair your vehicle.
Kmoney6026

Madison, WI

#10 Aug 9, 2007
I have a 2005. I have had it less than a year. Everything seems to be fine except, i will be traveling down the road and a high pitched noise will come from the back right of the vehicle. Sounds like air releasing from a tea pot or a siren. Anyone have an idea what it is? I notice that it happens more on hot days. Could it be pressure releasing from the hydraulics?
TAI

Greeley, CO

#11 Sep 25, 2007
i had the same problem it is kinda annoying but i found out that there is a switch in the back behind the seats you can turn that off and you wont hear the sound no more....
Andria

Glendora, CA

#12 Oct 9, 2007
We have had our 2003 for about two years now this Nov. when we bought the car we noticed the same kind of noises then about a year later we started having the SAME problems you are having with your Nav. When taking it to get looked at they told us that the air compressor is broke and that is what is causing it not to raise. Not saying that is your problem although it does sound like the same thing. We were quoted 1800 to fix it after already paying 250 for them to look at it. Hope this helps figuring out your problem.
Jimmy wrote:
my front passenger side will not rise at all when my truck is started. has anyone else had this problem? the bottom of the wheel well is rubbing the top of the tire. is it a fuse maybe or could it be a bad shock all together. please help!!!!
Shawn

Atlanta, GA

#13 Oct 13, 2007
I have an 03 Navigator for about a year now. Today I took it out and it said check suspension on the dash. Before I knew it I was as low to the ground as a car was. It was too late to take it to the dealership and had to drive it home once I took my family mechanic could take a look at it. Both the front and rear suspension are very low almost rubbing the tires. Anyone know a price range it will cost to get this fixed?
Lisa

Corona, NY

#14 Oct 14, 2007
I have an 03 navigator and its lean on left side anyone have any idea please help ??
tommy

Winnipeg, Canada

#15 Oct 25, 2007
i have an 03 navi, i read that it is normal to hear the compressor as the truck starts rising after turning it on, then it could stay active for up to 40 mins after parked. Now, I have a problem, I think, the truck lowers after shut off, which is normal, but only the front. Is the back supposed to drop too? then it raises when turned on but not to full hight, it looks ugly with the front lower than the back, i dont think is right for a 4x4 to be like this, any ideas and comments, please. Dealer says nothing wrong with it.
Lisa

East Elmhurst, NY

#16 Nov 4, 2007
I took mine to a dealer and they change height sensor now its perfect.Tommy i think you have the same problem.
cheryl

AOL

#17 Nov 14, 2007
I had my 2003 Nav. suspension repaired 5 times in the past 2 years. The Lincoln mechanics tell me 2003 was a bad year for the suspension and they changed it in 2004. I am paying so much for these repairs and I think Lincoln should do something about their faulty system failing in my car!!!
robert wrote:
I have a 2003 navi and now my suspension doesnt turn on at all. i check all relays and fuses everything seems fine. I dont hear the suspension motor coming on. the switch is on also. anyone got any ideas
Kevin

Garner, NC

#18 Nov 26, 2007
I've spent over $800 on the front suspension and left the Nav. in the dealership for five days, but it's still screwed up!!! Carried it to a second dealership and they want to change the compressor for another $700...???

Think this will fix the problem?

They all seem to want to make money but don't care if it fixes the issue or not!

Does any of you guys think we need a class action law suit to help us with the crap? FORD needs to step up and take care of this!!! I've driven Fords for the past 30 years and I think we deserve better than this!!!
AdrianNavi03

Plainview, NY

#19 Dec 5, 2007
i have a similiar problem with my 2003 lincoln navigator altough my problem is that the car comes up but when i drive it my left side is lower then the right.... any suggestions anyone? maybe its the sensors because i know it cant be the air bags or compressor cuz the car comes up and everything its just that one side of the car is higher then the other once it starts being driven.... any help people?
Dan

AOL

#20 Dec 7, 2007
I have a 2002 navigator and the suspension light went on just yesterday. Prior to this light going on I would drive to a store get in drive to the gas station and then the car wouldn't start. After 20 minutes or so it started. This happened four times having to wait to get it to start. Took it to the dealer, and of course they can't find anything wrong. The idiot light came on for check suspension and car doesn't start, but nothing is wrong. Anyone have trouble with this light and car not starting?

Tell me when this thread is updated: (Registration is not required)

Add to my Tracker Send me an email

First Prev
of 6
Next Last

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Lincoln Navigator Discussions

Title Updated Last By Comments
I cant find the override button up under my das... 12 hr Ray 1
2006 Lincoln Navigator - rust on hatch (Jan '10) Aug 28 Bradley 24
fitting tow hitch Aug 17 Uncle tony 1
2000 Lincoln navigator won't start Aug 13 Mstewart1002 1
2003 lincoln navigator air suspension (Jun '07) Jul '14 parker 322
Cadillac Escalade Review (May '07) Jul '14 Benzforlife 16
03 navigator factory keypad code (Mar '08) Jul '14 marie 23

Buy a New Car


Zipcode:
•••
Enter and win $5000
•••

Lincoln Navigator People Search

Addresses and phone numbers for FREE

•••