2003 lincoln navigator air suspension

Posted in the Lincoln Navigator Forum

Comments (Page 9)

Showing posts 161 - 180 of321
|
Go to last page| Jump to page:

Since: Jul 10

Roxboro, NC

|
Report Abuse
|
Judge it!
|
#162
Jul 9, 2010
 
ROGER wrote:
Had a similar problem several months back, took it in and they repaired, told me it was a sensor.
Today it started again only this time on the drivers side.
That's a common problem with these vehicles. The air systems are very unpredictable and have many components to them that could cause them to fail! I have a 2003 Lincoln Navigator and my air ride went out so I replaced it with a coil spring that eliminated the air. It rides great now and I have the comfort of not being worried with all of the problems that come along with air products. Strutmasters took care of my suspension problems and now I'm back on the road :)

Since: Jul 10

Location hidden

|
Report Abuse
|
Judge it!
|
#163
Jul 13, 2010
 
Adrienne wrote:
Our 03 Navigator is having the same problem. the suspension was fully repleaced 2 years ago but every time it gets too cold outside the passenger front side will not rise up. please email me lalajay71@yahoo.com We are in similar climates. Anything 30 or below it starts acting up.
<quoted text>
I am a Lincoln Navigator owner as well. Mine is a 2004 and my compressor went bad. So I decided to call around and get pricing. The first mistake I made was calling a dealership..... way too expensive. Then I started surfing the web and found several sites that offered the air compressors for more, but the more that I talked to different companies and sales people, the more I found out just how bad these air systems are. I never realized there were so many things involved with air ride systems. I ended up actually taking the air off of my Navigator and putting a conversion kit on from a company that I found out of North Carolina called Strutmasters. They took care of all my suspension needs and now I am back on the road.:)

Since: Jul 10

Location hidden

|
Report Abuse
|
Judge it!
|
#164
Jul 13, 2010
 
Stressed wrote:
I too have a 2003 Navigator, today I was pulling out of the driveway when I realized that the air bags did not inflate (all 4). Did not have or notice any issues when I pulled in earlier. The check suspension warning came on and I'm left wondering what could have happened? I know nothing blew out, could it be something electrical that causing the air bags not to fill? Again, it's all 4 bags that won't fill up. What do you think?
Hey I have a great solution for your problem. First, your problem lies within the air system itself. Either your compressor is shot from trying to pump up a leak in your system or one of the air hoses or bags has a hole in it..... your looking at a lot of money to replace this system. Don't put yourself through that. I had similar problems with my 02 Navigator and I converted to a non air system offered by Strutmastes. I searched the web endlessly after I was quoted pricing for the air replacement and found a great deal with them :) Check um out!!!!!

Since: Jul 10

Location hidden

|
Report Abuse
|
Judge it!
|
#165
Jul 13, 2010
 
LULY MIAMI FLORIDA wrote:
<quoted text> i HAVE HAD THE SAME PROBLEM I HAVE CHANGE THE WHOLE SUSPENSION AND MY CAR SUSPENSION STILL DOESN'T COME ON> VERY FRUSATING IF ANY ONE CAN GIVE USE ADVICE PLEASE FEEL FREE TO CONTACT USE AT DANSHEEHY@AOL.COM
When you say that you have replaced the suspension, did you convert the car to a non air system or did you replace the air parts? You may want to give Strutmasters.com a look, they have great solutions for suspension problems!!!!

Since: Jul 10

Location hidden

|
Report Abuse
|
Judge it!
|
#166
Jul 15, 2010
 
Jimmy wrote:
my passenger side front will not rise when the truck is started. The top of the wheel well is rubbing the tire. i'm wondering if anyone has had this problem before.
Have you ever considered a conversion kit. Call or go to Strutmasters.com . I did and it helped me tremendously!!!

Since: Jul 10

Location hidden

|
Report Abuse
|
Judge it!
|
#167
Jul 16, 2010
 
Runsky wrote:
Joe,
I tried turning off the suspension but the front suspension still went down. My issue is related to the outside temperature and turning off the suspension did not stop the 'leak' of air. I just ordered a new solenoid and will try to figure out how to change it. First the front passenger solenoid and then test. If still an issue then front driver. If stil an issue then o-rings.I fstill and issue then the T-fitting as omar suggested.
To me is seem that the solenoid does not 'close' properly when it is cooler outside. One time I had turned of the suspension. When i got back to the car, it was sitting level. I turned on the suspension, then the car. The front started lowering while the compressor was running. I seems this could be a bas solenoid, releasing air as it being pumped into to the bag. Not sure though.
Hi, when you say you turned off the suspension what do you mean? It sounds like you need the conversion kit. I had similar problems with my 2003 Navigator and I went to Strutmasters.com . They had a solution for my problem that was affordable and reliable. Check them out :)

Since: Jul 10

Location hidden

|
Report Abuse
|
Judge it!
|
#168
Jul 16, 2010
 
sadiebug6 wrote:
<quoted text>
That's a common problem with these vehicles. The air systems are very unpredictable and have many components to them that could cause them to fail! I have a 2003 Lincoln Navigator and my air ride went out so I replaced it with a coil spring that eliminated the air. It rides great now and I have the comfort of not being worried with all of the problems that come along with air products. Strutmasters took care of my suspension problems and now I'm back on the road :)
I hear that is a common problem as well. All air systems have a problem eventually. With anything relying on air there's always the possibility that if there is a leak, air is not going to work. Try a conversion kit. Great advice, Strutmasters is the place to go!!!

Since: Jul 10

Location hidden

|
Report Abuse
|
Judge it!
|
#169
Jul 16, 2010
 
chris268 wrote:
Strutmasters only way to go easy installation..Rides perfect no air bs
Right on.... Strutmasters is great!!! I had major suspension problems and they hooked me up!!!
Joe - Miami

Miami, FL

|
Report Abuse
|
Judge it!
|
#170
Jul 18, 2010
 
I haven't written here in over 6 months. Since I did the o-ring replacement, my '03 Navigator air suspension continues to work fine. The only thing I noticed is that one airspring in the front and another in the rear have an oil stain about 1/3 of the way from bottom to top. I suppose it is a slow oil leak coming from the strut itself. For now, my dashboard doesn't says "Check Suspension". Will monitor it and report back.
Joe - Miami

Miami, FL

|
Report Abuse
|
Judge it!
|
#171
Jul 18, 2010
 
One more thing. I don't know if it's obvious to all here like it is to me. It seems Strutmasters has too many pumpers here. Can't separate the true customer experience feedback from the biased feedback of someone that's on the inside.

Since: Jul 10

Location hidden

|
Report Abuse
|
Judge it!
|
#172
Jul 19, 2010
 
Fred wrote:
<quoted text>
Yes, except my 2003 Nav is lowered on both the rear and front. I am wondering if there is a air valve that you are suppose to pump air into. I do hear the air sus. engine initiate, but I still see "CHECK SUSPENION" warning and my truck is still lop sided.
There is a leak in your system somewhere that is not allowing the air to be properly distributed throughout the vehicle. Check out Strutmasters.com for a quick, easy solution!:)

Since: Jul 10

Location hidden

|
Report Abuse
|
Judge it!
|
#173
Jul 19, 2010
 
Jimmy wrote:
my passenger side front will not rise when the truck is started. The top of the wheel well is rubbing the tire. i'm wondering if anyone has had this problem before.
Try going to Strutmasters.com and having a free diagnosis done. They usually have fixes for these type of problems
Elmer

Copperopolis, CA

|
Report Abuse
|
Judge it!
|
#174
Aug 4, 2010
 
Yeah I have a2003 also and same problem any lawsuit or something going on?because it seems that a lot of people are having this problem let me know eycarballo78@aol.com
I started to have this like three years ago dealer told me it was the computer $1000 later it got fix but for a year after that the same thing happened
davidp33781

Saint Petersburg, FL

|
Report Abuse
|
Judge it!
|
#175
Aug 23, 2010
 
I have a 2001 lincoln navigator.
Last week I went outside and my whole back end was laying down last week, I unhooked the battery over night and they pumped back up. I drove for about an hour and it went down, now nothing.
I wont take it to the dealership, show im just trying to figure it out on my own. My air bags are good, I know its some sensor.
I do believe it should be a recall.
davidp33781

Saint Petersburg, FL

|
Report Abuse
|
Judge it!
|
#176
Aug 23, 2010
 
Why is this designed so that it cant be scanned to find problem, there should be a lawsuit.
kms470

Cedar Rapids, IA

|
Report Abuse
|
Judge it!
|
#177
Aug 24, 2010
 
I have an 03 nav that is low on the passenger side but high on the drivers side. What could be a cause?
kms470

Cedar Rapids, IA

|
Report Abuse
|
Judge it!
|
#178
Aug 24, 2010
 
p.s. my compressor is not running
musique4life

United States

|
Report Abuse
|
Judge it!
|
#179
Aug 26, 2010
 
hey guys I'm never the one to write or comment on these blogs. However, until recently my 98' licoln navigator back droped and I was feeling every pot hole I went over when driving . At first I panic,I came on here and read this guy notes about how to bypass the relay by using a small wire and touching the cord that connects to the relay to see if its ur pump or the relay . I got under the front passenger side right next to the horn there was a amp-like looking box . I remove the plug and by using a small wire i touch the left hole to the right hole make sure the wire that was connect to the relay is facing down. once I did that my pump started to work . Rite away I knew the pump was good . I went out and got a relay which is the amp-like looking box. once I replace it the truck came right back up. hope if you try that if will work. As you can see im not mechanically incline. If we were talking music it would be a whole different story. Oh and sometimes too the relay may burn the pump out too. so before you go spending a large sum of money see what you could do first.good luck.
rodeogator

United States

|
Report Abuse
|
Judge it!
|
#180
Aug 30, 2010
 
kms470. It sounds like you might have a solenoid thats stuck on one side not letting air in to fill it up. Possibly a leak in a line. You can bring it to the dealership and have them run the codes for about $90 then just buy the parts yourself from Fordparts.com or elsewhere. It's usually not too difficult to replace things like solenoids, compressors, relays, etc. If it's the airbags then it's a little more complicated. Good luck and post back once you figure out the problem for everyone elses education.
rodeogator

United States

|
Report Abuse
|
Judge it!
|
#181
Aug 30, 2010
 

Judged:

1

Also could be the ride height sensor module or arm, there are reports from a few of the arm popping off.
Also, ENOUGH WITH THE SPAMMING STRUTMASTER SALES CRAP, OK?!!!! Unless you're going to offer advice on how to fix something, stop your fake advice trying to sell your kit. Amazing how many people recommending the Strutmaster kit are from NC, just by chance where Srutmaster is from too. Get back to work and stop ruining this site for people who have legitimate advice.

Tell me when this thread is updated: (Registration is not required)

Add to my Tracker Send me an email

Showing posts 161 - 180 of321
|
Go to last page| Jump to page:
Type in your comments below
Name
(appears on your post)
Comments
Characters left: 4000
Type the numbers you see in the image on the right:

Please note by clicking on "Post Comment" you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Other Recent Lincoln Navigator Discussions

Search the Lincoln Navigator Forum:
Topic Updated Last By Comments
2006 Lincoln Navigator - rust on hatch (Jan '10) Jul 9 SteveS 22
Ford's New CEO Wants to Revive the Stodgy Linco... Jul 8 KDN 1
2007 Lincoln navigator looking for dash kit wi... Jun 30 Matt michael 2
ABS light (Jan '11) May '14 Duane 5
replace cigarette lighter in 2006 lincoln navig... May '14 GeorgeLawshe 1
Navigator 2003 ABS Control Module failure Mar '14 Alex 1
Ford to start selling Lincolns in China's luxur... (Aug '12) Mar '14 FoMoCo 4
•••

Buy a New Car


Zipcode:
•••
Enter and win $5000
•••
•••