Jeep Liberty problems
Marita

Pueblo, CO

#627 Sep 7, 2011
Tanya wrote:
we have a 2003 jeep liberty renegade...engine light goes on /off at will.engine will sputter,stall etc.(VERY bothersome!!)took to dealer,had a"coil pack"changed,drove away,1mile away same **** happened.this went on for at least
3"coil packs"one right after another.FINALLY fixed
only to have engine light on/off again about 6 months later.diagnostics said all was well..?well,here i am about a year later with the same sputter/stall problem.taking to dealer in morning.
have also had problems with my cd's getting stuck,
thought it was just me.
anyone hear of the "lemon law"?by the way...my jeep isn't even paid for yet ):
Tanya, that is because you bought a Jeep, I had my Renagade for 3 months and spent $3,700.00 just to get rid of it, I actually broke out even on this piece of Junk, I will never by any Jeep product, I am looking at a Honda Prelude from a private owner for way under book value, those of you who own Jeep products I feel for you because you own the worst auto that came off the assembly line. LOL
Alvino

Pueblo, CO

#628 Sep 7, 2011
PATACAKE VIRGIN ISLANDS wrote:
MY 2202 JEEP LIBERTY, PURCHASED NEW IN JAN 2003 NOW HAS A LOCKED ENGINE. IT HAS HAS 32,234 MILES.I NEVER HAD ANY WARNING, NO ENGINE LIGHT COMING ON, NO SHAKES,NO JUMPY-NESS, NO NOISES. I WAS DRIVING, PULLED TO THE SIDE OF THE ROAD TO SAY HELLO TO A FRIEND AND THE THE STEERING GOT TIGHT AND THE ENGINE QUIT. SERVICING WAS ALWAYS DONE ON SCHEDULE LAST ONE WAS DONE LATE FEBRUARY 08. H E L P !!!!!!!!!!
Your not alone, I bought my 08 Lib Sport new and after 18 K my 3.7 engine also locked up, luckily the DEALER found a defect with internal parts of the engine, I believe camshaft & Crank were not properly calibrated when they were built, I was told it would have cost over $6,800.00 had it not been for the recall on this model engine, there were only a hand full that were bad, you may have gotten one, I am going on 89 K and the engine is still running great, the little guy finally wins one, I wonder how many more out there have gotten the dirty end of the stick, it does happen.
Arnold

Pueblo, CO

#629 Sep 8, 2011
Judy wrote:
I have a 2002 Jeep Liberty Sport. The radio quit on me and the clock lights go on and off when they feel like it. The car won't start every ten days, Had the battery and the alternator checked out ok.The dealer told me the battery wires were corroded and cleaned them. Ten days later , no start! I am wondering if this is a wiring problem and a new radio might fix it. Dealer can not find the problem. What to do?
1ST mistake you took it to the DEALER, they tried to tell me I needed a new PCM when I took it in to have them check the engine light, little did they know that I had a mechanic check it prior and he said it was probably my gas cap, out of curiousity I asked how much the PCM would cost, are you sitting down,$670.00 and no warranty, I asked the service tech twice if he was sure this was the problem, he said thats what the computer shows, I told them I would get a second opinion, I went to AutoZone and got a heavy duty gas cap for $9.99 to get a tight seal and no more check engine light, my mechanic told me that the DEALER here in Pueblo, CO is currently being investigated for doing work that does not need to be done, I did however make a report to the BBB, bunch of CROOKS.
Sparetire

Pueblo, CO

#630 Sep 8, 2011
Wheeljack wrote:
Hi All,
I have and 06 3.7 L Liberty and I have run into a new problem. The engine light has come on and when it happened the temprature guage needle dropped back to 0. When I pulled over and shut off the ignition, i heard an unusual reving down type noise. When i re-started the engine, the temp guage worked but the engine light remains on. Any thoughts or ideas?
Same problem here with my 08 Lib, took it to a mechanic and he took off the negative cable from the batter for 20 minutes, he said this will reset the PCM and let us know if there is a bad sensor, 20 minutes later he reconnected the cable and the light is off, I did reset the clock, been driving it for 8 months and no problems.
bad PCM and SENSOR

Pueblo, CO

#631 Sep 8, 2011
bbyh2o wrote:
I have a 2002 Jeep Liberty (78,000 miles)that has starting issues. I'll go to start it and it's dead, no lights, no nothing. Then twenty minutes later it will start and run fine. It does this about every twenty starts or so. The battery is only two months old and checked out fine. I had it towed to the dealer (wouldn't start) and they said it was the negative battery cable and replaced it, but it is still acting up. Any suggestions?
Same problem with my 09 Lib Sport, took it to the DEALER and they put it on the Diagnostic, they said the PCM was bad and wanted to replace for $670.00, lucky for me my warranty covered this and I was on my way, next day check engine light back on, called the DEALER they said bring her back in, now they say the o2 sensor is bad, asked why they did not find this the first time around they said the old PCM did not detect this, asked if the warranty covered this and he said yes, got lucky again, been driving the Lib for a few weeks and so far so good, LOL.
transfer case

Pueblo, CO

#632 Sep 8, 2011
leslie k ohio wrote:
I have a 2003 jeep liberty sport ,relocated, drove it to tx from ohio and now my tranfer box is shot. Im now 2000 miles out of factory warranty when 3 months ago they told me it was my brakes. Any body else have similar problems with transfer case? any suggestions?
after purchasing my 07 Lib sport with 36 K I took it in for a complete oil change and lube as I noticed a little vibration from underneath, the service tech called me and said that the transfer case was completly dry, luckily for me it was not damaged and they filled it with gear oil, the service tech said to keep an eye out for leaks in the event the transfer case has a bad seal, I been driving this for a few weeks and have not noticed any leakage at all, my suspicion is that perhaps there was never any oil in the transfer case in the first place or it was replaced and not serviced correctly, so far so good with a [prayer].
tranny fluid change

Pueblo, CO

#633 Sep 8, 2011
Kaiboo wrote:
I just purchased a used 2006 Jeep Liberty and notice that the transmission temp light will flicker and an alarm bell sounds once or twice in a 30 mile drive. Doesn't seem to affect anything else and doesn't make sense that transmission temp would even be an issue since driving is very light (on highway). Have read many comments about PCM or BCM issues on Libertys. Any suggestions appreciated.
Same problem with my 07 Lib sport, took to a tranny shop and the guy changed the fluid and filter for $79.00, he said on these Liberty"s the manufacture recommends changing the fluid every 80 K, been running great ever since.
defective CD player

Pueblo, CO

#634 Sep 8, 2011
Anna wrote:
The cd player in my 04 liberty has a cd stuck in it. I can still listen to the cd but when I hit eject nothing happens. I can hear the cd spin like it's trying but it still remains stuck. Any suggestions?
same here, my 09 Lib sport CD player has been replaced 3 times by the DEALER, thankfully the warranty has picked up the tab, the service tech said he has replaced the CD player in every Liberty that has come through the shop and that it is a factory defect in mostly all Jeep products, so far so good with this one.
oil light

Pueblo, CO

#635 Sep 8, 2011
Mimi wrote:
I have a 2005 Jeep Liberty and I just noticed the oil light came on, but now it went out. Any suggestions
Sounds like you may be low on oil or you may need an oil change, do not think your oil pump is bad, take to AutoZone and they will check it for free.
new PCM

Pueblo, CO

#636 Sep 8, 2011
Jeep 2002 engine sputters wrote:
I have a Jeep Liberty 2002 Limited Edition...
114,000 miles...
I have replaced the spark plugs which were never replaced until now...
I have changed the MAP sensor...
Battery went dead immediately after the engine light went on.... so replaced the battery with a new one.....
Engine began missing, sputtering, white smoke, some black.
Can't hold idle unless I hold my foot on the gas...
It is hard to start
I am at a loss of what to do next....the engine light went off....
Help???..:)
had the same problem with my 07 Lib sprt, took to Carquest and they said it was a bad PCM, I went on line to www.autocomputerexchange.com and bought one for $199.00 already programed, I gave them my Vin# and mileage and it was ready to go, I recieved it within 3 days with directions, unplugged the old one and put the new one in and it is running great, by the way I called the DEALER and they wanted $670.00 to install, bunch of rip offs.
not alone

Pueblo, CO

#637 Sep 9, 2011
JoAnn wrote:
My 2003 Jeep Liberty (69,000 mi) just stopped in middle of traffic on a busy street, I got it started to try and get if off the road but as soon as it started it stop. If you turned the key it would make a weird noise, not one I have heard. I towed it to a mechanic and they said the computer was showing up a problem but the spark plug wires were burned out, so they changed the plus and wires and the car started smoking, burned out the wired again, they said that the computer needed replacing, so now I am waiting to get a second hand computer intalled and programmed. Wish I left the keys in it and walked away.
I had the same problem although I was dupped into getting a new PCM by the DEALER, turns out I never needed the PCM in the first place, found out this piece of Junk Liberty just needed a tune up, went back to the DEALER regarding the PCM and the guy (mike) said that is what their computer showed, asked for a refund and he said that was not an option, asked for the other PCM and he said it was shipped back to the factory, humm sounds like we have a crooked DEALER here in Pueblo, CO, always get a second opinion, wish I had.
Atlas

Pueblo, CO

#638 Sep 9, 2011
rico wrote:
my 2002 Liberty cilynder 2 doesn't work. I change the coil park and the spark plug. Nothing happens. I'd like to know what else i can change
had same problem with cylinder 3 misfire on 03 Lib, took it to the DEALER and they said that the PCM was bad, asked how much to replace they said $670.00, told them them I would get a second opinion, took to a reputable mech after checking with the BBB and they said was spark plug wire was bad and needed replaceing for $29.00 including labor, had it done and the Jeep Lib is running great, I did mention to the mech about the DEALER wanting a new PCM and he said he was not surprised that he has fix 3 Jeep Libs in the past 3 months that has been diagonsed by the DEALER and that in each case it was not the problem, the mech thinks the DEALER here in Pueblo, CO is a slim shaddy [crooked].
fallseason

Pueblo, CO

#639 Sep 9, 2011
summerdayvid wrote:
my check engine light was on, took it for a diagnosis done, they gave me a code p1195..which said sensor bank 1 slow switching during catayst monitoring. what does that mean and what part do i need, some type of sensor or something.please send a email who ever can help me with this question,[email protected]
that would be your lower sensor bank 1 on the exhaust that monitors emissions from the cat convertor, I had mine replaced and it has been great since, prior to that I took it to the DEALER and they wanted to replace the PCM at $670.00, my mech said that they do that alot, they are being investigated for fraud and I also reported them to the BBB.
electroman

Pueblo, CO

#640 Sep 9, 2011
cindy wrote:
I have a brand new 2010 Jeep Liberty sport, and the battery light stays on, WHY?
09 Jeep Lib had the same problem, took to the DEALER and they could not find out what the problem was,took to AutoZone and they replaced a relay, working great ever since, asked the tech why the DEALER could not find out the problem he said that the technicians there at Chrysler Jeep have not been trained on any Jeep products, they guess at this and that, keep your Jeep product away from the DEALER there priorities are with Crhyler products after all they did inherit the Jeep products, take to a Cert mechanic.
Jeepisjunk

Pueblo, CO

#641 Sep 9, 2011
Celena wrote:
I just bought a 2002 Jeep Libert Limited and don't have any of those problems yet!
Does your Jeep make a clunking noise when you are driving on a rough road? Or maybe small bumps on the road?
after buying a 2002 Jeep Lib at auction 3 months ago I am sad to report that it is now in the auto salvage for JUNK, within 1 month of purchas the engine locked up and found out the transmission was also bad, with 38K who would guess this could happen, I would have to pay double to fix this tin can, I later found out that this may have been the worst auto that ever came off the assembly line, shame on you JEEP CORP.
Dan

Bobcaygeon, Canada

#642 Sep 9, 2011
Nili wrote:
I have all kinds of problems with my Jeep Liberty 2004. AC doesn't blow cold, transmission doesn't lock on "D", thus casuing rolls back on hills.
While it was still under warranty, I took it to the Authorized Dealer "Lithia Dodge in Concord, California, with the above problems.
They allegedly fixed the AC 3 times but to no avail. On my fourth visit,(Warranty Expired) I was advised to pay $1000+ to have the Compressor replaced. When confronted about their lousy repairs 3 different ocassions earlier, they started playing the 'delay tactics'.
When asked about the other problems they advised nothing was wrong it was just normal for my Liberty to do a roll back on hills when engaged in "D" position. I don't buy that.
Whatever these people are telling me is hard to believe.
Not sure if its something special on the liberty, but ANY other auto vehicle i'v driven yet (from a 2.0 l sunfire to a 5 ton international flatbed) will roll back on a hill, if its steep enough... usually anything over 15-20 degree slope... you can sometimes balance it out by gently hitting the gas, but idk if thats good for the tranny or motor...
faultypart

Pueblo, CO

#643 Sep 9, 2011
alex wrote:
I have a 2002 Jeep Liberty Sport(Manual). When changing from 2>3 gear there is a "clunk" which you can hear & feel as the gears slip into place. Anyone have any suggestions how to fix this ?? All other gears are ok.
had to replace the rearend due to a factory faulty pinon gear, the DEALER said it was covered under warranty for this particular year and model # and only a hand full of Jeep Libs had this defect, made me happy,$1800.00 saved out of my pocket, now a new problem with my 09 Lib the check engine light just popped on and I am hoping it is something minor, will keep you Jeep Liberty lovers posted.
slimmyoil

Pueblo, CO

#644 Sep 9, 2011
Stan wrote:
Had a oil change - there was a slimey, gunky build up on the cap. The tech told my wife that it is common. If it is true, what is it and what is it due to?
My 09 Jeep Lib with 26K started having this very problem, took the DEALER and they said it was due to a faulty head gasket and that coolent was getting in the oil, thank goodness I took it in because the Srvc Tech said this would cause the engine to lock up, they replaced for free at no charge and so far so good, will keep posted.
Bad Bad Jeep

Pueblo, CO

#645 Sep 9, 2011
edward wrote:
2002 jeep liberty engine light ON
repair service center change gas cap, reset, battery power off and on but still same..
what the heck JEEP LIBERTY 2002!
O2 sensor problem? valve problem? or CD deck electrical problem? who know about it?
email me : [email protected]
welcome to Jeep Liberty problem world, you are in for a real treat,
after owning my 08 Lib for over 3 months and having the DEALER take it back after some legal litagation, this Jeep Lib was the cream of the crop, every possible problem that you can think of happened to this future salvage tin can, make a long story short, I was given every penny that I paid for it PLUS all expenses that I incurred, the DEALER apologized for all the problems and headaces this Jeep caused me, last I heard it was in the local auto salvage yard, good attorney.
disfuntionaljunk

Pueblo, CO

#646 Sep 9, 2011
after purchasing an 07 Jeep Lib Sprt with 28K I would like every Liberty owner to beware, unlike other makes and models which are dependable Jeep Corp has managed to build the #1 piece of JUNK, you heard right JUNK, from the time I purchased my future recycled tin can I have been dumping dollar after dollar into this thing, I have currently paid more in maintaing this hungry money machine than I actually paid for it, It grieves me to inform all you Jeep lovers that I have reached the last straw when the engine locked up, towed it to a mechanic and from there it went to the Auto salvage to be melted down, those of you who still have one of these so called vehicles my advice dump it as soon as possible or you are going to go broke with this so called Jeep Liberty, Jeep Corp shame on you for producing a piece of JUNK in mass numbers, I did report my piece of JUNK to the national transportation lemmon law, it is to late for me but you still have time to dump it.LOL

Tell me when this thread is updated:

Subscribe Now Add to my Tracker

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Jeep Liberty Discussions

Title Updated Last By Comments
2011 Liberty Transmission Issue 22 hr PMolloy 1
2006 jeep liberty sway right when accelerate an... (Apr '10) Aug 20 Moleskyjm 10
2003 sport 3.7 transmission problem Aug 16 B613randon 1
How do you set up U-Connect? (Nov '06) Aug 14 Lee 77
2007 Jeep Liberty Starting Issues (Aug '11) Aug 11 Ana M 51
2007 Jeep Liberty engine light on Aug 8 T Bone 2
2002 jeep liberty won't start Aug 8 lisa 1
More from around the web