Jeep Liberty problems
mdm

Cambridge, MA

#42 May 16, 2007
Concern wrote:
My son has a Liberty 2004 without owners manual. Both brake lights down work when he applies brakes, but the one on the top works fine.
I'm suspecting a bad fuse, but as I said he doesn't have th owners manual.
Can someone let me know which ons is the brake light and where (eng compartment or left of dashboard)?
Thanks
It is number 12 on the interior panel (left of instrument panel). However, I have the same problem and replaced the fuse and this didn't work.
tjsmit5

Fayetteville, AR

#43 May 18, 2007
I have a 2002 Liberty and the stereo has quit. No power, nothing. The fuses are fine, so don't know what to do now.
Also the "check engine soon light" decides when it will come on and when to go off. So, I would not spend ANY money chasing this problem down.
scott

Phoenix, AZ

#44 May 20, 2007
Have the same issue here in the states. I have a 2003 and it started shortly after I bought it. Have taken it in at least 6 times to 4 diffent dealer with no results. Most were unable to duplicate so they tell me there is no issue. One duplicated and stated it was normal and didnt do anything. Told them to replace the trans and they said no. Contacted Jeep Headquarters and they wouldnt do anything either. Told me to work with the dealership. So 4 years into and an no resolution. Will never buy another Jeep. Hope it gets stolen or totalled.
NENA KENT

Greenwood, AR

#45 May 21, 2007
MY JEEP LIBERTY JUST STARTED DOING THE SAME THING. I AM PUTTING IT IN THE SHOP TODAY BUT AFTER READING SOOO MANY OTHE SIMILAR PROBLEMS, I AM VERY WORRIED THE PROBLEM WON'T BE FOUND UNTIL SEVERAL TIMES IN & OUT OF THE SHOP & BEING VERY COSTLY. IF YOU OR ANYONE HAVE FOUND OUT WHAT THE CAUSE OF THIS PROBLEM IS, PLEASE REPLY OR E-MAIL ME AT GORDON24BRAT@AOL.COM. THANK YOU SOOO MUCH.
Carol Young wrote:
My Jeep will start up and run great till it warms up then it will stall, it has to set around 15 to 20 minutes before it will restart. When it stalls and you try to restart it the key when in run position the RPM's will jump back and forth on the tack. The dealer said to tune it up, so we cleaned the throttle body and new spark plugs and need idle position sensor, but did no good still doing the same thing. Please any thought would help.
JeepLady

Aurora, CO

#46 Jun 3, 2007
My 2002 JEEP has 110,000 on it; the stereo comes and goes. I did my research and did all
the fuses and put in a new battery...suggestions to correct the problem. The dealer told
me this happens in the LIberty; he said they take them out return them to Jeep, who sends
back a refurbished radio. He tried to find the "number" on this radio and could not which
stumped him. A new factory radio is $500 dollars. I am looking into a after market radio.
For everyone's info: at 110,000: for the most part this vehicle is a dream. Yes, it has been recalled
three times for the front suspension stuff. The differential pan seal broke (old age); the back window
has a mind of its own sometimes and just pops up; the check engine light finally got corrected by putting
on a "heavy duty" gas cap. I buy 235 tires...makes it handle and ride better.
JeepStressed

Moorestown, NJ

#47 Jun 4, 2007
I have to say that I can't complain much about my Jeep. Its been good so far, until the car completely would not start on this past Friday. It started just fine all day and then Friday night, it just wouldn't work. The lights would come on, the windows would roll up and down, the radio would play, etc.(sluggishly, but eventually)Also, once all the other stuff started lighting up, if you tried to blow the horn or unlock the doors , everything would shut down. So I had it towed to a mechanic and now I'm being told the battery is bad, some wiring was damaged and had to be replaced and that it needs an alternator!$600+...has anybody heard of this happening with this car?! Have you had it happen? I feel like I'm getting snowed and ripped off and there's nothing I can do about it except pay because I need my car.
Brenda

AOL

#48 Jun 6, 2007
Rick wrote:
<quoted text>
I have a 2004 Liberty. All Libertys have Jeep's Command Track 4WD system. The transfer case in this system has no slippage and is describred and advertised as being for "part time" use.Why would you want to use 4WD on bare pavement anyway?
I use mine on bare pavement when it is raining because this thing is lightweight and takes entirely too much stopping time (a car length) on wet pavement - even a light rain. I hate this vehicle. I'll never own another one.
Brenda

AOL

#49 Jun 6, 2007
scott wrote:
Have the same issue here in the states. I have a 2003 and it started shortly after I bought it. Have taken it in at least 6 times to 4 diffent dealer with no results. Most were unable to duplicate so they tell me there is no issue. One duplicated and stated it was normal and didnt do anything. Told them to replace the trans and they said no. Contacted Jeep Headquarters and they wouldnt do anything either. Told me to work with the dealership. So 4 years into and an no resolution. Will never buy another Jeep. Hope it gets stolen or totalled.
I have the 2003 as well and it will be traded this year. I hate it. Have to put it in 4WD when there is even a light rain as it slides on wet pavement if I don't. I drive the interstate every day where they draft like in NASCAR and that's not a good problem to have. My dealership in Indy (PENSKE) totally forgot who the hell I was when I sent in the card so they could keep their 5 Star Rating. Until I sent that in, they called once a week, etc. After I sent it in, happy because they were so attentive, I was treated worse than a bastard stepchild. When I bought it new, out of the showroom, I was promised a spare tire cover and I ordered a cargo cover. That was 6/17/03 - it will soon be 6/17/07 and I've yet to see other or have a phone call returned. National office couldn't care less either. I did have a problem about a year and a half ago - kept hearing a definite 'squawl' from right rear tire when braking. Called another Jeep dealership and, as usual, was treated like a "stupid woman driver" by the snotnosed kids in service. I was driving at '67 GTO convert before their parents met - I know cars! Anyway, turned out to be a crimped brake line. They, of course, had to order the part (it was warranty work, but I was told that there had been enough Liberties with this problem, Jeep was considering making it a recall). Finally, after being without my Liberty for 3 weeks, I found a Mopar part online for a reasonable price, even to drop ship it to me overnight. Funny, when I called the dealership to tell them I had the part they had on back order, mine suddenly 'appeared'. I had my Jeep back in under 48 hours. What a crock. I hope Chrysler-Dodge-Jeep goes bankrupt. The bastards.
Chuknchez

Trenton, NJ

#50 Jun 7, 2007
Had the same problem in my 2002 Liberty Sport. Very simple fix. Your electric fan is going. My fan relay went first. Have your mechanic replace the cooling fan relay (or module as it is called) and the electric fan. Models with standard cooling package do not have a belt driven fan, only an electric one that is controlled by a relay circuit. You can get an replacement fan fron Radiator US (check e-Bay) for about $120 with shipping.
BSC

Jackson, NJ

#51 Jun 12, 2007
I HAVE WATER LEAKING FROM FOOTWELL DASH VENTS ONTO FEET-SEEMS LIKE HEATER BOX-EVAPORATOR CONDENSATION-DRAIN BACKING UP-WHERE IS IT LOCATED?-FIREWALL?
Leo

Wayne, NJ

#52 Jul 1, 2007
carowalk wrote:
<quoted text>
I've had the same problem two times with only 24000 miles, perhaps we should get together with Chrysler?
That really sounds like a good idea cause I have got if replace once already which was under warranty and now it happen again and I was also told by one of their own mechanic that the radio is bad and lots of complains. Now that it's no longer under regular warranty and my extended warranty kicks in and they want to charge me $200 for a refurbish radio. And a new one cost about $500 +. What make it worst the cd was working before taking into the dealer went I went to pick it up from the dealer that's went it stop working of cause it not their problem they say.
Kelly Murray

Vancouver, Canada

#53 Jul 3, 2007
I have a 2004 jeep liberty which recently started making noise in the rear end, I have no owners manual and wanted to know how to check the differential fluid, and or how to grease the axle. I do not think it is anything mechanical becasue it does it when just coasting out of a parking spot in neutral, as it is a 5 speed.
Chris Alden

Wasilla, AK

#54 Jul 10, 2007
We have a 2006 Jeep Liberty and it is at the dealer for a second time since we bought it 10-2006. My wife has come out after work and it doesn't crank or start. The first time this happened the dealer came and got it and said it started right up. The mechanics checked the computer codes and gave it back to us. The second time the dash warning lights came on when she turned the key, but the starter never cranked. Now they are changing a relay pack and the starter. It has been in the shop over a week and they still haven't received the starter. Seems to me they are guessing. I think the next time it doesn't start we will be out in the boonies some where up here. Anyone have a similar problem?
Chris Alden

Wasilla, AK

#55 Jul 11, 2007
Anchorage Lithia Chrysler Jeep got our new starter and relay pack installed and the Jeep Liberty still doesn't start. Now we don't know when we will get it back. It has been 8 Days and counting. This vehicle only has 15,00 miles on it. The first time it went to the shop for the same problem it had 13,000 miles on it.
Chris Alden

Wasilla, AK

#56 Jul 13, 2007
The dealer (Anchorage Lithia Chrysler Jeep) had a computer module shipped over night to try and get the Jeep going. They still can't figure it out why it doesn't start. It seems to me that these Jeep Liberty's are a piece of junk. They now have had the vehicle 10 days and counting. My wife and I are thinking of trading it in on a Chevy. It would be a financial hit, but at least maybe we could count on it to start and have it in out yard instead of sitting at a dealer 60 miles away.
Larry Young

United States

#57 Jul 22, 2007
I have a 2003 Jeep Liberty Limited 2WD with the 3.7 and auto transmission with 85,000 miles. It started shifting very hard at all times. I had the transmission serviced and now it only shifts hard from 3rd to overdrive. Any ideals

Geo

Since: Jul 07

United States

#58 Jul 23, 2007
Chris Alden wrote:
The dealer (Anchorage Lithia Chrysler Jeep) had a computer module shipped over night to try and get the Jeep going. They still can't figure it out why it doesn't start. It seems to me that these Jeep Liberty's are a piece of junk. They now have had the vehicle 10 days and counting. My wife and I are thinking of trading it in on a Chevy. It would be a financial hit, but at least maybe we could count on it to start and have it in out yard instead of sitting at a dealer 60 miles away.
trading it for a chevy will give you more problems than the jeep I have 2 jeep libertys they are diesels they are awesome
Chris Alden

Port Lions, AK

#59 Jul 23, 2007
We got our Jeep Liberty back on the 13th of July. Lithia Jeep Chrysler of Anchorage had it for 10 days. The invoice says that they got the Jeep for repair on the 11th of July, but we had it towed on the 3rd of July. Lithia didn't even seem to have a clue on how to fix the problem, but were just doing parts changing until I got the Jeep Chrysler Corp. involved. The invoice did not reflect the changing of the starter and relay pack that they told us they changed. With this kind of service and honesty, it will be the last product I buy from them. They are even the Chevrolet Dealer here in Alaska. Guess Alaska Sales and Service will get my biz next.
neons8

Altamonte Springs, FL

#60 Jul 29, 2007
2002 liberty the dash lights all of them keep going off and on. I replaced the ignition swicth and have jiggeled all the wires. if I just turn the key to the on point it does it to.
can anyone help
john jay

Austin, TX

#61 Jul 30, 2007
i have a jeep liberty 2004, and i have a problem with the cd player too! the first time it happened, the cd just came out later on that i turned off and on the jeep... but yesterday another cd got stuck and it wont come out whatever is that we do! i'll think i just have to wait for it to come out eventually, but i need it to get out because is not mine...

Tell me when this thread is updated:

Subscribe Now Add to my Tracker

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Jeep Liberty Discussions

Title Updated Last By Comments
2007 Jeep Liberty Starting Issues (Aug '11) Oct 21 Kwt 67
exhaust Oct 9 newkj 1
Liberty '03 insane "clicking" w/ wheel rotation (Feb '08) Oct 6 b Rad 10
How do you set up U-Connect? (Nov '06) Sep 29 DSpears 79
why does my part time 4x4 light come on when I ... (Jan '09) Sep 26 Pkursave 123
2003 Liberty Sport 3.7 Evap Leaks Sep '17 Heidi83 1
2002 Liberty steering column ignition switch/ke... (Jul '06) Sep '17 d0miller 248
More from around the web