Peter

Calgary, Canada

#305 Sep 27, 2009
Both power seats and rear wiper stopped working at the same time on my partners 2003 Jeep Liberty renegade.Has anyone else had this happen all at once? Checked fuses - all okay. The motors or sqwitches are the only thing I haven't checked. Any other suggestions will greatly be appreciated.
Giovan13

Montréal, Canada

#306 Oct 5, 2009
dmac wrote:
had the same type of problem a couple of years ago. the dealer had to replace the computer module. No issues since
Hi, my CD Player motor runs when the ignition is off and key is out every 45-50 seconds in my Jeep Liberty 2008. I brought it to get serviced and they blamed it on the radio.... same problem happened same day I got it back. The battery drained and Im sure its from the cd motor constantly running every 50secs. Brought it back to the servicing dept. and they tried another radio and same issue.. now they are looking deeper into the issue... waiting for their news.

What problems were you experiencing exactly?

Thanks!
Gio

Since: Oct 09

Montréal, Canada

#307 Oct 5, 2009
dmac wrote:
had the same type of problem a couple of years ago. the dealer had to replace the computer module. No issues since
Hi,

I have a 2008 Jeep Liberty and been having issues with my radio. The CD motor keeps running every 50 secs while the Jeep is off and the key is out of the ignition. The service dept. blamed it on a faulty radio and they put it a new one and same problem persisted. Over the weekend my battery drained so obviously it was related. I brought the Jeep back to the service dept. and they tried a 3rd radio only to see the same problem persist again. They need to keep it a little longer to search deeper for the issue.

Do you think the modular might need to be replaced?

What symptoms were you having?

Thanks!
Gio
Gert

South Africa

#308 Oct 7, 2009
I had a simmilar problem on my 2002 3.7 Limited,,,it would die for no apparent reason, normally when you slow down. It stopped doing that AFTER the mechanic replaced the AIR Sensors, I think there are 4 different ones on the 3.7 engine. If you have the same problem I had, this may solve your problem also.
Gert

South Africa

#309 Oct 7, 2009
William Kelly wrote:
Having the problem where it runs great for about 10-15 minutes and then it will stall for no apparent reason, can manage to get it restarted after a few tries but it will only run a mile or two before crapping out again. then once off it becomes very hard to get started. no strange noises from the engine when running. it sounds fine. if i wait about an hour or two and start it again, it will run fine for 10-15 and do it all over again. when it does this the check oil light comes on. i have changed the oil and to no avail it is still doing this. any idea's?
sorry, on my previous post, I lost the heading...

I had a simmilar problem on my 2002 3.7 Limited,,,it would die for no apparent reason, normally when you slow down. It stopped doing that AFTER the mechanic replaced the AIR Sensors, I think there are 4 different ones on the 3.7 engine. If you have the same problem I had, this may solve your problem also.
edward

Mckinney, TX

#310 Oct 10, 2009
2002 jeep liberty engine light ON
repair service center change gas cap, reset, battery power off and on but still same..
what the heck JEEP LIBERTY 2002!
O2 sensor problem? valve problem? or CD deck electrical problem? who know about it?
email me : hackeroh@paran.com
Sandra

Surrey, Canada

#311 Oct 18, 2009
I have a 2003 and I've had some issues as well. The key immobilizer light kept coming on so we brought it to the dealership, they "fixed" it, then it came back, the tried again, ran some tests etc. and couldn't find anything wrong. I figured as long as it runs....fine. Just yesterday morning the Emergency Break light stayed on...the break comes off but the light stays on. Was going to bring it to the dealership again. A little concerned as the breaks now feel a little weak. Stupid thing is I just had it in the dealership to change their squeaky break pads last week. Urg! Time to get a new car!
Amy

Rockville Centre, NY

#312 Oct 19, 2009
Terrie wrote:
<quoted text>
Jim,
I sent you an email with detail. I am having the same problem and my car actually shut off the other day after the engine light started blinking. the dealer is working with me on the problem. It appears to be a valve problem, not rotating and causing build up of dirt, etc. I have a power train warranty for 100,000 miles and I am at 95,000 on my 2002 Jeep Liberty. So, I would have the dealer check that.
I am having the same exact problem. My "malfunction" light came on a couple of days ago. I read the owners manual, and it said that the jeep(2003) would shut off if the light started to blink. I am taking the jeep into the mechanic tomorrow to see what he has to say. It only has 58k on it, and has been maintained very well.
I will keep you posted.....Amy
langong

Oakville, Canada

#313 Oct 25, 2009
when I start my 06 Liberty limited and let it iddle the rmp gauge go up then slowly drop to 0 and the engine shut off then the oil light came on. If I drive right away then it ok. Any idea?
Mimi

Souderton, PA

#314 Oct 26, 2009
I have a 2005 Jeep Liberty and I just noticed the oil light came on, but now it went out. Any suggestions
Dani

Fort Collins, CO

#315 Nov 2, 2009
Hi,
I just need some advice, I have a 2000 Toyota celica, 130,000 miles on it, runs great, no problems at all. I want to ungarde to something better for snow driving, I posted an add on craigslist and some replied wanting to trade me straight across for their 2003 jeep liberty sport, 4wd 6 cyl. I know nothing about jeeps, and I havent heard too many good things about them, does anyone have any advice for me? Would you do it? I appreciate any advice. Thanks.
tammy

Washington, DC

#316 Nov 5, 2009
My 2003 Jeep Liberty has started leaking in water when it rains. This occurs in the front passenger side and I have to actually use cups and towels to clean it up yet can not see where it is coming in from. Has anyone experienced this??? Solution?
Thanks
Liberty

Houston, TX

#317 Nov 11, 2009
JeepLady wrote:
My 2002 JEEP has 110,000 on it; the stereo comes and goes. I did my research and did all
the fuses and put in a new battery...suggestions to correct the problem. The dealer told
me this happens in the LIberty; he said they take them out return them to Jeep, who sends
back a refurbished radio. He tried to find the "number" on this radio and could not which
stumped him. A new factory radio is $500 dollars. I am looking into a after market radio.
For everyone's info: at 110,000: for the most part this vehicle is a dream. Yes, it has been recalled
three times for the front suspension stuff. The differential pan seal broke (old age); the back window
has a mind of its own sometimes and just pops up; the check engine light finally got corrected by putting
on a "heavy duty" gas cap. I buy 235 tires...makes it handle and ride better.
Im afraid the problem is not the gas cap but several hoses a few close to the gas tank and under the car But that is not the worst get ready for a BROKEN VALVE SPRING it could cause mayor damage to the engine jeep liberty with 3.7 L engine have weak valve springs
Liberty

Houston, TX

#318 Nov 11, 2009
Sheridan wrote:
I have a 2002 Jeep Liberty that has had compression problems in the #3 cylinder. Now I am taking the head to a machine shop to have it rebuilt. I don't know what I'm looking at for a cost...? I'm sure labor will be outrageous, but I would like to how much poorer I will be.
Im sorry for your wallet but if your jeep engine is a 3.7 L do yourself a favor and replace all 12 valve springs they are weak and break. Im looking at the broken spring from my jeep liberty 3.7
Liberty

Houston, TX

#319 Nov 11, 2009
edward wrote:
2002 jeep liberty engine light ON
repair service center change gas cap, reset, battery power off and on but still same..
what the heck JEEP LIBERTY 2002!
O2 sensor problem? valve problem? or CD deck electrical problem? who know about it?
email me : hackeroh@paran.com
Take your car to your local autoparts store to have the check engine light read so you will know the code so we can help you more. If they allready changed the gas cap because of a vacuum leak the problem might be a few bad hoses check all hoses close to the gas tank and under the car and all engine hoses... O and by the way save money for the valve problems you are going to have 3.7 engines have weak valve springs that break around 100k miles. if that happens it could damage heads and cylinder and pistons...I do have the broken valve spring to prove it.
Liberty

Houston, TX

#320 Nov 11, 2009
Dani wrote:
Hi,
I just need some advice, I have a 2000 Toyota celica, 130,000 miles on it, runs great, no problems at all. I want to ungarde to something better for snow driving, I posted an add on craigslist and some replied wanting to trade me straight across for their 2003 jeep liberty sport, 4wd 6 cyl. I know nothing about jeeps, and I havent heard too many good things about them, does anyone have any advice for me? Would you do it? I appreciate any advice. Thanks.
Hi I own a 02 jeep liberty 3.7 engine with 105,000 miles and I can tell you this is not good on gas its been great until i got a broken valve spring and that is serious it seems they have weak valve springs, get them replaced, its not going to be cheap
Liberty

Conroe, TX

#321 Nov 11, 2009
langong wrote:
when I start my 06 Liberty limited and let it iddle the rmp gauge go up then slowly drop to 0 and the engine shut off then the oil light came on. If I drive right away then it ok. Any idea?
could be your MAP sensor check with volt meter at iddle you have high vacuum, sensor should be sending .5 volts to the PCM if higher bad sensor... assuming that the TPS is working
eric

United States

#322 Nov 20, 2009
Jeff wrote:
We have a 2004 Liberty and recently we started getting the check engine light quite a bit and what seemed like some transmission issues, took in and was told it was an issue with the a circuit that runs from the the gas pedal switch to the engine. There is a short or some similar type problem, but it isnt the switch. At a stop the rpm's will race up causing the car to surge or jump. Anyone had any issues like this? And how did you remedy this? Dealer, private shop? I only have 50k on it and everyone who has looked at it says it runs great except for this problem, but no one knows how to fix it and our local jeep dealer is less than reliable.
I have had the same problem. changed the throttle sensor, but that did not help. it's in the effing dealer right now. i'll let you know if i find anything out. how did yours end up?
eric

United States

#323 Nov 20, 2009
tammy wrote:
My 2003 Jeep Liberty has started leaking in water when it rains. This occurs in the front passenger side and I have to actually use cups and towels to clean it up yet can not see where it is coming in from. Has anyone experienced this??? Solution?
Thanks
Same problem but front passenger side. freaking sucks. 2002 liberty, problem started about 1 year ago. no solution-- too cheap/angry to bring it to anyone.
eric

United States

#324 Nov 20, 2009
Dmcdo wrote:
Have a 2002 Jeep Liberty Sport 3.7. Driving to work yesterday morning, Thought I had started to slide on ice/snow , let foot off gas ,accelerated again and it wouldn't go into second (automatic transmission), felt like i was in Nuetral. Had it towed, they have done all tests they can and everything comes back ok.They think it is the transmission . I have 96,000 miles on it .Have had no problems driving .no noises ,no slippage or hesitation when shifting .No smell either .Nothing to indicate I was having an issue anyone else have or has had an issue like this If so what was it.
Get the throttle sensor changed-- had the same thing happen and ignored it for a day. kept running fine for a few days and then while driving 65 mph on highway it happened again and almost died.
new throttle sensor cost $60 and paid $200 for repair. found out later it is an easy DIY fix.

Tell me when this thread is updated:

Subscribe Now Add to my Tracker

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Jeep Liberty Discussions

Title Updated Last By Comments
2007 Jeep Liberty Starting Issues (Aug '11) 3 hr pboopter 37
Jeep liberty noise-- sounds like metal rubbing (Jul '06) Mon Tanner 156
2012 jeep liberty performance May 2 cathyw 1
why does my part time 4x4 light come on when I ... (Jan '09) Apr 27 Chinksforlife 85
How do you reset the "Change Oil" Warning (Oct '09) Apr 18 dakotab 48
05 Jeep Liberty Water Leak (Aug '08) Apr 12 Mick 44
2002 Jeep Liberty Right Brake Light Doesn't Work (Jul '09) Apr 11 rjw1794 23
More from around the web