First Prev
of 48
Next Last
Carol Young

Columbus, OH

#1 Nov 25, 2006
My Jeep will start up and run great till it warms up then it will stall, it has to set around 15 to 20 minutes before it will restart. When it stalls and you try to restart it the key when in run position the RPM's will jump back and forth on the tack. The dealer said to tune it up, so we cleaned the throttle body and new spark plugs and need idle position sensor, but did no good still doing the same thing. Please any thought would help.
Ken - Karon Miller

Little Rock, AR

#2 Nov 26, 2006
We have a 2003 Jeep Liberty that is doing the exact same thing. 3 times we have had it to the dealer and its still doing the same. Their next option is to replace the computer unit but we think it has something to do with something in the gas tank! Will keep you up to date.
Email: kmill88@sbcglobal.net
Abdi

Moultonborough, NH

#3 Dec 7, 2006
my jeeb liberty 2002 it start up and run great untill I tryed to wash my car it shut of the hole engine i dont know what is cousing that problem can some on help me....
Jim

Shelton, CT

#4 Dec 16, 2006
I was wondering if anyone could help with a problem my wife has been having with her 2003 Jeep Liberty Limited. The vehicle has 88K miles and runs well. About 2 months ago, the check engine light came on and wouldn't go off. My wife took it in for an early oil change and diagnostic. The oil change didn't solve the problem and the diagnostic showed nothing wrong. Then a few days later, the light went off. A few days later the light came back on again. She then brought the vehicle to a mechanic and, after diagnosing the vehicle for over 2 hours, decided that the gas cap needed to be replaced. The light went off. 2 days later, the light came back on again. Brought the vehicle back to the same mechanic who did a full oil change, tune-up and replaced the gas sensor. The light went off. That was yesterday. Today, the light came back on again. I refuse to bring it to another mechanic and have them "guess" at the problem, charge us an arm and a leg and wind up having the liht come back on a few days later. Any suggestions?

You can contact me at adamscrnr@comcast.net

Thanks to anyone who can assist..

Jim
freddy_b

Canada

#5 Dec 21, 2006
Jim wrote:
I was wondering if anyone could help with a problem my wife has been having with her 2003 Jeep Liberty Limited. The vehicle has 88K miles and runs well. About 2 months ago, the check engine light came on and wouldn't go off. My wife took it in for an early oil change and diagnostic. The oil change didn't solve the problem and the diagnostic showed nothing wrong. Then a few days later, the light went off. A few days later the light came back on again. She then brought the vehicle to a mechanic and, after diagnosing the vehicle for over 2 hours, decided that the gas cap needed to be replaced. The light went off. 2 days later, the light came back on again. Brought the vehicle back to the same mechanic who did a full oil change, tune-up and replaced the gas sensor. The light went off. That was yesterday. Today, the light came back on again. I refuse to bring it to another mechanic and have them "guess" at the problem, charge us an arm and a leg and wind up having the liht come back on a few days later. Any suggestions?
You can contact me at adamscrnr@comcast.net
Thanks to anyone who can assist..
Jim
A few years ago, I had the same problem with my Nissan Sentra. I asked the mechanic at the dealership about the check engine light. He told me that it was basically a gimic that was programmed to come on at 40,000 km to remind the owner that the vehicle should be brought in for service so that the emissions and general operation of the engine & components could be "serviced"....whethe r it needed it or not. I imagine the one in my 2003 Liberty will come on soon, I have 62,000 km on it and I don't know when it's programmed to come on, but I will probably ignore it because I believe its just a money grabbing scam.
Maria

San Mateo, CA

#6 Jan 4, 2007
Same problem here - 2002 Liberty Limited...runs fine until it warms up - then shuts off. The RPM niddle goes crazy when I turn the key and no one can help...any suggestions? We changed the throttle sensor, but that didn't help. Someone suggested it might be the computer, but we are still trying to see if it's something else before we go that route. Please if any one has a suggestion...lospenas1@juno.co m
Thanks
Maria

San Mateo, CA

#7 Jan 4, 2007
Carol Young wrote:
My Jeep will start up and run great till it warms up then it will stall, it has to set around 15 to 20 minutes before it will restart. When it stalls and you try to restart it the key when in run position the RPM's will jump back and forth on the tack. The dealer said to tune it up, so we cleaned the throttle body and new spark plugs and need idle position sensor, but did no good still doing the same thing. Please any thought would help.
Did you ever get any suggestions on this...it sounds like we have similar problems..
Terrie

Chicago, IL

#8 Jan 11, 2007
Jim wrote:
I was wondering if anyone could help with a problem my wife has been having with her 2003 Jeep Liberty Limited. The vehicle has 88K miles and runs well. About 2 months ago, the check engine light came on and wouldn't go off. My wife took it in for an early oil change and diagnostic. The oil change didn't solve the problem and the diagnostic showed nothing wrong. Then a few days later, the light went off. A few days later the light came back on again. She then brought the vehicle to a mechanic and, after diagnosing the vehicle for over 2 hours, decided that the gas cap needed to be replaced. The light went off. 2 days later, the light came back on again. Brought the vehicle back to the same mechanic who did a full oil change, tune-up and replaced the gas sensor. The light went off. That was yesterday. Today, the light came back on again. I refuse to bring it to another mechanic and have them "guess" at the problem, charge us an arm and a leg and wind up having the liht come back on a few days later. Any suggestions?
You can contact me at adamscrnr@comcast.net
Thanks to anyone who can assist..
Jim
Jim,
I sent you an email with detail. I am having the same problem and my car actually shut off the other day after the engine light started blinking. the dealer is working with me on the problem. It appears to be a valve problem, not rotating and causing build up of dirt, etc. I have a power train warranty for 100,000 miles and I am at 95,000 on my 2002 Jeep Liberty. So, I would have the dealer check that.
hopalongliberty

Port Alberni, Canada

#9 Jan 15, 2007
Have a 2003 liberty ltd it hops around corners,put in any 4x4 mode and it feels like its binding in the rear and bangs and thumps when turning. Took it to a dealer had the diffs lubed and the guy actually tried to tell me you should'nt drive in 4 wheel if it's not snowing (huh?) any input.
cdnlibby

Winnipeg, Canada

#10 Jan 16, 2007
I was wondering if anyone could help with a problem my wife has been having with her 2003 Jeep Liberty Limited. The vehicle has 88K miles and runs well. About 2 months ago, the check engine light came on and wouldn't go off. My wife took it in for an early oil change and diagnostic. The oil change didn't solve the problem and the diagnostic showed nothing wrong. Then a few days later, the light went off. A few days later the light came back on again. She then brought the vehicle to a mechanic and, after diagnosing the vehicle for over 2 hours, decided that the gas cap needed to be replaced. The light went off. 2 days later, the light came back on again. Brought the vehicle back to the same mechanic who did a full oil change, tune-up and replaced the gas sensor. The light went off. That was yesterday. Today, the light came back on again. I refuse to bring it to another mechanic and have them "guess" at the problem, charge us an arm and a leg and wind up having the light come back on a few days later. Any suggestions?

I had same problem but changed the filter and enging light went out. Make sure when u get an oil change they change the air filter too.
hopalongliberty

Port Alberni, Canada

#11 Jan 17, 2007
Bough mine 1 year ago and learned about the ball joint recall,took it to Ensign chrysler and was delighted at their courtious proffesionalism. Other company said call periodicaly to see if we have any, same company that took it for a test to find out why it binds in4x4 mode and said nothing wrong these jeeps do that. Ensign is going to take care of this problem also. Hmmmm wonder where i'll shop for any future chrysler products.
Rick

Bridgewater, Canada

#12 Jan 21, 2007
hopalongliberty wrote:
Have a 2003 liberty ltd it hops around corners,put in any 4x4 mode and it feels like its binding in the rear and bangs and thumps when turning. Took it to a dealer had the diffs lubed and the guy actually tried to tell me you should'nt drive in 4 wheel if it's not snowing (huh?) any input.
I have a 2004 Liberty. All Libertys have Jeep's Command Track 4WD system. The transfer case in this system has no slippage and is describred and advertised as being for "part time" use.Why would you want to use 4WD on bare pavement anyway?
John

AOL

#13 Feb 1, 2007
The 2003 liberty Has a Comp Problem, My brothers and I are working on one now! We did coils and spark plugs, for it having a stalling problem. Its would only stay idel if you open the idel, it you have it a normal idel it would shut off. Now The idel control moduel is On Back order so I am guessing that is the Problem. We changed The Iach moter no chang. I will update you when I install the PCM/Computer.

Since: Feb 07

United States

#15 Feb 3, 2007
Has any1 had any problems with the factory installed CD player? I have a 2005 Liberty and have had the CD player replaced twice now, and the one I have now, almost felt like the CD was going to get stuck...which is how the problem starts. It is a 1-CD player. Fortunately, it has been covered under the warranty, so far! The dealership tells me there are no other reports of problems, that they know of. Any1?
Bob B

Terrebonne, Canada

#16 Feb 10, 2007
Just today, in my 2005 Liberty, the CD will not eject. Any suggestions?

Since: Feb 07

United States

#17 Feb 16, 2007
Bob B wrote:
Just today, in my 2005 Liberty, the CD will not eject. Any suggestions?
As you may have read, I had the same problem! CDs would get stuck, periodically, but it would eventually release it.(Eventually) That was the first time. The second time, the player partially released the CD, and I pulled it out, with force, and then it kept showing "ERROR". Both times, the dealership nearest to my home, replaced it with no problem, as it was under warranty, still. So, with that, I guess my only suggestion would be to bring it to the dealership and get a new one. If you are no longer under warranty, I might suggest replacing it with a different brand from whatever the factory install is. This is assuming the problem is with the CD player, and not some strange problem that is generated from the Jeep itself!! Good luck!!
Tom P

United States

#18 Feb 21, 2007
Engine light on with slipping ini tranny. 2003 JP Liberty.

Anyone have any tranny issues? thoughts and prayers welcome

Since: Feb 07

United States

#19 Feb 25, 2007
Well...I just noticed what appears to be tranny fluid leaking...back to the Jeep dealership I go tomorrow...still have about 3500 miles before my warranty runs out...I am wondering if perhaps the extended warranty might have been a good investment???
edawg

Lewiston, ME

#20 Mar 5, 2007
i bought a 2002 jeep liberty with 68,000 miles recently but am having some problems. the spedometor does not work sometimes, nor does the radio. just the other day the oil light came on and the car stalled while i was driving it. i checked the oil and it was full. i'm guessing the problem is either a computer problem or a fuse needs replacement. can anyone help me figure out what the problem is?
Matt

East Weymouth, MA

#21 Mar 9, 2007
I own a 2005 Jeep Liberty 4 x 4. Today the Malfunction light came on and has not gone off. I am nearing 20,000 miles. Does anyone feel this is a common occurrance to get the Jeep in for Service? Anything else I should check?

Tell me when this thread is updated:

Subscribe Now Add to my Tracker
First Prev
of 48
Next Last

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Jeep Liberty Discussions

Title Updated Last By Comments
2008 Liberty Dead Battery Issues (Jun '09) Dec 14 thomsthoms 11
2007 Jeep Liberty Starting Issues (Aug '11) Dec 7 Peone 35
2006 Jeep Liberty A/C Problems (Aug '13) Dec 6 Euria carlton 5
part time 4 wheel drive light on (Feb '11) Nov 22 johnny57 5
Win A Car For Christmas! (Nov '09) Nov 20 Deanna Sanders 33
02 Jeep Liberty 3.7 replaced engine - turns ove... (Jun '09) Nov 20 Not Happy 39
2010 JEEP LIBERTY, clicking electric actuator m... Nov '14 Philabison 1
More from around the web