Jeep Liberty CRD
First Prev
of 5
Next Last
Towcar

Brunswick, ME

#1 Jan 20, 2006
I have an 06 Liberty with the diesel in it. I'm satisfied for the most part although there is a vibration at 52 to 55 MPH. I have had it in the dealer where they installed a new drive shaft but it didn't help. I drove another Liberty diesel and it has the same vibration although not as bad as mine. Now the dealer is telling me there is nothing wrong and that all of them vibrate at that speed.

I'm asking if anyone else is having the same problem.
Ben

United States

#2 Jul 29, 2006
I have had the same vibration occur in my 2002 Lib (gas) at 48 to 52 mph. I believe there is just some resonance in the drive shaft supports. I work as a noise and vibration engineer at merc marine.
Drew

Minneapolis, MN

#3 Dec 15, 2006
I have a 2006 Liberty CRD. I have heard of people getting 25 mile per gallon with theres. I drive 100 miles a day for work a mix of highway and county roads. I have never seen anything over 22 miles per gallon. Is there anything I can do to get this number up??
Bob Jasper IN

United States

#4 Dec 26, 2006
Have any of you noticed that your brake pedal will fade all the way to the foor if you press hard while stopped ? My dealer tells me all of the diesels do that. Funny it didn't start until they replaced the master cyl. I have checked other gas Liberty's and one 06 CRD , they all have a hard pedal.Am I just beeing screwed with?
mics28

Coatesville, PA

#5 Jan 6, 2007
Bob Jasper IN wrote:
Have any of you noticed that your brake pedal will fade all the way to the foor if you press hard while stopped ? My dealer tells me all of the diesels do that. Funny it didn't start until they replaced the master cyl. I have checked other gas Liberty's and one 06 CRD , they all have a hard pedal.Am I just beeing screwed with?
Mine certainly doesn't. Sounds to me like they didn't install the master cylinder properly. I'm pretty sure they should be able to re-adjust it so your pedal isn't so mushy- if they say they can't, then yes, they are definitely screwing with you.
freddy_b

Vancouver, Canada

#6 Jan 7, 2007
Towcar wrote:
I have an 06 Liberty with the diesel in it. I'm satisfied for the most part although there is a vibration at 52 to 55 MPH. I have had it in the dealer where they installed a new drive shaft but it didn't help. I drove another Liberty diesel and it has the same vibration although not as bad as mine. Now the dealer is telling me there is nothing wrong and that all of them vibrate at that speed.
I'm asking if anyone else is having the same problem.
I have a 2003 Jeep Liberty and I have a slight vibration around 75-80 km/h, which is similar to what you are reporting. It's a minor thing that I have learned to live with. It seems to me that this is a commom problem and no one has an answer for it. Maybe the drive shaft is not correctly balanced???
Greg

Traverse City, MI

#7 Jan 14, 2007
'06 Lib/CRD. I have no vibs in mine.
jim

Roxbury, PA

#8 Jan 20, 2007
for all those liberty drive train vibrations, look underneath the rear end, you will see a piece of weight which the manufaturer attached to counter effect the vibration issue.
Doug

AOL

#9 Jan 21, 2007
Mileage seems to vary a great deal in my 2005 CRD.
Also have a rough sounding noise when I am driving in traffic, throttle up to pass and release the throttle again right away. Has anyone else experience this rough, metalic noise?
Had the torque converter recall completed, took over 8 days as the dealer's mechanic broke linkage when removing the transmission and had to order parts, not sure where they came from. When I finally picked up the CRD, I noticed a loud snapping sound everytime I turned. I crawled under the Jeep to find the mechanic left the rear mounting bolts out of the back of the transmission.
you would think after 8 days, he would have fingured it out... nope!
Now the CRD has a check engine light on and the dealer is saying it's a bad glow plug.. parts are on order again.
I think the CRD's would be a pretty fair unit if the dealers were trained and capable. Hasn't happened by the sounds of things.
ray

Charlotte, NC

#10 Feb 2, 2007
I have a 06.been having problems with it. its been to 4 different dealers. none have fixed it. now they refuse to look at it.they say now that its been to too many dealers or they don`t have anyone qualified to fix it. its been broken for 3 months now. it won`t start unless you spray ether in it. plus when you`re going down the road it loses power until you turn the switch off and turn it back on and then its fine for a while. has anyone else had these problems?
Ken

Eddington, ME

#11 Feb 7, 2007
Mine has been in the shop seven days now for they same problem as yours. They are waiting for parts. I'm not sure if they know how to cure it. I feel as if I own some sort of foreign sports car. I'm considering buying an extended warranty or getting rid of it as a trade in. Although I like the car when it's running. You might try posting a question on lostkjs.com , they have a section on the crd. Good Luck
ray wrote:
I have a 06.been having problems with it. its been to 4 different dealers. none have fixed it. now they refuse to look at it.they say now that its been to too many dealers or they don`t have anyone qualified to fix it. its been broken for 3 months now. it won`t start unless you spray ether in it. plus when you`re going down the road it loses power until you turn the switch off and turn it back on and then its fine for a while. has anyone else had these problems?
Harry C lake Tx

Austin, TX

#12 Feb 12, 2007
I am having a problem with my speedometer reading 3-4 MPH low and the odometer is off .1 in a mile and it is culmative. 2006 Liberty 4WD crd, just wondering if anyone has had this problem or if anybody has checked to see. Dealer says nothing is wrong
Edo

United States

#13 Feb 13, 2007
I own a 2006 jeep liberty crd automatic its been great so far but does anyone know if it is ok to hold the breck and rew the engine around 15,000-20,000 RPM when lounching off a green light because i have heard that i need to worm up my turbo to get a better performance and does anyone know how fast a crd can go or does it have a governer.
bcalvert

Irving, TX

#14 Apr 18, 2007
2002 lib and my swing gate won't open anymore...has anyone else had this problem
DarbyWalters

AOL

#15 May 10, 2007
1 ) The speedo does read about 3-4 miles too low and the odometer reads 4% lower than actual miles travelled. 2 )As for the Transmission Shudder with the CRD, there can be many reasons for this. The F37 Customer Satisfaction Bulletin is supposed to address this with Torque Converter Replacement among other things. Shuuter typically happens at 35 and 55 mph. You might also have a Fuel Heater Soleniod leak at the fuel filter head. You can pump the primer and look for bubbles at the electric connections (with the vehicle turned off). 3 )The "donkey balls" that hang down at the rear diff are to stop vibration at the rear driveshaft. 4 )NO!!! do not rev it up and power brake the CRD. You will do nothing but possibly get a MIL code referring to Brake/Turbo interplay. 5 )As for mileage, winter blend fuels will get less mileage. Expect 20-21 City stop n' go, 27 pure hwy and 23-24 combined. On the highway the best speed/mpg is 68mph...I have recorded over 30 at that speed with Cruise Control engaged. 6 ) Metallic Noise is probably a Turbo out of whack with your description. Some tend to do that and the dealer should replace. 7 )Ray, you have a fuel delivery problem. Have the "stealership" replace the Fuel Filter Housing Assembly...it is probably leaking at the heater solenoid. DO NOT use ether in a Diesel...Instead use the primer pump on the side of the Fuel Filter Housing Unit.
Geo

Milwaukee, WI

#16 May 16, 2007
I have 2 liberty crd's they average 25-30 mpg I use a premium diesel fuel only. do not use just any diesel fuel you will have problems the liberty's require a good quality diesel and use only mobil 1 synthenic oil o w 40 I love my crd's
Geo

Milwaukee, WI

#17 May 16, 2007
Doug wrote:
Mileage seems to vary a great deal in my 2005 CRD.
Also have a rough sounding noise when I am driving in traffic, throttle up to pass and release the throttle again right away. Has anyone else experience this rough, metalic noise?
Had the torque converter recall completed, took over 8 days as the dealer's mechanic broke linkage when removing the transmission and had to order parts, not sure where they came from. When I finally picked up the CRD, I noticed a loud snapping sound everytime I turned. I crawled under the Jeep to find the mechanic left the rear mounting bolts out of the back of the transmission.
you would think after 8 days, he would have fingured it out... nope!
Now the CRD has a check engine light on and the dealer is saying it's a bad glow plug.. parts are on order again.
I think the CRD's would be a pretty fair unit if the dealers were trained and capable. Hasn't happened by the sounds of things.
I have noticed that most of these dealers dont have the technicians trained to work on the diesel lib. Chrysler requires 5 star dealers to emply techs trained on these engines so make sure the dealer you take your diesel lib to is a 5 star dealer
Geo

Milwaukee, WI

#18 May 16, 2007
Towcar wrote:
I have an 06 Liberty with the diesel in it. I'm satisfied for the most part although there is a vibration at 52 to 55 MPH. I have had it in the dealer where they installed a new drive shaft but it didn't help. I drove another Liberty diesel and it has the same vibration although not as bad as mine. Now the dealer is telling me there is nothing wrong and that all of them vibrate at that speed.
I'm asking if anyone else is having the same problem.
I have 2 diesel libs I have not had this problem
Fred

Springfield, VA

#19 Jun 25, 2007
Towcar wrote:
I have an 06 Liberty with the diesel in it. I'm satisfied for the most part although there is a vibration at 52 to 55 MPH. I have had it in the dealer where they installed a new drive shaft but it didn't help. I drove another Liberty diesel and it has the same vibration although not as bad as mine. Now the dealer is telling me there is nothing wrong and that all of them vibrate at that speed.
I'm asking if anyone else is having the same problem.
Yep, I just left the dealer after dropping my '05 Liberty (non-diesel) off for the third time and they are saying the same thing. At this point they are saying they will try rotating the drive shaft (they tell me there are eight different points they can rotate it to) and see if that helps. Otherwise, don't cruise between 50 and 55mph - children, can you say r-e-c-a-l-l.
Eric

Dallas, TX

#20 Jun 28, 2007
freddy_b wrote:
<quoted text>
I have a 2003 Jeep Liberty and I have a slight vibration around 75-80 km/h, which is similar to what you are reporting. It's a minor thing that I have learned to live with. It seems to me that this is a commom problem and no one has an answer for it. Maybe the drive shaft is not correctly balanced???
On my 2003 liberty Limited (gas) 4x4 I have a vibration that occurs in the rear at 40 to 50 MPH only. It justed started mildly about two months ago and went away. Now it is back and much worse. It's like going over a washboard road and lasts about 5 seconds. As long as you are at 40 to 50 mph it recurs every minute or so. Once you drop below 40 or get up past 50 it goes away. does it in both 2-wheel and 4-wheel drive, though it is worse in 4-wheel drive mode (full time version).
I have discovered via testing that it is the over drive feature. If I turn it off the problem goes away. If I turn it on it starts up again.

Have your dealer check that out. The overdrive would come into play about that speed and may be have problems during the transition.

Tell me when this thread is updated:

Subscribe Now Add to my Tracker
First Prev
of 5
Next Last

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Jeep Liberty Discussions

Title Updated Last By Comments
05 Liberty engine in 04 Ram need help Fri 04DodgeRam 1
2002 Jeep Liberty Headlight off/on (Jan '11) Dec 11 John 21
2002 Jeep Liberty No Heat. Dec 7 Anonymous 1
How do you set up U-Connect? (Nov '06) Dec 5 Deebo79 80
My 03 Liberty makes a "fart" noise (May '07) Dec 4 Laura 91
2004 Jeep liberty problems (Sep '08) Nov 29 Glenda 58
electrical problem Nov 29 Glenda 2
More from around the web