why does my part time 4x4 light come on when I switch to 2wd?

Posted in the Jeep Liberty Forum

First Prev
of 5
Next Last

Since: Jan 09

Le Mars, IA

#1 Jan 18, 2009
I recently purchased a 2005 jeep liberty sport and noticed the "part time" light on the dash when the vehicle is in 2wd. When placing the vehicle in 4high the light turns off. The 4wd engages though. I found this odd so I looked in the manual and it states that in 4high the dash should say part time. Any suggestions? I bought the jeep privately but I called the local jeep dealer. They said they have never heard of this. One guy thought thats how its supposed to be. But from reading the manual I don't think that this is how it is supposed to be.
Greg

El Paso, TX

#2 Feb 6, 2009
I hade same exact problem on my 2003 Liberty. It turned out to be a faulty transfer case switch. Dealer replaced at cost of about $250.
----------
I recently purchased a 2005 jeep liberty sport and noticed the "part time" light on the dash when the vehicle is in 2wd. When placing the vehicle in 4high the light turns off. The 4wd engages though. I found this odd so I looked in the manual and it states that in 4high the dash should say part time. Any suggestions? I bought the jeep privately but I called the local jeep dealer. They said they have never heard of this. One guy thought thats how its supposed to be. But from reading the manual I don't think that this is how it is supposed to be.
medinapool

United States

#3 Feb 7, 2009
i read another forum that suggested driving in reverse for 100 feet or so. Sometimes it will reset the sensor.
Rob

West Palm Beach, FL

#4 Aug 5, 2009
These are some of the best answers I have found yet. My 03 just started doing this. If and When I get a real answer I'll get back to you guys.
Carl

Overland Park, KS

#5 Aug 6, 2009
I just bought a 2005 Liberty and it is doing the same thing. I tried the recommendations I found in another forum 1)drive in reverse 2) Drive and move back from 4H to 2. I also put it in 4L for a bit. Somewhere along the way the light went off. But this morning it is back on. Mine is under a very limited warranty, so I'm going to get dealer to look at it - but dealer isn't jeep dealer. My guess is that it is the switch.
clark

Gallatin, TN

#6 Sep 27, 2011
i just bought an 06 yesterday and got the same issue today. from reading mechanics reviews it is a sensor that goes bad. but it does not state what harm it will do if left unfixed. when i called the dealer i got the same story " we have never had a problem with the sensor you are talking about"... but in the few hours i have been looking for a solution i have seen thousands of posts of this same issue..
bill

United States

#7 Dec 11, 2011
Same problem I just stop vehicle put it in 4hi and go a bit up the road stop put back in 2hi back up alittle bit and it fixes it for about a month
alex

Aurora, CO

#8 Dec 12, 2011
Is there an easy way to tell if it's the transfer switch or the sensor? Can these items be changed out without the help of a mechanic?
ron

Roseville, CA

#9 Feb 4, 2012
i have a 2006 liberty with the same problem, and i work at an auto shop, my mechanic has never heard of the problem, however he does not specialize in just one auto maker,i find it odd that the dealers have never heard of this problem, or are they just not wanting to accept that it is a manufacture problem, it is the transfer case switch, you can get it done cheaper by a local mechanic rather than the dealer prices, good luck everyone
donnieontario

Canada

#10 Mar 30, 2012
I have a 2003 liberty. I was driving along about 90/km/HR....when I heard a noise under the Hood almost like a howling. It disappear s when lettingoff the throttle but again you hear it when on the gas. I have a code coming up for a co2 sensor but recently it wont start by the ignition or by jumping it. I figure a starter but I just today tried to put it in neutral to move it ahead and it wont budge. Any ideas?
Tammy

Wichita, KS

#11 Jun 21, 2012
I'm having the same problem with my 2005 with the Part Time light. I called the dealer and talked to someone in the shop, they told me that it's suppose to be on when in 2 wheel low. I told him that it's never been on before. I had to put it in 4 wheel drive yesterday and that the light wont go off now. They are a Jeep dealer. I feel they are wrong and they are just saying this so something will break and they get more money when it has to be fixed.
migs 32835

Tampa, FL

#12 Oct 21, 2012
It is a the tumbler pin in your steering column and egnition (as skinny as the end of a fork.) it cracked thats why you are not able to get the egnition to turn. Jeep does not want to make a recall on this but it happens to alot of their vehicles. i had to either pay over $1100 for a new steering column at the dealer or take a risk (the economical route) and get the entire steering column from the junk yard for $400. i did the latter of the two. less then a month went by and it occoured again! same problem. I took it back to my mechanic and he covered the parts and labor however, he told me he would never work on that problem again. To date knock on wood no problem. been about 2 months now.
btw... i had the same problem with that co2 sensor. simple fix.
donnieontario wrote:
I have a 2003 liberty. I was driving along about 90/km/HR....when I heard a noise under the Hood almost like a howling. It disappear s when lettingoff the throttle but again you hear it when on the gas. I have a code coming up for a co2 sensor but recently it wont start by the ignition or by jumping it. I figure a starter but I just today tried to put it in neutral to move it ahead and it wont budge. Any ideas?
migs 32835

Tampa, FL

#13 Oct 21, 2012
I'm having the same issue with the part-time light on. i will try the suggestions that have been given above. hopefully they will work.

on another note it seems that ALOT of Jeep Liberty owners are having the same issues... I'm almost postive 60-75% have had to change the motor on your windows already.

FOR SALE: Jeep Liberty 05'---- 66,000 miles 4wd :-( lol

This has been the most difficult car that i have owned and i bought the car brand new out the box. not a happy customer right now. I've given up talking to the "so called Chrysler Dodge and Jeep certified nuckle heads at the dealership." As most of you have posted already, these guys either dont know their product or would rather avoid talking to an upset owner that just keeps getting the run-around.

I'm almost positve they hear about all these issues on a daily basis!
hypox

Three Rivers, MI

#14 Dec 27, 2012
I just started having the same problem with my part time light. Yesterday I went to put my 2005 Liberty in 4WD and the light didn't come on. I thought there was something wrong with the 4WD itself but it was working. Today I took it out of 4WD and the part time light came on. In 2 hi light on, in 4 hi light off. I'm taking it in to have a tune up next week, so I'll ask about it. I'm not going to the Chrysler deal so we will see
tigerfan

United States

#15 Dec 28, 2012
hypox wrote:
I just started having the same problem with my part time light. Yesterday I went to put my 2005 Liberty in 4WD and the light didn't come on. I thought there was something wrong with the 4WD itself but it was working. Today I took it out of 4WD and the part time light came on. In 2 hi light on, in 4 hi light off. I'm taking it in to have a tune up next week, so I'll ask about it. I'm not going to the Chrysler deal so we will see
Wow it must be a Michigan issue as mine did the samething around the sametime yesterday! My Jeep is 2006. You would think with as many posts there are on this issue that Jeep would have a recall on the defective sensor.
jamac

Portage, MI

#16 Dec 28, 2012
Nice to know I am not alone. I have a 2003 liberty. The "part time" light has been on while in 2 high, for probably 2 years. It goes off when in 4 high, opposite of what is used to do, and should do. No adverse effects, mechanically, have been experienced (knock on wood).
Jeep owner

Cincinnati, OH

#17 Dec 30, 2012
I have a 2003 Jeep Liberty and my part time light in also staying on when its in the 2 wheel position. This just happened yesterday while someone wasshowing me how to put it into 4 wheel drive. I have had it in 4 wheel a few times this year and it was working fine. leaver down(2 wheel)with no part time light on. Lever up (4 WHEEL) part time lght on. I agree with the fact that it needs to be recalled!!!
Liberty Owner

Portsmouth, OH

#18 Dec 31, 2012
I had this problem as well.
I have a 2004 Jeep Liberty
It's just an idiot light..
You should be able to fix this problem by reversing in 4lo in 2nd and 3rd back and forth.
switching in and out of 2wds and 4wd as well.
I play'd around with it for about 15 minutes and it fixed itself.
If you don't have a long driveway to fix it..Maybea family member has farm pasure you could do this!!
Liberty Owner

Portsmouth, OH

#19 Dec 31, 2012
By the way his worked for me twice in the past and each time I managed to fix it the same way. By reversing and going forward from 4lo and switching in and out of D,2nd, and third. However, before you spend $250.00 or more from the dealer to fix it...give it a try, it shouldn't hurt anything.
tim

Culloden, WV

#20 Jan 1, 2013
Same thing happened to me last night, what's the heck?

Tell me when this thread is updated:

Subscribe Now Add to my Tracker
First Prev
of 5
Next Last

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Jeep Liberty Discussions

Title Updated Last By Comments
Jeep Liberty problems (Nov '06) Sun Angel 974
2012 jeep liberty performance May 19 cathyw 2
Who to trust (Power Steering Problems and Noises) (Feb '08) May 17 some guy 69
2002 Jeep Liberty Issues May 14 OklahomaJeep 1
Jeep liberty noise-- sounds like metal rubbing (Jul '06) May 11 Deon rohner 157
2007 Jeep Liberty Starting Issues (Aug '11) May 6 pboopter 37
How do you reset the "Change Oil" Warning (Oct '09) Apr '15 dakotab 48
More from around the web