First Prev
of 2
Next Last
ryan

Molalla, OR

#21 Feb 28, 2011
i have a 99 grand cherokee and my son left the door open and ran the battery dead and now it has a fast idle at about 2 grand. HA dit all the way wramed up a couple times and jsut doesnt go away.
ericcaldwell

Chicago, IL

#22 Mar 30, 2011
i have a 1993 grand cherokee limited with a 4.0. i had a low idle when i bought it, i replaced the idle air control valve, throttle position sensor, coolant temp senor, manifold air temp sensor, o2 sensor, new throttle body gasket and did a complete throttle body cleaning, now on start up it starts at 800rpm's, within 4-5mins. it will rise to 1500rpm's and within 4-5 more mins., it will drop back to 1000rpm's. if i drive it will rise back up when i stop. i checked for vacuum leaks best i could, can not find out what the problem is. please help. [email protected] m
Rick

Columbus, OH

#23 Jun 1, 2011
I m havin prob with the idle its too high i just bought 97 wrangler i wsh the moter it was runin ok but after day idle start goin high its up to 1500 now i change the idle air contrl twice but its still same can ne one help with that plz nd thanx...
kenoshadan

Racine, WI

#24 Aug 6, 2011
Jeepgirl3610 wrote:
1999 Jeep Wrangler. We replaced the intake manifold and ever since then it idles real high, like red lines. Vacuum hoses are all good no leaks that we know of. What could be the problem
did you find out problem please help
Mike

Omaha, NE

#25 Sep 22, 2011
I have a '97 Wrangler 4.0 with similar fast idle problems after I removed and replaced the head. After a week at the mechanic he's telling me that it may be the computer which is showing 0 RPM when it's idling at around 2000. He'll swap the computer next week and hopefully that will fix it. My best guess would be that having the battery disconnected for a couple days while I changed out the lifters may have corrupted the programing somehow. There were also leaks at the manifold after re assembly that contributed but fixing that didn't fix the whole problem.
found my fix

Cornelia, GA

#26 Oct 15, 2011
Just replaced the cracked exhaust manifold on my 1999 Wrangler with a new header and had high idle when job was done. Solved the problem by raising the intake manifold slightly in front of vehicle. The rear alignment peg for the gasket goes directly in to the intake manifold but the front peg does not. You must make sure that the front of the intake is in the correct position. I raised the intake slightly and the idle slowed way down. Still slightly high but driveable. I would suggest taking the vehicle to a professional to have exhaust manifold changed. Remember, if you have purchased a used jeep with the 4.0 liter engine there is a good chance the exhaust manifold has already been changed. Was it done correctly ?
rich

Margate, UK

#27 Nov 24, 2011
Hi I have a grand cherokee 2002 2.7crd and when vehicle is warm it idles high at 1200rpm but when put into drive or park it settles.when touching the throttle it picks up again, any ideas would be gratefull.
sam

Lakeville, MN

#28 Jan 25, 2012
Idle problem with 93 buick century. Will occassionally go to very high idle when restarted and gradually slow down. Can IAC on this car be cleaned? 3.3
WAYNE CABALLERO

Riverview, FL

#30 Jun 23, 2012
idle air controll valve
Rob

Morganton, NC

#31 Mar 11, 2013
I have an 2001 Jeep Wrangler with same idle problems it will go from 800 which is close to normal to 2500 -3000! i have put three iac valves on it and two tps sensors! Every time it will run right for a few min then return to same high idle problem. I have started it up and it idle normal then disconnect the iac valve to see if it would still idle high again with it disconnected and it would! It dosent matter if its connected or not i still have the same symptoms.
Jesse

Whittier, CA

#32 Oct 17, 2013
I have a 1999 Jeep Cherokee Classic that had the same problem. Idle would jump to 3500 rpm at start in neutral. I checked everything, vacuum leaks, throttle cable, replaced my IAC, and Throttle Position Sensor. Nothing changed. Finally I got a refurbished ECM off the internet, plugged it in and fixed the problem immediately.

Since: Nov 14

London, KY

#34 Nov 13, 2014
Daysprinbeliever wrote:
I just replaced the head on my 2001 4.0 Sport. we carefully marked all sensors and made sure they were plugged in properly. when I crank it up it starts ramping up like I'm flooring it. I shut it down before it goes to high. scared it might blow the engine. we had an extra throttle assy so we put it on with all the sensors...same thing. we disconnected the trottle cables...same thing... the butterfly is not opening....Help
Check your intake/exhaust manifold gasket for proper alignment, seems to be a common problem in the 4.0 engine. on the manifold/intake, loosen the bolts and if necessary remove the intake.k Retighten the bolts and see what happens before removing manifold
Larry

Zanesville, OH

#35 Sep 7, 2015
don wrote:
i have 88 jeep cherokee idols wide open mash gas an still want go down.cleand throttle air control valve didnt help.cleand throttle intake didnt help still very high idols wide open no lose vacum lines. could you please suggest what it would be
Check your fuses I have d one blown under the hood another blown in fuse box
Ol willy

Toronto, Canada

#36 Sep 14, 2015
4.0 has a good vibration to it. I'm finding that the connector itself is vibrating on the tps to a point it looses connection. I put pressure on connector and instantly fixes idle until I let go. Im going to try dielectric grease and clean pins. If that doesnt work I'll change the connector. Back probing checks fine.
Just thought I would share my opinion...
odinkeep

Temple, TX

#37 Nov 11, 2015
ok, possibly stupid question....
i have a 96 cherokee 4.0 standard and have the general issues involved with an older vehicle, nothing I haven't been able to handle(so far) so we bought our kids a 2001 4.0 cherokee automatic to help them out. For some reason the jeep begins to ramp up the gas after its warmed up,almost like you're mashing the gas.....the boy lost the gas cap,could this be the reason or should I look deeper before I put myself in a HUGE hole going down there.....
Parkerj

Ashburn, VA

#38 Jun 15, 2016
2004 jeep Cherokee. Cleaned throttle body. Replaced Iac and TPS sensors. All vacuum lines are good. Still runs high idle at around 1800. Ideas

Tell me when this thread is updated:

Subscribe Now Add to my Tracker
First Prev
of 2
Next Last

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Jeep Grand Cherokee Discussions

Title Updated Last By Comments
Cam shaft replacements 10 hr Mike 1
left tail light goes out when headlights are on (Mar '11) 20 hr jamie 58
2003 grand cherokee turn signals (Mar '08) Aug 21 MJF 119
jeep wobble in front end (Feb '07) Aug 19 Cin 58
jeep grand cherokee code radio (Apr '07) Aug 19 moengma 121
Rear air bag clunk after a bump Aug 16 OkanaganRod 1
2001 jeep grand cherokee tailgate lock (Oct '11) Aug 15 D mccray 9
More from around the web