Saftety of the "ECO" light on 2007 Ho...

Saftety of the "ECO" light on 2007 Honda Odyssey

Posted in the Honda Odyssey Forum

First Prev
of 3
Next Last
dibesh

Santa Clara, CA

#1 Feb 16, 2007
I am not sure if this is the proper place fo this but I felt the issue that I wanted to birng up warrants further investigation and maybe a possible safety issue. 2 weeks ago I bought a 2007 Honda Odyssey with NAV. One of the feature that sold me to the car is "Cylinder Deactivation System" which shuts of 3 cylinders of the car when you are crusing and a "ECO' light (green) on the dashboard comes on whenver this feature is being used. This is an excellent feature but the problem is that on normal driving the "ECO" light on the dashboard comes on and off quite often and whenever the "ECO" light comes on my attention is diverted from the road to the dashboard as people are conditioned to focus attention to a light that comes on like a warnning signal etc. thus as soon as the "ECO" light comes on my attention is diverted to the dasboard. If this happend once it's no big deal but as an example, on a 5 min drive- the light may come on and go off average of 5-10 times and like I said it becomes a distraction as it leads my attention away from the road to the dashboard. If the light required me to take an action then I understand why the light should come on but the light is an informational light only thus I feel it should not be placed on the dashboard. Thus, I propose have a button to disable this light or have an option to take the car to the dealer to have the light disabled permenantly or to locate this light outside of the dashboard because the light is just so distracting.
Joe

Fall River, MA

#2 May 1, 2007
The first time I drove the car it bothered me but it goes away.
plasmaboy

Fairfax, VA

#3 Sep 7, 2007
I kinda like it. ECO makes driving more challennging and fun. Safety first of course..meaning I won't ECO my way through a busy intersection. Things you could do is like place a sticker/tape on top of it or vary your rpm. It would be nice to have settings to enable/diable it.
John in Carlsbad Ca

United States

#4 Feb 8, 2008
Regarding the ECO system, I drive on I5 quite often and usually when everyone else is there too.
I hope I am wrong, but it seems that when the ECO cycles a lot during slowdown and speedup on up and down grades, the transmission appears to be taking a beating as part of the process. I do feel the occasional up and down shift only in this environment. On my trips on the open highway to far away places, it is great.
P.S. this is the second Odyssey I have owned, It is great. The first one I had a 2001, had the transmission replaced at about 20,000 miles. I hope the ECO is not going to effect this one.
picky7

Sycamore, IL

#5 Feb 8, 2008
I have my first Honda Odyssey in Nov. 2007 and I bought 2007. I have same issue and also an other concern which it is giving me 14 miles a gallon. Is that normal or not. I had a Dodge and it was giving me 19 mile in town and 27 mile on high way. I went to the dealer and he said this car is just fine and you are getting low milage due to cold weather. I told me him that is does not matter because they make car for this market and must know about the weather condition in the state. So how about your average per gallon ?
A Simmons

Hernando, MS

#6 Nov 21, 2008
I have a 2005 Odyssey with the "ECO" system. At a constant speed of 30-40 mph and approx 1500 rpm, intermitantly the van will start to shudder and the rpm will fluxuate slightly.If you increase the rpm it will stop. I think that this is related to the ECO system, but dealer has not been able to find the problem. Shudder is very noticable. Any ideas about a fix?
jmgamble

Rice Lake, WI

#7 Jan 15, 2009
Same problem with a shudder during transition from ECO to no ECO in 2005 Odyssey. Same rpm 1500 to 2100. Seems like a slip in transmission, but computer does not indicate a transmission slip. Have you heard anything from the dealer? Any resolution?
Me2u

Minneapolis, MN

#8 Jan 18, 2009
jmgamble - probably rear engine mount
minneapolis 2

Saint Paul, MN

#9 Feb 2, 2009
Me2u - what do you mean rear engine mount? I just purchased a 2007 for my wife and it appears that the shudder does happen quite often. Also, the car appears to engage the engine during breaking...which causes a noticable shudder as well. Thoughts?
plrbear

Plaistow, NH

#10 May 31, 2009
If the light bothers you so much, just put a piece of black electrical tape over it and move on. Simple Fix!
jack sheaer

United States

#11 Jun 15, 2009
I would like to know if there is any way to make the run in ICO while in park
Michelle

Bohemia, NY

#12 Jul 2, 2009
I have the same problem, although mine goes on non-stop. I am actually bringing my Honda in for service tomorrow because #1 that light goes on Non stop, and honestly everytime it goes on I feel like my car shakes, although it only goes on after I hit a certain speed. So is the ECO light a saftey issue? I have three kids in my car all the time and its starting to make me nervous.
dmrayborn

Meridian, ID

#13 Sep 16, 2009
so what was the outcome of the visit...mine does that too and it's beginning to bother me greatly when driving.....
Michelle wrote:
I have the same problem, although mine goes on non-stop. I am actually bringing my Honda in for service tomorrow because #1 that light goes on Non stop, and honestly everytime it goes on I feel like my car shakes, although it only goes on after I hit a certain speed. So is the ECO light a saftey issue? I have three kids in my car all the time and its starting to make me nervous.
fivewide

Edmonds, WA

#14 Nov 20, 2009
Same problem with ECO light. The van jerks every time the light comes on especially between 60 and 70 mph. Just got it back from the dealer and they said they noticed the problem but their diagnostic equipment didn't register anything wrong. They took the van out 3 times and "felt" the issue but their machines didn't register anything. I mentioned the engine mounts, software updates and torque converter issues but they said everything is fine. Ultimately they said that that is how the van drives.
liner

Bronx, NY

#15 Nov 20, 2009
fivewide wrote:
Same problem with ECO light. The van jerks every time the light comes on especially between 60 and 70 mph. Just got it back from the dealer and they said they noticed the problem but their diagnostic equipment didn't register anything wrong. They took the van out 3 times and "felt" the issue but their machines didn't register anything. I mentioned the engine mounts, software updates and torque converter issues but they said everything is fine. Ultimately they said that that is how the van drives.
In dealer world, if they aren't willing(for whatever reason)or able to find a problem, you get the old "they all do that" routine.
fivewide

Edmonds, WA

#16 Nov 20, 2009
Just got off the phone w/ Honda. They said that if the car is not self-diagnosing a problem i.e. there's a light on indicating somethings wrong, then the techs can't proceed with a diagnoses. All they would be able to do is tear it down and look themselves which would cost a ton of $$$ and they would be going in blind since there's no computer telling them what is wrong.

Very frustrating, the Honda guy actually told me that I will have to wait until it gets worse or a warning light comes on before I can get it diagnosed and fixed.

I chatted w/ on on-line Honda service tech about the problem and he said its definitely the torque converter and that it needs to be replaced.

Since: Nov 09

Andover, MN

#17 Nov 24, 2009
PLEASE HELP.
just bought a used 2005 Honda Odyssey ex-l. it jerks every time the light comes on. Last week, a transmission shop replaced both torque converter and rear engine mount per Honda dealer diagnoses. Repair completed, there is slight improvement. van still jerks as if on a gravel road. Took it back to shop. They aren't sure what else to do. Is the jerking normal and should be expected?
Any suggestions. Please help.
fivewide

Edmonds, WA

#18 Nov 25, 2009
Just got my '05 Odyssey EX-L back from its second visit to he dealer (I've had the car a week). I'm trying to get them to diagnose the problem that MALD5 mentions above. They recognize there is a problem but can't get an official diagnoses. The tech I rode w/ told me that there may be an issue w/ the VCM system and/or the computer. He was very vague I think because he just wanted to get the hell out of there and go home.

I've read that people who have had their torque converters replace needed a full alignment afterwards maybe that is the problem.

Good luck!

Also, if you could tell me how they diagnosed your issue w/ the TC and mounts that would be great. So far the techs I've dealt with have simply ridden in the van and hooked up their diagnostic machines to no avail.
justme

Oroville, CA

#19 Dec 27, 2009
I've had a similar problem on a 2006 accord hybrid, dealers couldnÂ’t find what the problem was, I took it to a local electrician he suggested to replace a computer located behind the front interior light and the front speakers, did that and no problems ever since.
fivewide

Edmonds, WA

#20 Dec 28, 2009
A Simmons wrote:
I have a 2005 Odyssey with the "ECO" system. At a constant speed of 30-40 mph and approx 1500 rpm, intermitantly the van will start to shudder and the rpm will fluxuate slightly.If you increase the rpm it will stop. I think that this is related to the ECO system, but dealer has not been able to find the problem. Shudder is very noticable. Any ideas about a fix?
It's your torque converter and /or engine mounts. Trust me, I just went through this w/ my dealer and after 4 trips they finally solved the problem. do some more research about "juddering" and I think you'll find that in 95% of the cases its the torque converter or engine mounts.

Tell me when this thread is updated:

Subscribe Now Add to my Tracker
First Prev
of 3
Next Last

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Honda Odyssey Discussions

Title Updated Last By Comments
wet seat belt in retractor (Dec '13) Jan 13 Lund 11
2006 Honda Odyssey Leaking Water (Mar '09) Jan 12 Frank 98
even with new battery key fob won't unlock doors Jan 10 liner 2
Heater Blows Cold Jan 10 liner 2
Dash "Brake" Light Flickers (Oct '08) Jan 7 LakeMechanic 5
Odyssey 2005 EX-L, Passenger Sliding Door - No ... (Apr '12) Jan 7 Hahahahaha 33
'03 odyssey radio power problem?? (Jan '07) Jan 5 Tan Le 146
More from around the web