94 Sonoma 4.3L stalling/not starting

94 Sonoma 4.3L stalling/not starting

Posted in the GMC Sonoma Forum

First Prev
of 3
Next Last
JMcClain

Dearborn Heights, MI

#1 Dec 28, 2006
I have a 94 sonoma 4.3l which recently developed a problem in which it sputters and stalls while driving. Sometimes it will shut down for a second or two and then come back and other times I have to pull over and restart. That is how it began, and finally it got to the point where sometimes it wouldn't start at all. I pulled the fuel line to check whether the fuel pump was working, and found that it was intermittent. Some key cycles it would work and others it wouldn't. I replaced the fuel pump, sending unit, and fuel filter. It started up immediately after finishing the work, but died about 5miles later, same thing again. It seems like maybe there is no signal getting to the pump. Any ideas?
denny Michigan

Independence, MO

#2 Jan 1, 2007
Try to clean the egr valve. Has it had a tune up latly plugs, wires, cap, rotor,

Since: Dec 06

Dearborn Heights, MI

#3 Jan 1, 2007
Thanks for the response! I just replaces plugs, wires, cap, rotor, and EGR valve a month ago. I think I'm gonna give up and let a professional try it.
lonoma

Old Hickory, TN

#4 Nov 4, 2007
My 00 Sonoma had that problem but it was the alternator...how is your voltage?
Barclay

Mount Liberty, OH

#5 Nov 6, 2007
I have a 98 Sonoma and i went to start it the other day and i turned the key over and it started and shut off right away like it was dieing for fuel. so after replacing a fuel pump, fuel filter, injectors, On board Computer it still seems to stall out. does aybody have any suggestions on what to do next?
numbermandoeslie

Nassau, Bahamas

#6 Dec 9, 2007
Amazingly it seems like a number of persons are experiencing the same problem I am having. I am hoping that someone has a solution. I have been laidup for a month commuting to work. Please Help!!!
numbermandoeslie

Nassau, Bahamas

#7 Dec 9, 2007
Ionoma, was your alternator voltage too high or too low? I changed my alternator some months ago and noticed that the gage is reading 14volts constantely.
russ

Kensington, Canada

#8 Mar 19, 2008
did u replace ur temperature sensor it controls how much fuel to send to the motor..If it was ur alternator it would not roll over without a boost..could be a knock sensor as well .
numbermandoeslie

Nassau, Bahamas

#9 Apr 10, 2008
Hey guys I'm still working on this problem. After replacing a "sworay" of parts I'M RETRACING MY STEPS.
ON OBSERVATION TODAY I NOTICED THAT AFTER THE ENGINE COMPART HEAT UP THE LITTLE BUGGER STARTED ACTING FUNNY. I PLAYED WITH THE TPS, UNPLUGED IT AND THE TRUCK STARTED TO RUN FINE. I'M GOING TO TRY REPLACING IT TOMORROW.
IF THIS WORKS I'LL BE SURE TO POST MY FINDINGS

IS THIS VEHICLE KNOWN FOR HAVING AN ECM PROBLEM???? SEND ME AN E-MAIL.
98blazer

Janesville, WI

#10 Apr 11, 2008
ya buddies gf's blazer will run fine for a while, but after she gets to work like 50 miles away it wont start sometimes when she is ready to go home later. its happened a couple times. can usually hear the fuel pump kick on, but it doesnt cycle when it is in this nostart condiiton

Since: Oct 09

United States

#11 Oct 26, 2009
I am having the same problem. I have a 1995 GMC sonoma with 4.3l V6 vortec. Auto transmission. I have replaced cap and rotor, pvc valve, spark plugs, fuel filter, and fuel pressure regulator in CMPI system. Engine idles fine, can rev up to 3000 rpm no problem. But when i put the truck in gear and try to drive, the vechile spits and sputters. The engine surges, and from a stop have to rev to 3000 rpm to shift attaining just 30 mph. Any updates or help is great.
Mr right

Williamsburg, KY

#12 Nov 2, 2009
This is an easy one .
Fuel pump !
Eric

United States

#13 Jan 20, 2011
The 94 I have did it and the guy replaced everything you guys all mentioned even the ECM module and sometimes after he would do a major rip down and fix on some sensor or tearing out and replacing the ECM I told him it sounded like the pickup coil in the bottom of the distributor you have to take it out, and disassemble it to get the unit out, it was like 15 dollars at the store. GM HEI would have the same thing happen and it was easier to fix, just 2 screws and a wire. They caught on to us self auto fixers, and made it a whole tear down routine to fix. I hope this helps. Also having this sort of issue does not come up on the computer either, it will code 12 and shut down most likely noticing no pulse reference from the distributor and shutting down the fuel system
Isaac

United States

#14 Mar 8, 2011
Having problem starting my truck it's a 94 GMC SONOMA it just cranks. Thought it's was my fuel pump so I got a new one and a new fuel filter and it still want start. So then I got a new fuel pressurer regulator and still want start just crank. Thinking on buying a ECM computer but not to sure so if any one no please let me no
travis

Medina, OH

#15 Nov 7, 2011
My 1994 sonoma has a problem where it starts drives fine but somtimes when im not movinng or at a stop the engine just stops running then I try to start it it cranks but wont start I normally have too wait a few hours then it starts fine can anyone help
mr right

Columbus, OH

#16 Nov 7, 2011
travis wrote:
My 1994 sonoma has a problem where it starts drives fine but somtimes when im not movinng or at a stop the engine just stops running then I try to start it it cranks but wont start I normally have too wait a few hours then it starts fine can anyone help
Fuel pump !
travis

United States

#17 Nov 12, 2011
I kno you said frul pump but my truck is getting gas up until the exact moment it dies and I found a broken bolt on my distribuutor cap are you still thinkin feul pump
travis

United States

#18 Nov 12, 2011
I watched the gas inject into the rotor it stoped the moment it cut off
travis

United States

#19 Nov 12, 2011
Sorry not the rotor the carb ugh long day
wes

Williamstown, MA

#20 Jan 26, 2012
I had a vortech 4.3 that would be hard starting sometimes but would stall out and and not restart for hours then run well again and be intermittent. I replaced every thing It turned out to be the fuel lines in the intake manifold were cracked. very common. when you remove the upper half of the intake you will see a clean spot where they are leaking. also if the regulator on the cpi is leaking you will see a clean spot at the leak also. Check this first only cost of gasket and immediately apparent if it is the problem

Tell me when this thread is updated:

Subscribe Now Add to my Tracker
First Prev
of 3
Next Last

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

GMC Sonoma Discussions

Title Updated Last By Comments
1992 GMC Sonoma S-10 Dec '17 Oldbonestoo 1
1998 Sonoma Security Light (Apr '07) Oct '17 Heather 19
engine rebuild2.2 Sep '17 markh 1
Rearends Sep '17 Jacobw jack 1
1998 sonoma Aug '17 dEVANS66 1
AC problems Jul '17 Dale ingle 1
engine problems (Jul '17) Jul '17 agg1 1
More from around the web