2001 gmc jimmy won't start
Cale

Dallas, TX

#41 Aug 8, 2010
I have a 1989 gmc Jimmy and it keeps burning the coil and the module up what could this be
Fox

United States

#42 Aug 14, 2010
Look people GMC jimmy's and Blazers have trouble with the with Ignition Switches and fuel pumps from 97 to 05 don't go trowing parts at the trouble when they start acting up save your money The fuel pump can be tested if you get 60 psi just turning the key on and 55 psi running the fuel pump is ok

Now if you are getting no codes at all and it just dies when you are driving or just stalls when you hit the brakes it's your Ignition Switch shorting
out 79 bucks to fix most of the time its the pink
wire shorted out and never lube your keys or lock cylinder on your passlock Gm system with oil !

And people the ground system wires should be cleaned on this SUV's they suck big time
I upgraded my grounds wiring system to a full
Closed loop system and even added some extra ground wires for the coil so it don't short out
To the frame box it sets in
Tina West Virginia

Augusta, WV

#43 Sep 13, 2010
I have a 2000 GMC Jimmy and have read the above comments. My Jimmy has a mind of its own lol, At first about one year age It would keep the key for about ten minutes then release it, or it may not startat first then 20 minutes later start up fine. It has never shut off on me after running, nor do I have a transmission problem. But, I within the last two months I have replaced the battery, alternater, and starter. Now the mechanic says that the fuel pump doesn't hve full pressure. However, when hooked up to a computer reading machine the machine said it lost the computer info even when running. All along during all this trouble the security light on dashboard would come on while rumming or start flashing. What is weird is sometimes before if you would lock and unlock the doors it would start up. Right now I can get it to try and start, and it acts like it is not getting fuel. But instead of buying fuel pumps after fuel pumps could the problem be in the security sensors somewhere?Please HElP!!!!!
Missy

Lake Havasu City, AZ

#44 Oct 13, 2010
calvin from motown wrote:
I also have problems with my 2001 jimmy, first I thought it was my master airflow sensor,than I bought a fuel pump,I was told if you are stiil getting pressure from pump that's not it. I was wondering why there hasent been a recall yet, on jimmy's everyone is having this problem?
There is a recall on the fuel injectors that start to burn out the engine if not fixed.
UPfreebrid

Escanaba, MI

#45 Oct 14, 2010
I have a 2000 Jimmy and a few months ago it just wouldn't start. Turned over just fine until the battery finally ran dead. Tried to fix it myself with no avail. Finally took it to a garage shop.

Turned out to be the distributor. Even with a fuel injection there is a distributor. Well my distributor was making it's own electric storm inside itself. Plus the teeth on the gears was wore down pretty good. Replaced it with a new one, and it's ran great ever since! In fact, it runs better than it ever has since I've owned it.

I've come to the realization that I HAVE GMC JIMMYS!!
D Fischer

United States

#46 Nov 19, 2010
2000 Jimmy, 4.3L engine, 4by4. Just failed to start one day after a short drive. The MIL has been on for some time. I need to check the fuel pump but can't find the jumper point. Battery was bad so replaced that. After the ignition is on I don't hear the pump running. Code reader,(ieScout) says it can't read the codes but says the MIL is off??? Help please.
Randy

United States

#47 Dec 13, 2010
1994 Jimmy starts fine when cold. Engine sputters and dies ounce warmed up. Fails to restart until engine cools down. Then restarts and runs good until warms up again.
justin

Grand Island, NE

#48 Dec 27, 2010
i'm having the same trouble as all these mentioned before. i've changed cap and rotor and spark plugs had pressure done on fuel pump. reads 6o something at start and 55 to 56 at run. wondering if its the temp signal thats in the intake right after the MAF?
cowboymech60

Dayton, OH

#49 Dec 31, 2010
steve wrote:
my 2001 jimmy wont start. My batt. died because i left the lights on so i charged the batt. in the morning i started the jimmy and it started fine so i shut it off, 2hours later i went to start it and it would turn over but not fire, would only fire once but wouldnt run. i cant afford to just startparts anyone figure out this jimmy problem?
I could be wrong but it sounds like you lost the code between the the anti-theft system to the pcm I would have to look it up but normally all you have to do is get a cheap batt charger and turn your ign key on you will see the theft light turn on in approx 10 min it will go off do this sequence 2 more timeas and see if it starts key is if this is the prob the theft light will either stay on or blink
Tamarah

Roanoke, VA

#51 Jan 25, 2011
I was having similar problems and finally noticed that my security light was blinking every time it failed to start (even though it would sound like it was going to). Therefore, I pulled out my user manual and found that if the security is triggered, it will not start for 10 minutes. Now, when it happens I watch the light and sure enough, it stops blinking in exactly 10 minutes and it starts again.

I had a lot of theories as to why this was happening and after much trial and error, I've discovered that this happens when I get in and try to start the car while adjusting the seats and/or steering wheel.(Like someone stealing your car would do). This seems to be the only thing that causes it to happen.

I have a new battery, new fuel injection, new this, and new that...I've spent THOUSANDS of dollars trying to fix a problem that I have found to be security! If anyone knows how to override the security without having to wait for 10 minutes, please let me know!!! But, I also hope this helps someone with a similar problem.
Tamarah

Roanoke, VA

#52 Jan 25, 2011
Tina West Virginia wrote:
I have a 2000 GMC Jimmy and have read the above comments. My Jimmy has a mind of its own lol, At first about one year age It would keep the key for about ten minutes then release it, or it may not startat first then 20 minutes later start up fine. It has never shut off on me after running, nor do I have a transmission problem. But, I within the last two months I have replaced the battery, alternater, and starter. Now the mechanic says that the fuel pump doesn't hve full pressure. However, when hooked up to a computer reading machine the machine said it lost the computer info even when running. All along during all this trouble the security light on dashboard would come on while rumming or start flashing. What is weird is sometimes before if you would lock and unlock the doors it would start up. Right now I can get it to try and start, and it acts like it is not getting fuel. But instead of buying fuel pumps after fuel pumps could the problem be in the security sensors somewhere?Please HElP!!!!!
- My Jimmy does the same thing and it is the security. What I have found that causes it, is if I'm adjusting the seats, steering wheel and sometimes if the door is open when attempting to start the car. What I do now is get in, shut the door, start the car, then adjust whatever I need to. I haven't had the problem sense. Now if I can figure out what to do if it happens again so that I don't have to wait for 10 minutes, I'd be a happy camper!! Hope this helps you.
Fran

United States

#53 Feb 11, 2011
i am having same staring problems with 2000 Jimmy, 4.3. I have had fuel pump relaced 3 times in past 3 years, radiator, heater core, and recently ( with in last 3 months) the convertor, O2's, water pump, intake manifold, plugs, wires.so now what is. love my Jimmy but it doesn't like me. oil preasure gage when driving is reading under 40 and there is a slight ticking
Fran

United States

#54 Feb 11, 2011
and yes it doesn't want to start all the time. Most of the time if I just keep trying it will start BUT NOT last night it took over 2 hours to get her started. Does anyone know for sure why this is happening to our beloved JIMMY'S
Roberto

United States

#55 Feb 12, 2011
99 jimmy, new f pump, filter. has 65 # pressure. runs and drives fine if started with starting fluid. otherwise wont fire up. maybe regulator? I see lots of problems here, no answers, what up?
Michelle

Cleveland, OH

#56 Mar 1, 2011
I have a2001 GMC Jimmy and today I replaced the distrubtor cap for the second time within a year, I'm going to call the dealership and find out what to do about this, shouldn't be like this, anyone else having this problem?
adam

Twining, MI

#57 Apr 4, 2011
adam wrote:
I have a 99 Jimmy 4.3 vortec it wont start again. First it wouldn't start. Changed the mass air flow sensor. It ran great for 2 weeks. Then wouldn't start. Changed the 02 sensors. Ran great 3 weeks then wouldn't start changed the spider injector. Ran great for 3 days now wont start changed plugs wires wires cap roter. Nothing. Has spark has fuel has air. I'm lost. I m leaning towards crank sensor. If it don't work its for sale if you want a cheep suv
what happened????
jerry

Louisville, KY

#58 Apr 20, 2011
i have changed my fuel pump twice it still wont start the pump dont even make a noise its a 2001 gmc jimmy any ideas
gmc guy

Clarksville, TN

#59 May 11, 2011
my 94 gmc 1500 did the same would start after sitting all night... it was the fuel pressure regulator hope it help guys cheap fix
ALex

United States

#60 Jun 7, 2011
were deos the wire from the gauge to the end of the wire go connected.....it dissconected whie drivind i guess and idk were to connect it again..please need some help asap...
wrongway64

Louisville, KY

#61 Jun 8, 2011
a 12 pin connector in rear of vehicle solved all of my problems not fuel pump

Tell me when this thread is updated:

Subscribe Now Add to my Tracker

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

GMC Jimmy Discussions

Title Updated Last By Comments
1997 gmc jimmy electrical problems!!! (Feb '14) Jun 9 Marko386 4
2001 GMC Jimmy problems. (Sep '07) Jun 4 Pete maxwell 121
96 Jimmy revving high but won't accelerate Jun 1 thisizit32 1
2001 Jimmy transmission not shifting (Jul '09) May '16 Ryan 8
2001 jimmy won't start Mar '16 mike 1
News Blazer Electric Rear Hatch Will not Open (Sep '06) Mar '16 nic from winnipeg 62
frustrated with combo switch Jan '16 syule 1
More from around the web