Comments
1 - 20 of 117 Comments Last updated May 22, 2014
First Prev
of 6
Next Last
stormeweather

Lockport, IL

|
Report Abuse
|
Judge it!
|
#1
Feb 16, 2008
 
about 6 months ago my 2001 gmc jimmy 4.3 liter automatic had starting problems, so I foolishly change the fuel pump (after market) and then a month later I change the pump again with a oem pump, the jimmy ran great for the next 4 months then it just would start, I just put the fuel gauge on it and I have 62 lbs of pressure, and if I put a small amount of fuel in the throttle the jimmy starts but only long enough to burn the fuel off then it dies, my code reader doesn't give a code and no check engine light,I have already invested $700 dollors in fuel pumps and will most likly need to have a mechanic look at it so this is my last chance to get it done myself
erik

Glennville, GA

|
Report Abuse
|
Judge it!
|
#2
May 13, 2008
 
have you tried changing the inline fuel filter?
edw

Fort Huachuca, AZ

|
Report Abuse
|
Judge it!
|
#3
Oct 23, 2008
 
I have the same problem with a 99 Jimmy.
It will fire but not stay running. It has new Delphi Pump and new filter. I think its got plenty of pressure and volume to at least stay running.
edw

Fort Huachuca, AZ

|
Report Abuse
|
Judge it!
|
#4
Oct 23, 2008
 
sometimes it will fire up and run fine. no codes are indicated. seems to be a fuel problem.
I need some advice here. thanks.
jamie

Baton Rouge, LA

|
Report Abuse
|
Judge it!
|
#5
Oct 27, 2008
 
try the oil pressure switch....gmc oil pressure switch causes fuel pump to not work
edw

Fort Huachuca, AZ

|
Report Abuse
|
Judge it!
|
#6
Oct 30, 2008
 
i am trying to locate the the fuel pump test wire if any exists. so i can bypass the fact of the oil pressure switch running the pump. if i can find this, and it runs the engine, i can assume its the oil pressure swith. i checked other postings, the librairy, etc. i am looking for clear direction to locate this on a 1999 gmc jimmy 4.3. also is their another relay for the pump other than the one located on the drivers side fender engine compartment in the block? thanks
edw

Fort Huachuca, AZ

|
Report Abuse
|
Judge it!
|
#7
Oct 30, 2008
 
1999 GMC JIMMY 4.3L SFI 4WD 4DR. HAS NEW DELPHI PUMP AND NEW FILTER & THE RELAY UNDER THE HOOD IS FINE. HAS PLENTY OF FUEL PRESSURE, CHECKED AT SHRADER VALVE, AND VOLUME, CHECKED RIGHT AFTER FUEL FILTER, UPON KEY-UP. ENGINE TEMP IS ACCURATE WHEN IT RUNS. ENGINE WILL START FOR A SECOND OR SO, LONG ENOUGH TO BURN THE FUEL THAT IS PRIMED BY PUMP AT KEY-UP. RARELY, ONCE A WEEK? OR SO, THE ENGINE WILL START AND WILL RUN LIKE A CHARM. I WANT TO DETERMINE THE PROBLEM. SO THE PUMP DOES RUN AT KEY UP. MAYBE ITS NOT RUNNING ONCE ENGINE FIRES UP. THE OIL PRESSURE GUAGE DOES MOVE UP WHEN THE ENGINE FIRES. COULD IT STILL BE THE OIL PRESSURE SWITCH? COULD IT BE THE FUEL PRESSURE REGULATOR? FAULTY WIRING? PLENUM WASH? INJECTORS? DOES THIS VEHICLE HAVE A FUEL PUMP TEST WIRE TO BYPASS THESE. IF IT STAYS RUNNING IT SEEMS IT MUST BE ONE OF THESE THINGS. NOT SURE WHAT TO DO....
Adam

Seattle, WA

|
Report Abuse
|
Judge it!
|
#8
Nov 4, 2008
 
stormeweather wrote:
about 6 months ago my 2001 gmc jimmy 4.3 liter automatic had starting problems, so I foolishly change the fuel pump (after market) and then a month later I change the pump again with a oem pump, the jimmy ran great for the next 4 months then it just would start, I just put the fuel gauge on it and I have 62 lbs of pressure, and if I put a small amount of fuel in the throttle the jimmy starts but only long enough to burn the fuel off then it dies, my code reader doesn't give a code and no check engine light,I have already invested $700 dollors in fuel pumps and will most likly need to have a mechanic look at it so this is my last chance to get it done myself
- have figured you out the problem at this point?
edw

Fort Huachuca, AZ

|
Report Abuse
|
Judge it!
|
#9
Nov 5, 2008
 
I HAVE NOT FOUND OUT WHAT HTE PROBLEM IS. IT HAS BEEN STARTING UP LATELY. THE NEXT TIME IT WONT START I AM PULLING IT IN TO THE SHOP FOR DIAGNOSIS.
edw

Fort Huachuca, AZ

|
Report Abuse
|
Judge it!
|
#10
Nov 10, 2008
 

Judged:

2

1

1

the shop replaced the ignition switch lock cylinder and said it was an anti theft problem. sometime grease leaks on some magnets in the pass loack and messes up the magnetic connection. sometimes you can clean the greas rather than replace. i had to replace. i hope they were right. so far so good.
Adrienne

AOL

|
Report Abuse
|
Judge it!
|
#11
Jan 24, 2009
 

Judged:

1

I was reading this forum and it sounds very familiar. Have a 2001 GMC Jimmy too. It started off just giving us trouble to start, but a good 5-10 minutes of cranking, and it would finally turn over, then it ran great, no stalls or anything at idle. The problem is only on the initial start. If you got it to start, ran around to the mall and stores,..no trouble with the subsequent starts, just the intial. Unless you let it sit overnight again and then the next morning, the intial start would be a problem again! Now, it won't turn over at all unless you give it a shot of ether, then once again, once it's being driven around here and there, there's no problem and it runs great. What could be the problem? The mechanic said it's something really simple and stupid but he can't put his finger on it! The fuel pump was just replaced like a little over a year ago. AAA thought it was the temp sensor, that was replaced but it is still doing it? Any ideas?
steve

Chatham, Canada

|
Report Abuse
|
Judge it!
|
#12
Feb 7, 2009
 

Judged:

1

my 2001 jimmy wont start. My batt. died because i left the lights on so i charged the batt. in the morning i started the jimmy and it started fine so i shut it off, 2hours later i went to start it and it would turn over but not fire, would only fire once but wouldnt run. i cant afford to just start replacing parts anyone figure out this jimmy problem?
waihh

College Station, TX

|
Report Abuse
|
Judge it!
|
#13
Jul 30, 2009
 

Judged:

1

have you guys eventually figured out the problem? I have the same problem. My GMC Jimmy 2001 won't start in the morning but start fine in the afternoon. Once it is running, it will start again and again. Overnight the problem appear again. Cranks just no start.

new battery, newly tuned up (plugs, cap, fuel filter, air filter) did not help.

before I go after the fuel pump (expensive!), I would like to know your experience, as I read replacement of the fuel pump did not help for a few others...
cmj

United States

|
Report Abuse
|
Judge it!
|
#14
Aug 13, 2009
 
Adam wrote:
<quoted text>
- have figured you out the problem at this point?
you need new spark plugs, wires and d-cap
Dad

United States

|
Report Abuse
|
Judge it!
|
#15
Sep 29, 2009
 
I have a 1999 Jimmy and it is doing the same thing as Adrienne and waihh. Has trouble starting but then runs fine. I replaced the fuel pump, dist. cap, rotor, plug wires, plugs and removed cleaned and replaced the upper and lower intake. I cleaned the injectors while it was apart. I do get P0440 code which is evap emmissions code. I also have had the IAC code P0507 and took apart and cleaned that also. One time I had TP sensor intermittent. Most of these codes set after trying to start 5 or 6 times. I wouldn't buy another Jimmy if it were the cheapest SUV anywhere. This problem has persisted for quite some time, it has been in the shop alot. I may try the TP sensor and the crank sensor before I junk this thing.
Free-Air

Kermit, WV

|
Report Abuse
|
Judge it!
|
#16
Oct 10, 2009
 
I have a 1994 GMC 3500 with a 454 f.i. It'll crank but not start. I just replaced the cap, rotor, coil and confirmed the module is good. Still I get no spark from the plug wire or the coil wire. I do have 12 volt at the coil. Any suggestions?
jim

Fenton, MO

|
Report Abuse
|
Judge it!
|
#17
Oct 19, 2009
 
I too am having problems getting my 2000 GMC Jimmy to start. thisn just started all of a sudden. The only odd thing to happen was the ABS light came on the day before it would not start. Curious if there is some kind of safety feature that will not allow it to start if the ABS is acting up??
mike

Brooklyn, NY

|
Report Abuse
|
Judge it!
|
#18
Oct 24, 2009
 
i have a 2001 gmc jimmy and i m having trouble getting it started, i replaced the spark plugs, the coil, new feul pump, i gave it the works, ran for a day then the next morning it wont start. whats good, please help im getting tired of it.
Scott

Painesville, OH

|
Report Abuse
|
Judge it!
|
#19
Oct 26, 2009
 
Have any of you figured out what the cause of the Jimmy hard/no start issue is? If so, what is it and what is the corresponding fix? Please help those of us who are still struggling to find a solution.

Thanks.
LThomas

Berthoud, CO

|
Report Abuse
|
Judge it!
|
#20
Nov 17, 2009
 
I have a 2001 gmc sonoma i went thru all the usual starting with the fuel pump ,injectors, pcm, etc,it would only run if you primed with gas then die, a so called mobile mechanic sapossed to be certified gm mech, was guiding me, after i got rid of the real problem ,him. it turned out to be the body control module, i bought one towed it to the dealer they put it on, and man it runs like a new one,I contribute that fact to the new fuel injectors and o2 sensors. by the way the security light was on all the time with the ignition turned on, not running of course, if bcm goes your fuel pump and many other things will not function.(security feature)

Tell me when this thread is updated: (Registration is not required)

Add to my Tracker Send me an email

First Prev
of 6
Next Last
Type in your comments below
Name
(appears on your post)
Comments
Characters left: 4000
Type the numbers you see in the image on the right:

Please note by clicking on "Post Comment" you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Other Recent GMC Jimmy Discussions

Search the GMC Jimmy Forum:
Title Updated Last By Comments
Blazer Electric Rear Hatch Will not Open (Sep '06) Mon Eddie 56
2001 GMC Jimmy problems. (Sep '07) Jul 15 tom in wisconsin 111
2001 Jimmy transmission not shifting (Jul '09) May '14 backyard wrenching 6
2000 jimmy transfer case oil / fluid (Jul '07) Feb '14 wayne 6
1997 gmc jimmy electrical problems!!! Feb '14 scottzzzzzzzzz 2
Fuel problem (Dec '13) Dec '13 Rlaughter4 1
WTO (World Trade Ord) designation / category fo... (Oct '13) Oct '13 dsk 1
•••

Buy a New Car


Zipcode:
•••
Enter and win $5000
•••
•••