Speedometer not working
Dennis

Las Vegas, NV

#21 Apr 12, 2012
Jorge wrote:
Have a 95 taurus wagon speeddometer works but nothing else works whats can be the problem
Start by checking the fuses.
Dennis

Las Vegas, NV

#22 Apr 12, 2012
Start by checking the fuses Jorge.
There's a diagram in your owners manual that describes the locations and functions of each fuse.
Good luck.
Tiffanie

Euless, TX

#23 Apr 30, 2012
I have a 95 Taurus. The speedometer moves, but bounces after 35-40 mph. After about 55 mph it bounces from 55-75. Do I need to replace the whole speedometer or is there just a part I need to buy?
Dennis

Las Vegas, NV

#24 Apr 30, 2012
Tiffanie; Your entire speedometer system is electronic. there is a sensor on the ft. pass side axle that could be dirty or loose, probably not. You probably need to get an "instrument cluster" out of a junk yard. Should be under a $100.
So long as your transmission is properly shifting, the bouncing speedometer is only an annoyance and no harm will come to your vehicle.
Josh

United States

#25 Dec 20, 2012
I have a Saturn l300 2002 an my girl was driving am the Gage's stopped working what would cause that and where would I find the relay cause I looked at my fuses an there all good
jabulani

Europe

#26 Dec 28, 2012
Bruce wrote:
My buddies 1998 had the same problem (speedometer not working). I replace the 5 amp fuse in the main panel under the dash and its fixed the problem.
my speedometer is stuck on 40 km/h
tookie

East Elmhurst, NY

#27 Apr 15, 2013
My 1999 Honda civic speedometer works but reads the wrong speed-could it be the fuse?
tookie

East Elmhurst, NY

#28 Apr 15, 2013
My speedometer is bouncing all over-could it be the fuse?
Speedometer

United States

#29 Aug 5, 2013
I had the same problem with my truck speedometer and so I sent it at chevyspeedo.com and he fixed it in 1 day. When i got it backed works perfectly now and very satisafied!
justin

United States

#30 Dec 27, 2013
I have 01 tarsus the speedo stopped working and gauge lights don't work but idiot lights do checked fuses all good any ideas
Kelly

Little Rock, AR

#31 Apr 16, 2014
I have a 97 Yukon gmc and it is not running right the speed and tack odometer is not working along with it won't tell me the gear I'm in and from a stop I can take off in first gear it takes off in second or third. I changed out the ignition switch and that's not fixed it please help
christina

Virginia Beach, VA

#32 Jun 24, 2014
I have a 99 Taurus and speedometer went out checked all connecters and wires and all good. I just changed vss and still not working. What else could be the issue here?
notelling

United States

#33 Sep 30, 2014
My speedometer sticks when I tab the dashboard then it works could it be the sensor or justva fuse please help me
notelling

United States

#34 Sep 30, 2014
I have a 97 mercury sable gs the speedometer dont work when I tab rhe dash board then it works can u help me please.
notelling

United States

#35 Oct 1, 2014
dan wrote:
ware is the speedsensor
Speedometer sticks sensor or fuse need help 97 mercury sable gs
notelling

Smithfield, NC

#36 Jan 22, 2015
How much does it cost to get8 freezeplugs fixed in goldsboro nc on a97 mercury sable gs
sildogg

Colorado Springs, CO

#37 Mar 2, 2015
I have a 98 Ford Taurus and can't find the fuse for the speedometer I know in manual it's saying look for 24 5a but not seeing it.
notelling
#38 Aug 21, 2015
Can someone help me my speedometer sticks us it the speedsensor plz help?
devinthor

Boise, ID

#39 Aug 25, 2015
Have 1998 Ford Taurus 3.0 V6. At first, after traveling at freeway/highway speeds and coming to a stop, the vehicle would not shift out of first gear. Then after we unplugged and replugged the vehicle speed sensor, after freeway/highway speeds the vehicle would not shift out of high gear, thus losing power steering. Replaced the vehicle speed sensor and the vehicle now shifts down and up as it should. The speedometer and odometer now no longer work. Checked all fuses and all were good. Where do I go from here?
Tachris

Fall Creek, WI

#40 Nov 9, 2015
Rita wrote:
I have a 99 Chrysler LHS and all of a sudden the speedometer quit working and the check engine light came on. Has this happened to anyone else and if so how did you fix it?
I had the same thing happen it was the speed sensor on the transmission 18 dollars and 20 min.work was all it required and its been working fine.

Tell me when this thread is updated:

Subscribe Now Add to my Tracker

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Ford Taurus Discussions

Title Updated Last By Comments
No heat, blowers work, feels like it's stuck wi... (Aug '07) 14 hr Chandexscott 112
Where is/How do you replace PVC valve on 2002 D... (Feb '11) Wed lvengineer 7
1999 Taurus dies while driving (Sep '11) Feb 1 jjj 2
How to disable Factory installed anti-theft (Sep '09) Feb 1 meagan 15
Power Door locks problem (Mar '06) Jan 20 Kwaidman 46
Removing or uninstalling a tentative System Jan 14 Joshua Adam Thomas 1
Unexplained electrical problem with son's 1999 ... (Sep '06) Jan '16 Kellyautomotive 278
More from around the web