Ford Explorer O/D Light, Slipping Tra...
Joe in NC

Raleigh, NC

#263 Sep 19, 2012
Same problem on my 99 Explorer. Flashing O/D Off light. Seems to have gotten worse after pulling a loaded traler about 50 miles. I'm thinking its a sensor problem. Anybody have any new news?
FRANCIN

Los Angeles, CA

#264 Sep 23, 2012
I HAVE THE SAME PROBLEM AND I REFUSE TO PAY FOR SOMETHING THAT OBVIOUSLY IS A RECALL FACTOR. I HAVE A 2002 EXPLORER 4WD AND MY O/D LIGHT BLINKS, MY SERVICE ENGINE LIGHT IS ON, WHEN I TAKE OFF THE TRANNY SLIPS BETWEEN 2ND AND 3RD WHERE I HAVE TO LET GO OF THE ACCELERATOR BECAUSE IT WONT GO ANYWHERE. IT ALSO SHIFTS WITH ALOUD CLUNK FROM PARK TO REVERSE, REVERSE TO DRIVE, AND THE REVERSE,AND SOMETIMES IT GETS STUCK SO I HAVE TO SHIFT WITH FORCE.
Wayne Bailey

Madison, MS

#265 Sep 24, 2012
I have a 2004 Ford Explorer. The rear end started singing at 55,000 miles, just out of warranty. And now my transmission has a hard time shifting into 3rd gear & the OD light is blinking, which I guess means it won't shift into overdrive on the freeway. Which means terribe gas mileage. Ford needs to recall all of these explorers & put in good transmissions for all of us at no charge. I will not buy another ford for sure, unless they own up to the problem.
Danny Dirt

Trenton, NJ

#266 Sep 26, 2012
I have an 03 and it has the same problem everyone is explaining. I have a good trans guy and he told me if someone rebuilds it without re-sleeving it, this will continue to happen. He's doing the work for me. He guaranteed it will never happen again.
lolo

Rio Grande City, TX

#268 Sep 28, 2012
and if someone knows what is the answer to this problem please let us know!!!
gman

Charlottesville, VA

#269 Oct 4, 2012
2001 explorer sport, same blinking o/d light but shifts fine. Changed trans cooler (went bigger) changed filter and fluid. Drove 8 miles o/d light blinking again. Will drive it until it blows. Never have another Ford.
timmyd

Canton, OH

#270 Oct 5, 2012
i have a 98 ford explorer and it shifts just fine with almost 200 thousand miles on it. the only problem is the reverse went out of it about a year ago and i cannot find a shop (even the dealership) that can tell me whats wrong with it. im not wanting to replace the trany. does anyone have any advice on what it could be.
lolo

Rio Grande City, TX

#271 Oct 6, 2012
i have a 98 explorer sport, and the O.D light turns on, i changed the cables, solenoids, turbine, box of valveless, and you use it for 8 miles and the lights turns on, and the shifts become hard, & the RPM goes up, i have no idea on what to do! because it always does the same, even though i erase the code with the computer it works perfectly then 8 minutes later it does the same thing, i have no idea on what to do anymore, if anyone knows what i can do please let me know! i am noticing that a lot of people are having the same problem thank you.
Joe

Rohnert Park, CA

#273 Oct 8, 2012
I love my 1999 Explorer but the transmission has started slipping – I've got 140,000 on it and it slipping mostly between 40 and 50, but now between 20 and 30 as well – not having problems with the O/D light – I am almost relieved to hear that this is a common problem but concerned about what to do about it – it just doesn't make sense for me to put thousands of dollars more work into it – if this is a design flaw I would be happy to join in any action to get Ford to fix it –
Martha

Lansing, MI

#274 Oct 11, 2012
I have a 2004 Explorer. Replaced transmission 2 times now and it just blew again. About every 60,000 miles. Ford will not claim responsibility as they don't want to the expense to repair them all. It is one of the most expensive transmissions around. The first time we had it repaired at a dealer. Got there to have it looked at not knowing what the problem was. Was told that since I was 10 minutes late for my appointment due to construction, I would have to wait until after lunch for them to look at it. 2 hours later got told I needed to leave it. 45 minutes later I got a rental from them. 5 minutes later, I was on the floor of their garage where I slipped on water that was on the floor for some reason. Fell with a computer monitor in my arms that I was taking out to take back home. So after wrenching my back, spraining my arm, and getting a nasty swollen bruise on my arm, I got no help, no apology until days later, and was treated rudely. Won't get service there ever again. So now that I am stranded without a car as the transmission blew up again, no money to repair it, no money for a new car, I email Ford. Their response, we can't help you but we recommend taking it to a dealer and having them look at it and see if they can help you. They can diagnose and fix the problem. WHAT? They obviously didn't understand that I can't afford that, or that after the last time at the dealer, it will be snowing in Hell before I walk in one again. Will never own another Ford. There are other lawsuits on them for other vehicles bad transmissions but no one who will take on one with the explorer. Other than one for the back tailgate crack. What is worse is, my niece works for them in the corporate offices. FORD= Fix Or Repair Daily.
Ricky

Lansdale, PA

#275 Oct 15, 2012
I have 106,000 miles onb my 2001 Ford Explorer. My O/D light has been fglashing. I took it to the dealer and they ran diagnostics on it and said it was incorrect gear 2 and 5, and that it is not shifting out of 1st gear. They want to replace the transmission.
Ricky

Lansdale, PA

#276 Oct 15, 2012
Lets start a facebook thread on this!
BOB

United States

#277 Oct 17, 2012
Had my 02 Explorer Tranny 2ed grar rebuilt at 52,000 miles in 07 at the Dealer. Now 3re gear is slipping and o/d light is flashing at 120,000 miles. Sad example for a family vehicel that is only used to sport the family around town.
shehata

Makkah, Saudi Arabia

#278 Oct 18, 2012
I noticed that my car 03 ford explorer and many cars on the roads have a crack in the back window frames
recently o/d off starts flshing?
Pete

Greenwood, Canada

#279 Oct 19, 2012
An inexpensive fix for most shifting problems can be found by googgling Ford explorer transmission servo repair solution kit and go to Andrew Wanie Web Site.
Pete

Greenwood, Canada

#280 Oct 19, 2012
The bores in the transmission are aluminum and the servo pistons are steel. The bores wear and hydraulic pressure drops failing the servo's. The repair can be done without removing the transmission with the repair kit.
Pete

Greenwood, Canada

#281 Oct 19, 2012
The servo bores wear (steel on aluminium) loosing pressure and causing shifting problems. The most inexpensive fix is to replace the two external servo plstons with the Andrew Wanie pistons with "0" rings installed.
JEGX

United States

#282 Oct 20, 2012
2002 Ford explorer same problem flashing O/D hard shifting,got it worked on 7 months ago,took them 8 days to fix it,said it was a computer problem,wasn't,ended up being some sensor,been doing great untill today,and its started all over again,sheesh
Frantic in Fortville

Greenfield, IN

#283 Oct 20, 2012
Mistake #1 - buying a Ford.
Mistake #2 - buying that Ford from JD Byrider (Tony Stewart you do not know what you are doing promoting them in their ads.)
Same "check transmission" and blinking O/D light. This is the 4th "rebuilt" transmission Byrider supposedly put in this vehicle. I don't believe they ever replaced the first one. Mysteriously, our new struts disappeared one of the times the vehicle was in their shop for "transmission repairs." Are there no trustworthy companies out there anymore? They sure don't mind taking your money for the pieces of junk they sell to you and then won't stand behind their guarantees/warranties! Husband has been in hospital with no income while off from work so there obviously is no money repairs. Wish Ford and Byrider had this vehicle where the sun never shines!
nita

Detroit, MI

#284 Oct 22, 2012
I thought it was just me smdh, mines just went out I have replaced the transmission and its make the worst grinding noise. Not to mention it keep going into over drive by itself & there is NO shut off for the 4x4 ugh =(

Tell me when this thread is updated:

Subscribe Now Add to my Tracker

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Ford Explorer Discussions

Title Updated Last By Comments
01 Ford explorer Sep 14 Calhoun 2
Two suv stickers under side mirror Sep 5 Bclever 1
"O/D off" light blinking on dash? please help ... (Sep '06) Aug 31 kimsber31 397
2004 Explorer Clicking noise as wheels turn... (May '07) Aug 28 fred 45
Ball joint replacement cost (May '06) Aug '16 Jay rock 216
Change a Rear Oil Seal on a Ford Inline 6 4.9L Aug '16 Andybaby 1
Tire sensor default Aug '16 Alex 123 1
More from around the web