"O/D off" light blinking on dash? pl...
hotreblig

Hidalgo, Mexico

#41 Mar 19, 2008
I have had the same problem with O/D blinking, some mecanical shop said the problem was the solenoid boxes inner transmission and change it.
A few days after the same problem start, but now I can not start the engine, so resolving the problem with the starter, found a wiring arnes touching the exaust manifold and some wires was damages.
When those wires was properly repaired and removed away from manifold the problem was solved.
The arnes came from the transmission sensor and it has 3 wires damages.
rnh6719

Greer, SC

#42 Apr 4, 2008
Tosha wrote:
Hello I have a 2002 Ford Explorer and my O/D light is contanley flashing. I took it to the dealership and they told me that it was a possiable transmission problem. The only problem that I have had so far is that today I noticed it jerkey from time to time a little. However from reading everyone elses replys it sound like a electrical problem and that the company may be trying to get over on me.
most likely its the speed sensor located on the rear end top of the diff/housing this sensor on 2002 f150's are for ABS& SPEED SENSOR IT TAKES A 3/8 WRENCH OR SOCKET FIVE FINGERS AND A PLASTIC BRAIN TO CHANGE IT LOL 1 BOLT HOLDS IT IN AND YOU JUST PULL IT STRT/UP HOPE I HELPED
thunder

Ponchatoula, LA

#43 May 3, 2008
I HAVE A 95 FORD EXPLORER WITH 185,000 MILES, FOR ABOUT A YEAR NOW MY OD LIGHT HAS BEEN FLASHING, WHEN THE TRUCK SHIFTS FROM 1ST TO 2ND I HAVE TO LET OFF GAS A LIL TO SHIFT OR RPMs WOULD GO TO RED WITHOUT SHIFTING THEN ITS OK WHEN SHITING TO 3RD I HAVE READ ALOT OF UR ARTICLES, MAYBE JUS A SENSOR ANY IDEALS, CAUSE IF IT WAS IN NEED OF REBUILDING THE TRANSMISSION WOULD HAVE BEEN WENT OUT RIGHT?
female in destress

AOL

#44 Jun 9, 2008
I have a 1994 for mustang and the o/d light keeps having what does that means?
female in destress

AOL

#45 Jun 9, 2008
I have a 1994 ford mustang and the o/d light keeps flashing what does that mean?
Jim

Regina, Canada

#46 Jun 13, 2008
This happened to me today on the way home from work. 1995 F150 w/ 4r70w trans and 302 eng. Travelling highway speed 70-80 mph. The OD Off light started flashing (continuously not like a blink code)it lasted about 30 - 60 seconds. When I pressed the OD button the trans downshifted normally and when pressed again it shifted back to OD, but the light was still flashing. Truck is not 4x4 so its not a transfer case issue. The speedo head has been fuggered for the last 6 years, but trans has worked fine the whole time. This is the first time I've seen this.
mike

Draper, UT

#47 Jun 24, 2008
shanks ford wrote:
I have a 95 explorer and the O/D off light keeps blinking on the dash and the vehicle starts shifting weird. I unplug the battery and it goes away and it starts shifting good again. happened 3 times now without me even toughing the O/D button. I was told there was a sensor in the tranny that was probly bad and I should replace it. What is this sensor? anyone know? Thanks in advance...
this just happened to me the EXACT same thing i was driving and the transmission turned to shit 500 to repair

sorry man
Dan

AOL

#48 Jun 27, 2008
Same thing happened to me and I had to replace the transmission at 82,000 miles. Maybe Ford should help people out with the cost of this since the transmission is suppose to be "no service" until 100,000 miles.
girlygirl

AOL

#49 Jul 1, 2008
Same issue here.....99 Limited Explorer. Torque converter clutch is exactly it. Requires rebuild of entire tranny. If your OD light flashes AND your speedomoditor is inoperative then it's more than likely the wires to the speed sensor or one/both of the speed senors themselves. I was told the speedomoditor won't work if the speed sensor isn't working...makes sense, doesn't it? I was also told to keep an eye on the RPM's if they flucuate abnormally, it's a concern. I have 130,000 miles on mine and was told it usually happens around 150,000 and after longer drives at higher speeds. Good luck everyone!
girlygirl

AOL

#50 Jul 1, 2008
Oh, and I thought this was important to share with you all as well.....if you haven't regularly changed your transmission fluid, certainely DON'T do it now if you are having problems. It will make it much worse. Mine was just checked for discoloration and odor. It was fine and I was advised not to touch it, or I would regret that.
lman

Pewaukee, WI

#51 Aug 13, 2008
hey i have a 94 lexus and my o/d light just poped on what does that mean
Matt

San Antonio, TX

#52 Aug 13, 2008
Had the same problem with my 1997 Cougar. I bought a $20 speed sensor and it took only 10 minutes to install. It did the job. No more flashing OD light!
Rob wrote:
<quoted text>
your problem could likely be a vehicle speed sensor or wiring problem leading to the sensor. make sure insulation on wires leading to the sensor isn't cracked and breaking apart exposing the wires. if not change out vehicle speed sensor, typically less than fifty bucks for the part. if not the problem could be powertrain control module , somewhere around 200 dollars.

Since: Aug 08

Sauk Rapids, MN

#53 Aug 18, 2008
I had a light staying on my ford expoere 2002, what i did was use electronic lube on all the latches, back front everywhere and that did it.
arnettia

Baltimore, MD

#54 Sep 1, 2008
why is my overdrive off light keeps flashing on and off? I flushed my transmission by taking the pan off and cleaning it and changed my filter and it is still blinking. Someone told me at a auto part store that it could be the overdrive sensor. I need to know what it looks like and where do it goes?
Penny

Washington Court House, OH

#55 Nov 7, 2008
My transmission had to be rebuilt and I have a 2002 Ford Explorer. If you google "2002 ford explorer O/D light" - you will see hundreds of people this has happened to - you should report it to NHTSA - I just did. There is something very wrong with this model and year.
Tosha wrote:
Hello I have a 2002 Ford Explorer and my O/D light is contanley flashing. I took it to the dealership and they told me that it was a possiable transmission problem. The only problem that I have had so far is that today I noticed it jerkey from time to time a little. However from reading everyone elses replys it sound like a electrical problem and that the company may be trying to get over on me.
sam

Cincinnati, OH

#56 Nov 11, 2008
My 99 ford explorer did that right before the transmission went out and i had to replace the transmission twice now because of it. what you wanna do is take it to a ford dealership before you go replacing things and have them do a diagnostic test which costed me $50 to get this done they told me that 3rd and 4th gear was about to go out and i would need a new transmission soon. i purchased one for 6 hundred at a junk yard make sure it has a warranty the first one i got had the same problem with it warranty covered for another used one. its worht the money for the diagnostic test i was stranded on a dead road for 3 hours with a baby in the car with me cause the ligth blinked no problem but out of no where it went out and i was stranded in the hot summer on a road without shade with a baby talk about could've ended bad and it was on fathers day not to mention.
grammaginny

Woodland Hills, CA

#57 Dec 8, 2008
MICHELLE wrote:
I have a 95 ford expl. wiht 90,000
the service engine light came on one morning when it was cold
tonight the 0/d light came on. the engine never lost
speed, it started to pull funny when climbing but no
other problems.
can someone help.
I'm broke....
am having same problem w/1995 explorer. any advise yet? i am a broke gramma, myself...thank you
grammaginny

Woodland Hills, CA

#58 Dec 8, 2008
have 1995 ford explorer. o/d light flashing up/down shifting noise in 1st only...am poor gramma any advise? thank you
jamil

Minneapolis, MN

#59 Jan 25, 2009
I am have o/d light blinking on my ford exporer 02 i couldn't figer it out what is wrong with it please help me fix thi problem?
JMG

Hillsborough, NJ

#60 Jan 30, 2009
I also have a 1999 Explorer XLS. Back in 2003 I 'broke' the reverse of the transmission - had it fixed for $1900 and I had the O/D Off light on 3 weeks after that. Shop said it would go away with time - it never did. Now, the SUV will not shift correctly after 30 mph and the O/D Off light starts blinking again. The OBDII does not show any codes related to this malfunction. The transmission was leaking a lot of oil and I found out the bolts fastening the oil pan were loose. After checking furthermore, I found out the 2 nuts supporting the transmission were missing!! I will never take the SUV to that shop again. Right now the Explorer value can be around $2500, so if the fixing cost is $2000, then is not worth keeping the darn thing. I think I will get a Mitsubishi Outlander next.

Tell me when this thread is updated:

Subscribe Now Add to my Tracker

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Ford Explorer Discussions

Title Updated Last By Comments
Ford Explorer O/D Light, Slipping Transmission (Feb '10) Sat Susieq 799
'96 Ford explorer eddie bauer version Feb 11 Mellie 1
02 Explorer Door Ajar light (Jan '08) Feb 10 Jmr 10
2005 ford explore of light stays on Feb 5 Lou 1
Popping noise in the front wheels Jan '17 Ruiz 2
96-v8-5.0L-AWD explorer will not start!! Fuel ... (Mar '08) Jan '17 erok 83
2002 Ford explorer wont start (Jan '10) Jan '17 jodie 59
More from around the web