99 exped electrical problem when it r...
Robert Carter

Roosevelt, UT

#42 Dec 18, 2012
Same issues, didn't know it was related to wet until now
mike

Edinburgh, IN

#43 Apr 12, 2013
2001 excusion same problems. It tried to start while already running. I didn't want to destroy my starter or flywheel but needed to drive the truck. I started it up and very quickly unplugged the small signal wire on the solenoid. Not a permanent fix but it works in a pinch. Water is most definetely the culprit and Ford is the problem. What a disgrace they are for not fixing this problem. Never again will I own anything with a blue oval on it.
Jason

Columbus, OH

#44 May 5, 2013
Adam wrote:
After it rains for an hour or two on my 92 Expedition XLT I have the same problems until it dries up. The windows don't work, interior lights don't work, and the wipers stop working. I hear a clicking noise up around the fuse box. One minute everything might be fine and the next it all stops working again. This ALWAYS happens after a good rain, and again I have no problems after a day or so of drying weather. I've check wires, switches, relays, fuses, can't find anything defective, nor can I find water that leaked in. Think I'm going to get my windshield removed and re-installed like some of you have also tried. Wish me luck!


If you have a moon roof make sure the drain tubes are clear and flowing.
Joe Stacey

Cincinnati, OH

#45 Jul 2, 2013
So glad I found this here. Iv read a lot of forums, but no answers only the same problem after problem. Mine just started doing this last night, going to replace the windshield ASAP in hopes of a solution. Thanks everyone who gave a solution to this!
rozy

Houston, TX

#46 Sep 18, 2013
Im having trouble with my 1998 expedition it rained hard last night and today as I was driving around it started to stall as I was driving..I was pushing the gas but it would take awhile and it feels heavy as im driving also my battery keeps on dying out I have to un plug it every day and my radio stays on as well to my wipers freeze up once in a while and da drivers window wont go down.....HELP!! Can it be my transmision as to it stalling????,,,
Vella Alvarez

Saint Louis, MO

#47 Sep 22, 2013
Bill wrote:
I have the same problem with my 2001 Expedition.<quoted text>
I have a 1999 Ford Expedition Eddie Bauer edition I have electrical problems with the radio and my windshield wiper in the back won't work
Vella Alvarez

Saint Louis, MO

#48 Sep 22, 2013
What can possibly be wrong I've tried to fuse is none of the fuses are out5852
vella Alvarez

Saint Louis, MO

#49 Sep 22, 2013
I'm having trouble with my 1999 Ford Expedition Eddie Bauer edition with the electrical the stereo won't come on the back windshield wipers won't work ive checked the fuses and nothings wrong with them can somebody help me out
Hikingkate

Ellensburg, WA

#51 Oct 3, 2013
We have the same problem - our 2000 Expedition keeps trying to start itself, dash lights flash on and off with a clicking noise, radio seems possessed, and only one headlight works at a time, among other weird things. We also nicknamed it "Christine." After spending thousands fixing other issues over the past several months, I cannot afford to fix the PCM. Our local FORD dealership told us it would cost a minimum of $200 to diagnose it and a minimum of $1000 to fix it. At this point, I am thinking of filing a class action lawsuit to get FORD to fix this problem because it is certainly a defect and they are not willing to fix their problems. Anybody else on board?
pfafzf

Chalfont, PA

#53 Dec 30, 2013
Try flex seal from tv ad and spray along front windshield
pfafzf

Chalfont, PA

#54 Dec 30, 2013
I tried a can of flex seal( clear) spray from the as seen on tv ad and sprayed around my front window sill and around my wire harness to seal around it and never had a problem since
pfafzf

Chalfont, PA

#55 Dec 30, 2013
Joe Stacey wrote:
So glad I found this here. Iv read a lot of forums, but no answers only the same problem after problem. Mine just started doing this last night, going to replace the windshield ASAP in hopes of a solution. Thanks everyone who gave a solution to this!
I tried a can of flex seal( clear) spray from the as seen on tv ad and sprayed around my front window sill and around my wire harness to seal around it and never had a problem since
Benjamin

Charleston, WV

#56 Jan 26, 2014
Fellas !!! This is so crazy . I had the same problem ,and now the truck is dead. Thanks to stupid ford engineering .. Get rid of your ford vehicles
Johnnie

Milwaukee, WI

#57 Feb 20, 2014
I have 2000 EB, with the same problems. Radio blinks in and out, heat turns on when truck is off, wipers stop working. I haven't had it looked at yet but I see it is a quick fix. Ford should definitely do a recall on the windshield.
thomas

Essex Junction, VT

#58 Feb 22, 2014
it s not only the exp. its all ford trucks I have 98 f150 and 99 f 250 ford trucks with the same problem and like most im a die hard ford fan but going to start rethinking ford products
thomas

Essex Junction, VT

#59 Feb 22, 2014
if anyone does desides to do a class action let me know I ll be onboard
Matthew I

Brinkhaven, OH

#60 Feb 22, 2014
I am having the same problems with my 99 exp I'm going to take the computer out let it dry and seal the bottem of the windshield I can't believe these trucks do this it's bad I've never had a ford and now I know why never again will I buy ford products again
naaman

Clarksville, OH

#61 Mar 4, 2014
my door locks keep going on and off and my vehicle is trying to start by itself...
ANN LOCKE

Owensboro, KY

#63 Mar 10, 2014
Iput new windshield in didn't fixit i have a '99 expedition
IT IS FIX NOW
there was a hole in the metal by the fuse box $5.00 repair $70 labor
!!!!!!!!IT IS FIXED!!!!!!
Ken

Columbus, OH

#64 Mar 11, 2014
April wrote:
We seem to be having the exact same problem. It was minor at first, but when it rains the truck tries to start by itself. Mine is a 2000 Expedition Eddie Bauer. This has been going on for a while so now we know to disconnect the batter if a storm is coming. I have noticed that the longer this problem goes on it gets worse. If you are driving it and it gets wet, even though it is cranked it will still try to turn over and make a terrible noise. I've searched this issue a lot through the internet and it seems that a lot of people are having this problem and Ford is doing nothing about it. They investigated it but closed the case and declared NO RECALL. Obviously there is a defect if so many people are having this problem. If you find out a solution I would appreciate it if you would let me know, and I will do the same!!
I have a 2000 expedition and am having problems with the electrical,it has been leaking water thru the lower part of the windshield and into the electrical componets.It won't start now or engage the starter.It started a few weeks ago and after running for a few minutes it tried to engage the starter over and over along with the dash lights going on and off.It has to be a short in the wiring under the dash on the drivers side.Ford's better Idea isn't so bright when it cam to designing these vehicles and they don't stand behind anything.My son's F-150 is also having an issue with the blend door freezing the driver even if the heat is on it is air on the drivers side,another of fords bright ideas with no resolve from ford

Tell me when this thread is updated:

Subscribe Now Add to my Tracker

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Ford Expedition Discussions

Title Updated Last By Comments
2002 Ford Expedition turns over but won't start (Aug '08) Mon Jnmsandoval 46
1999 Exp XLT 5.4L 2WD Oil Pump Failing? (Jul '08) Sun Keishae 13
1999 Ford Expedition - Car Troubles (Sep '07) Feb 18 scorn3767 168
2001 expedition fuse problem (Nov '09) Feb 11 Noah 31
Change out fuel pump Feb 4 Tracy MIXON 2
2000 Ford Expedition Feb 1 Megan 3
2010 Expedition headrest (Feb '10) Jan 31 DEANNA 34
More from around the web