Front ac vents in a 2003 Ford Expedition

Front ac vents in a 2003 Ford Expedition

Posted in the Ford Expedition Forum

sbmay

Tucker, GA

#1 May 14, 2014
When I start the truck the front vents blow cold air, when the truck reaches running temp and I start to drive it blows extremely hot air, feels like it is coming straight from the motor. Go faster, hot air comes in faster, go slower is comes in slower. But it is constant with or without the ac on. I drove 4 hours today and ended up with burns on my foot because of the floor vents. The rear ac works great all the time, but the front has to be on for the back to be on. So I suffer to keep the kids comfortable. Any ideas on what the problem might be? And how do I fix it? I have am 8 hour drive in 2 days with an already burned foot.

Tell me when this thread is updated:

Subscribe Now Add to my Tracker

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Ford Expedition Discussions

Title Updated Last By Comments
2003 Ford Expedition electrical problems (Feb '09) Apr 15 Swany 37
98 expedition door lock issue Apr 14 William 1
2001 ford expedition electrical problems (Sep '07) Apr 6 Harris 45 89
child safety lock rear passenger side (Jan '07) Mar 26 buhhhhhford 81
1998 ford expedition troubleshooting question-h... (Nov '06) Mar '18 Ronniejbaldwin 1,037
2003 Expedition will not start (Sep '09) Mar '18 CldLk-Tim 17
2007 ford expedition wont start (Feb '09) Mar '18 CldLk-Tim 4