High speed chatter under load

Posted in the Ford Expedition Forum

John

Fredericksburg, VA

#1 Jul 7, 2013
This noise happens when I'm going over 60 and under load, like going up a hill. This chatter/tapping noise can be made worse when I press on the gas pedal, I can play with it, give it gas - louder, let up on it - it stops. If I push hard on the gas pedal the noise gets louder and then clunks and is gone til next hill. No issues under 60 mph
John

Fredericksburg, VA

#2 Jul 7, 2013
Its a 2003 Eddie Bauer 5.4V8 178,000
josh

Kingston, TN

#3 Nov 23, 2013
@ John I would say it is probley this cheap gas we are getting these day and you may want to see about getting the valves adjusted. Milage is a big thing it could even be the timing chain and gears having slack in them. good luck

Tell me when this thread is updated:

Subscribe Now Add to my Tracker

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Ford Expedition Discussions

Title Updated Last By Comments
2001 Expedition - Blower fan continues to run (Feb '07) 3 hr Theddy 33
99 Expedition 4x4 Issues (Nov '06) 8 hr WAYCOOL 107
2002 Ford Expedition turns over but won't start (Aug '08) Fri apaz220 21
2003 Ford Expedition Questions (Apr '07) Dec 26 noe hernandex 14
1999 Ford Expedition - Car Troubles (Sep '07) Dec 23 vab 143
99 exped electrical problem when it rains (Jul '07) Dec 22 Jonathan A 68
2001 ford expedition electrical problems (Sep '07) Dec 22 Justmy2cents 77
More from around the web