High speed chatter under load

High speed chatter under load

Posted in the Ford Expedition Forum

John

Spotsylvania, VA

#1 Jul 7, 2013
This noise happens when I'm going over 60 and under load, like going up a hill. This chatter/tapping noise can be made worse when I press on the gas pedal, I can play with it, give it gas - louder, let up on it - it stops. If I push hard on the gas pedal the noise gets louder and then clunks and is gone til next hill. No issues under 60 mph
John

Spotsylvania, VA

#2 Jul 7, 2013
Its a 2003 Eddie Bauer 5.4V8 178,000
josh

Kingston, TN

#3 Nov 23, 2013
@ John I would say it is probley this cheap gas we are getting these day and you may want to see about getting the valves adjusted. Milage is a big thing it could even be the timing chain and gears having slack in them. good luck

Tell me when this thread is updated:

Subscribe Now Add to my Tracker

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Ford Expedition Discussions

Title Updated Last By Comments
1999 Ford Expedition - Car Troubles (Sep '07) Sun Miguelblanco23 164
1998 ford expedition troubleshooting question-h... (Nov '06) Aug 25 lost_brett 1,023
can anyone explain why Ford put LED fog lights ... Aug 10 genefkohler1 1
1997 Ford Expedition Disaster Aug 10 Tuko74 1
2003 Ford Expedition electrical problems (Feb '09) Aug 9 JoePowellSr 30
Noise in the rear of 08 Expedition Aug 4 bcrain 1
99 exped electrical problem when it rains (Jul '07) Jul 30 Andy G 83
More from around the web