2004 Ford Expedition runs rough at idle

Posted in the Ford Expedition Forum

Mike from Buffalo

Buffalo, NY

#1 Jan 15, 2010
I have a 2004 ford expedition 4.6l that was running rough at idle (truck would shake) and poor acceleration. At first there was no fault light. I googled the problem on the internet and found several potential causes and their solutions, until I eventually found the one that fixed it. I'm writing simply to share my experience in hopes it helps some other poor !@#$# and saves them some money.

Steps.
1. No fault light... changed Air cleaner ($20 cheap)
2.(two days later) Fault light... took it to Autozone to have codes read they said it was running lean and could be a number of things. Had them reset light. Cleaned MAF sensor, checked for vacuum leaks, changed fuel filter.($69.00 cheap , bought MAF sensor cleaner but had ford dealer change filter, I couldn't find it and there is 3 ft of snow out there)
3.(1 week later) Light returned had Autozone read codes again, this time the error was more specific, it stated the #4 cylinder was misfiring. Changed coil and spark plug on the #4 cylinder (will change the reset in the Spring).($62.00 for parts... changed myself) This fixed the problem and truck is running perfect again.
Bob

Fort Lauderdale, FL

#2 Feb 12, 2012
Thanks, Mike that is a lot of help. I actually changed the fuel filter and it helped for about 2-3 weeks then it started to stall at idle again, I figured I figured I would change the air filter to make sure it was getting plenty of air. I see you changed coil and plug for #4 cylindar.I will also check with autozone and have them read the codes as i too have the fault light on.
Thanks agin this should be a lot of help.
Bob
Ryan

Wasilla, AK

#3 Jun 30, 2012
Thanks. I just got done swapping a motor for a friend and I'm having this issue with the new motor. Good news is I didn't replace the plugs or coils but he did supply new ones with the motor.
Thanks again!
Tom

Alpharetta, GA

#4 Apr 25, 2013
Maybe the Ford tecnicians should get online a read the different comments rather than their Ford manuals.

Tell me when this thread is updated:

Subscribe Now Add to my Tracker

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Ford Expedition Discussions

Title Updated Last By Comments
child safety lock rear passenger side (Jan '07) 13 hr Jay Plank 59
2003 Ford Expedition electrical problems (Feb '09) Jan 27 Garry123 20
97 Expedition park not engaging (Mar '08) Jan 23 hatch 28
1999 Ford Expedition - Car Troubles (Sep '07) Jan 14 mel 145
2002 Ford Expedition turns over but won't start (Aug '08) Jan 10 tskinner21 23
2000 Ford e350 Super Duty passenger van Jan 10 Keith 1
1998 ford expedition troubleshooting question-h... (Nov '06) Jan 9 Slim 976
More from around the web