Comments
1 - 20 of 75 Comments Last updated Wednesday Aug 6
First Prev
of 4
Next Last
sean

Cumming, GA

#1 Sep 18, 2007
my cd player wont turn on and my power windows wont go down!! any idea's why? could it be a burnt wire or blown fuse? if so how do i go about getting this problem fixed?

hercountryboy07@yahoo.com this is my email and suggestions welcome
Tim

Durham, Canada

#2 Sep 29, 2007
You will need to get a wiring schematic and see if there are any shared circuits between p/w and the cd player. If not you may have two problems. The schematics will also identify ALL the fused used for both. They may also share a connector, which may have corroded. I have the FORD Service Manual for this year, if you like email me and I will see if I can copy the schematic and email it back to you.
velvetjo@hotmail.com
dave

Santa Clara, CA

#3 Nov 18, 2007
I have a similar problem. I have a 2001 EB Expedition that came with a VCR next to the CD player and an overhead LCD screen behind the sunroof. I have lost power to both the VCR and overhead LCD. No other electrical problems noted. First, I can't find the fuse that drives these. Second, I believe there must be a common connector that went bad. Any ideas on where to look, how to get at it and where I would find a replacement?
Dledwards

La Vergne, TN

#4 Aug 17, 2008
The battery light stays on on my 1998 Ford Expedition. What generally casuses this?
JOHN

Elko, NV

#5 Jan 8, 2009
could be the altanor check with a multimeter and if the systeam charging then trace wire check coneters so on can suck find the proble
JOHN

Elko, NV

#6 Jan 8, 2009
hi dave I used to live on bernal in livermore I have an 01 expo eb that had the factory cd changer,sub,VCR,overhead 6in audiovox i think all that stuff was a dealer add on at a dealership not directley from ford.I ve changed out a ton of factory audio stuff and the custom lcd scren is next. IF you buy the right stuff ill help next time im in livermore email me nonwoven1@yahoo.com
Tim

Augusta, GA

#7 Jan 31, 2009
2001 Expedition XLT: My radio only picks up (1) station and all other stations are static completely. This started about a year ago. I figured it had something to do with the antenna so I went to the local Ford dealer to attempt to replace the antenna; it's $700 just for the part, not including the labor, needless to say we've been listening to the same station ever since, any ideas?
Perry

Warrenville, IL

#8 Jul 13, 2009
I have a 2001 EB Ford Expedition, that just recently start having electrical problems. Automatic light not working, interior sunvisor light not working, interior passenger light not working behind driver seat, 3rd row light not working but all lights come on when I open door, and now battery light comes on and stays on when I accelerate/driving, but car has not lost in power while accelerating or driving. What could be the problem?
Adrian

Spartanburg, SC

#9 Aug 18, 2009
Can't get c.d. tray out of the 6-disc c.d. changer in a 1997 Expedition. Any help?
Chris

Orlando, FL

#10 Nov 13, 2009
I have a 2001 ford expedition and my cd player works when it want to, my windows want let down,the lights on the inside want come on, and now i have to turn the truck on half way put it in N the turn it on the put in drive before i can drive it. what is the problem please help.
jmobley947

AOL

#11 Dec 16, 2009
dave wrote:
I have a similar problem. I have a 2001 EB Expedition that came with a VCR next to the CD player and an overhead LCD screen behind the sunroof. I have lost power to both the VCR and overhead LCD. No other electrical problems noted. First, I can't find the fuse that drives these. Second, I believe there must be a common connector that went bad. Any ideas on where to look, how to get at it and where I would find a replacement?
It is fuse #8 in the dash fuse panel. We worked on one with an open voltage supply between the fuse and ignition switch. The VCR is dead shorted. The harness to the LCD screen is paralleled to the VCR. Ford indicates there could be a 4 amp inline fuse to the units but ours doesn't have that....Jim
jmobley947

AOL

#12 Dec 16, 2009
It is fuse #8 in the dash fuse panel. We worked on one with an open voltage supply between the fuse and ignition switch.(No voltage to the fuse.) The VCR is dead shorted. The harness to the LCD screen is paralleled to the VCR. Ford indicates there could also be a 4 amp inline fuse to the units but ours doesn't have that....Jim
Russell

Conroe, TX

#13 Dec 29, 2009
I have a 2001 Expedition Eddie Bauer , when we open the door with the key less entry / remote the defroster comes on. The car also drags when you start it. This happens 3 out of 4 times, and you can't turn off the defroster unless you put the key in and turn on the ignition. I recently changed out the battery terminals due to corrosion and that seem to fix the low battery issue until now.
Tiffany

Duluth, GA

#14 Jan 25, 2010
I have a 2001 Ford XLT. The radio comes on as it pleases. I noticed that it is also affecting the window shield wipers. The SUV also seems to be trying to restart itself although it is already started. The dealership could not find anything wrong. The starter, cylinder, and alternator are all fine. I'm thinking its something electrical. Any suggestions?
Todd

Valhalla, NY

#15 Feb 23, 2010
I have a 2001 Expedition, with a horn that won't sound when the key is turned on. Without the key the horn works. Panic button also sets the horn off. Any ideas?
RANGER V8

Statesboro, GA

#16 Mar 11, 2010
why does the windows not work in my 2001 expedition
RANGER V8

Statesboro, GA

#17 Mar 11, 2010
why does the windows not work in my 2001 expedition ? i have checked all fuses and changed the master window switch
Scott

Peoria, AZ

#18 Mar 24, 2010
dave wrote:
I have a similar problem. I have a 2001 EB Expedition that came with a VCR next to the CD player and an overhead LCD screen behind the sunroof. I have lost power to both the VCR and overhead LCD. No other electrical problems noted. First, I can't find the fuse that drives these. Second, I believe there must be a common connector that went bad. Any ideas on where to look, how to get at it and where I would find a replacement?
Have you found a fix for this problem yet? I have the same problem and I checked fuse 8 but that wasn't the problem.
Scott

Peoria, AZ

#19 Mar 24, 2010
Scott wrote:
<quoted text> Have you found a fix for this problem yet? I have the same problem and I checked fuse 8 but that wasn't the problem.
I found the problem. It is an inline fuse located under the center console. It is directly under where the control for the rear climate control is. Remove cover, only two screws and you will see it. Mine had a 4 amp fuse. I went to checkers and they only had 3 and 5. I got the 5 amp and put it in and it works again. It you need more info let me know.
Scott

Peoria, AZ

#20 Mar 24, 2010
Scott wrote:
<quoted text> Have you found a fix for this problem yet? I have the same problem and I checked fuse 8 but that wasn't the problem.
Both the vcr and lcd monitor are working now.

Tell me when this thread is updated: (Registration is not required)

Add to my Tracker Send me an email

First Prev
of 4
Next Last

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Ford Expedition Discussions

Title Updated Last By Comments
Trailer wiring problem on 2007 Expedition Aug 27 Pete from FLA 1
Expedition won't shift out of park Aug 26 Djordan 1
2015 Popularity of Ford Crossover-utility Vehic... Aug 26 mamamoe 1
1999 Ford Expedition - Car Troubles (Sep '07) Aug 23 candy girl 141
99 Expedition 4x4 Issues (Nov '06) Aug 22 Dean 103
2001 ford expedition what and where can I find ... Aug 21 Cal 1
1998 ford expedition troubleshooting question-h... (Nov '06) Aug 20 Carm 961

Buy a New Car


Zipcode:
•••
Enter and win $5000
•••

Ford Expedition People Search

Addresses and phone numbers for FREE

•••