Tackforce

Memphis, TN

#1 Dec 31, 2006
I have a 03' exp. and the Door ajar light stay on and I cant lock my doors nor have the light to go out in the vehicle.
DAVID SCHUERMANN

AOL

#2 Jan 2, 2007
i HAVE AN ELECTRICAL ISSUE WITH MY 1998 EXPEDITION...
1.0 The door ajar light is on and the doors wont lock, only after driving a while does it turn off and the doors lock. Sometimes it is fine, other times it is real bad.
2.0 The windshield wiper in the rear operates intermittantly, seems to work only when the vehicle is in Park.
3.0 The speedometer works and then don't work.
4.0 The right turn signal works intermittantly.
5.0 The power windos also work intermittantly.

I have spent over 1000 on repairs, the check engine light was on, removed the intake and replaced sensors, replaced the module that controls the air bags and the dealer says everything else was OK. On the way home the speedometer stopped and tonight the door ajar and windows and rear wiper all messed up. I need a schematic for the electrical system...any help out there...I have had it with the dealer finding no faults and so many things are messing up.
Norm

Ajax, Canada

#3 Jan 18, 2007
Tackforce wrote:
I have a 03' exp. and the Door ajar light stay on and I cant lock my doors nor have the light to go out in the vehicle.
Had the same problem it's the sensor in the door. Just spray some lub like wd40 in the door latch that should clear up the problem.
Vince

Kissimmee, FL

#4 Mar 21, 2007
usually when mine dose that it's the rear glass by accedent i hit it on the key pad
Greg

Denver, CO

#5 Mar 28, 2007
I had the door ajar issue on my 2000 as well. Sprayed WD40 in the latches and the sensor works properly now.
Butch

United States

#6 Apr 23, 2007
Norm wrote:
<quoted text>
Had the same problem it's the sensor in the door. Just spray some lub like wd40 in the door latch that should clear up the problem.
Thanks guys, I was having same problem and you solved it for me, If I would have taken it to the dealership, they would have screwed me.
Dan Chicago Illinois

Chicago, IL

#7 Apr 25, 2007
I have a 2003 Ford Expedition bought new with 153,000 miles on it. I have Door Ajar light on for last year. I just sprayed WD40 on latches. It is still on. Also, Airbag light flashes on and off sometimes. And, if I turn rear wiper on it drains the battery after expo is turned off. Although, these are minor problems, I do not want to take to dealer as it will be a rip off. In the last 2 years, I already spent $2100 with dealer relplacing coils for engine misfiring. Any advice ?
Dan Chicago Illinois

Chicago, IL

#8 Apr 25, 2007
I forgot to add, the drivers heated seat does not come on but the passengers does. Also, my head lights will not go out automatically. I have to do it manually.
Robert

Burbank, CA

#9 Jan 5, 2008
ONE More WD-40 success story!!!!! No more Door Ajar!!
I also understand that when the battery cables get dirty all sorts of stuff goes haywire with the expeditions'--I heard that Land Rover and Ford have some associations---did the English design the wiring on the expedition???!!!
I have had (and paid for) a lot of these issues pointed out below--I'm buying a Nissan Titan--hopefully the dealer will give me a couple thousand for this POS, before anything else goes wrong---BTW the transmissions fail at 130,000 miles like clockwork--dump it before then!!!!
Tackforce wrote:
I have a 03' exp. and the Door ajar light stay on and I cant lock my doors nor have the light to go out in the vehicle.
Jacob T

United States

#10 May 27, 2008
Sorry to say, I cannot get the WD40 trick to work! The darn light stays on no matter what I do. ARGH!
Kenny E

Southaven, MS

#11 Aug 14, 2008
WD 40 not working for me either!
vinnie

Levittown, NY

#12 Dec 1, 2008
I been having the same problem did you ever find out what was wrong?
DAVID SCHUERMANN wrote:
i HAVE AN ELECTRICAL ISSUE WITH MY 1998 EXPEDITION...
1.0 The door ajar light is on and the doors wont lock, only after driving a while does it turn off and the doors lock. Sometimes it is fine, other times it is real bad.
2.0 The windshield wiper in the rear operates intermittantly, seems to work only when the vehicle is in Park.
3.0 The speedometer works and then don't work.
4.0 The right turn signal works intermittantly.
5.0 The power windos also work intermittantly.
I have spent over 1000 on repairs, the check engine light was on, removed the intake and replaced sensors, replaced the module that controls the air bags and the dealer says everything else was OK. On the way home the speedometer stopped and tonight the door ajar and windows and rear wiper all messed up. I need a schematic for the electrical system...any help out there...I have had it with the dealer finding no faults and so many things are messing up.
kitty

Novi, MI

#13 Oct 13, 2011
First the heated seats stopped, no biggie. Now the door ajar is permanently on, doors are SO closed,dome light won't go off. Tried WD40, doesn't work. Drains battery and have to jump, finally had to put quick disconnect on negative cable. Help me!!!
AL Smith

AOL

#14 Apr 16, 2012
When I open the doors on my 2000 Expedition the interior light won't come on and the truck won't start, but once I turn the interior lights on manually the truck starts. All this happened after my keyless factory remote wouldn't unlock/lock the doors. The windows won't come down unless I have the interior light on(manually)..
Eric

Oak Ridge, NC

#15 Feb 23, 2013
My ford expedition 98 model jerk at the speed of 15 to 60 what do i need to do
wanda

Elnora, IN

#16 Mar 18, 2013
Go to the local parts store and have them run a code check on it ( free @ autozone) ours was doing the same thing and it was not firing # 2 cylinder , changed coil pack . Runs smooth now
roberto

Brentwood, NY

#17 May 22, 2014
my 2000 ford expedition door and ajia door stay on
roberto

Brentwood, NY

#18 May 22, 2014
my car 2000 ford expedition door light stay on always

Tell me when this thread is updated:

Subscribe Now Add to my Tracker

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Ford Expedition Discussions

Title Updated Last By Comments
1998 ford expedition troubleshooting question-h... (Nov '06) Thu 3030glc 974
99 exped electrical problem when it rains (Jul '07) Dec 16 Ford Sucks 67
1997 Ford Expedition transmission problem (Mar '08) Dec 9 Roman 61
electronic on a ford expedition Dec 7 Jeff 1
2001 Expy XLT 5.4 running rough, idling (Jun '08) Dec 6 arnel 10
2001 electrical problem Dec 4 Tom 4
2001 expedition fuse problem (Nov '09) Dec 3 KathyO 25
More from around the web