First Prev
of 8
Next Last
candy girl

Hollywood, FL

#144 Aug 23, 2014
I have a 99Ford expedition and when I was talking my son to school it cut off. People say it's the battary I replaced it n nothing they say it was the starter I took it out n took it to auto zone n they checked it and it was good, my truck still want start It makes a noise like it's going to start and die at the same time why?
Please help
CupCake26

Twin Lakes, WI

#145 Nov 19, 2014
SMTKLLSMTH wrote:
MY 99 XLT DONT START ON EVERY TURN, SOUND LIKE THE STARTER BUT WHEN THIS HAPPENS THE GAUGES GO CRAZY, I HAVE TO RESET MY RADIO IS IF THE BATTERY IS BAD.(CHECKED BATTERY TODAY ITS OK)
We have a 1998 and it dont want to start and we have the same problem and we put a new battery in it and it still will not start IDK what is the matter with ower.
vab

Mission, KS

#146 Dec 23, 2014
Richard wrote:
I have a 99 eddie baur 4x4. I am having problems with my antilock brakes just grabbing at low speeds. its like my traction control is kicking in. Anyone have any ideas? I am also trying to find out if there is some way to completely turn the 4wd off. it has the automatic.
Replace you rear wheel speed sensor.
base jackson

Newark, NJ

#147 Jan 8, 2015
I change my alternator an now my truck wont charge.
mel

Charlotte, NC

#148 Jan 14, 2015
I have 1999 ford expedition the anti theft light is on and car wount start can anyone tell how to reset it
LTj2

Oviedo, FL

#149 Feb 10, 2015
I have 1999 ford expedition the anti theft light is on and car wount start can anyone tell how

With the key in the ignition open the driver side door ,....lock it....unlock it.....lock it again...the lock it...that should take it off!
LTj2

Oviedo, FL

#150 Feb 10, 2015
base jackson wrote:
I change my alternator an now my truck wont charge.
did you charge battery?
Smurf

Dandridge, TN

#151 Feb 18, 2015
I got 99 ford expedition and when I cut it off the heater blower keeps running what can cause it
michael

Lawton, OK

#152 Thursday Mar 26
Richard wrote:
I have a 99 eddie baur 4x4. I am having problems with my antilock brakes just grabbing at low speeds. its like my traction control is kicking in. Anyone have any ideas? I am also trying to find out if there is some way to completely turn the 4wd off. it has the automatic.
Your abs sensors are bad two in front and one on rear end..
Eddie

Washington, DC

#153 Sunday Mar 29
Dish lights don't work
jon b

United States

#154 Monday Apr 6
I have 1999 expedition 5.4... my truck idles really rough when I start it acts like it wants to cut off at stop lights and signs. I took it to auto zone to put on the diagnostic tests and nothing showed. It's mos def something wrong with my truck. Anyone know anything about this problem and what I should do will be gladly appreciated. Maybe something to do about the egr sensor but I'm not sure. Any suggestions?
sam

Carol Stream, IL

#155 Yesterday
how to operate auto lamps

Tell me when this thread is updated:

Subscribe Now Add to my Tracker
First Prev
of 8
Next Last

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Ford Expedition Discussions

Title Updated Last By Comments
2003 Ford Expedition Questions (Apr '07) Thu Montana ford 16
Increased fuel mileage for an Expedition (Oct '07) Apr 22 Tim 5
2004 Ford Expedition XLT (rear) AC clicking sound (Apr '09) Apr 20 terepuga 26
child safety lock rear passenger side (Jan '07) Apr 18 ted 60
2001 expedition fuse problem (Nov '09) Apr 17 Ida 27
1998 ford expedition troubleshooting question-h... (Nov '06) Apr 15 allen 991
Gas gauge for 98 Ford Expedition Eddie bauer. Apr 12 Kenny 1
More from around the web