1999 Ford Expedition - Car Troubles
Sharon

Millville, NJ

#123 Apr 17, 2013
Once the hatch is open on my 1999 ford Expedition the lights inside as well as on the running board will not shut off. How ever they will turn off once driving down the road after it hits about 25 mph. Does
nathan

United States

#124 Apr 25, 2013
i have a 99 triton v8 expedition 4 wheel drive it idles fine but under pressure it studders. i dont know what it is i changed 1 coil pack and changed wires and spark plugs can someone please help
greg bradenton fl

Bradenton, FL

#125 Apr 25, 2013
had tune up done on expidition still runnind rough and sloggish whats wrong
greg bradenton fl

Bradenton, FL

#126 Apr 25, 2013
my expedtion is a v8 triton had tuneup done and still running rough what else could it be
shaun

United States

#127 May 2, 2013
I have a 1999 4.6 L expodition xlt and when I come to a stop the oil gauge drops to to low and it starts ticking then when I start driving it goes back up I have oil in it.....can someone please help me
shannon

United States

#128 May 12, 2013
I have a99 expo eddie b with 5.4 my brake lights stopped working then two days later no headlights and now when its in park idling it with make noise like your turning tbe key over while its started..ive changed starter and fuses..is there anyone who has an idea what else to do.
Arlene

Milton, MA

#129 Jun 8, 2013
rodney wrote:
i have a 98 ford expedetion and this morning put 10 dollars in gas and then while going down the road it started missing and my temp gage and my oil gage went to high.what could this be?thanks
Did you find out what this was? I have it happening to my 1999 now. It keeps needing coolant too.
chad

United States

#130 Nov 2, 2013
I have a 99 expidition that eill not crank over to dtart anyone have any ideas
MrsBrandon2013

Knoxville, TN

#131 Jan 4, 2014
Me and my fiance bought a 1999 Ford Expedition a year ago as of March. Maybe about 2 months ago the truck started acting up. It runs but acts like it wants to cutoff and dont. It has never cutoff but it acts like it. We have someone to look at it but dont have the funds right now to pay him or anybody else. Is there anybody that can give mw an idea as to whats wrong with our truck even tho I think we need oil. ADVISE PLEASE!!
joey

Cub Run, KY

#132 Jan 12, 2014
When the switch is on accessory the radio wipers windows and I'll work. But when you start it the windows don't work the wipers don't work the radio don't work.
Lance

Palatka, FL

#133 Jan 25, 2014
I have a 99 Expedition, a few years ago I pulled up somewhere and when I went to leave it wouldn't start. I calked somebody and they said it was my relay so I popped the hood and pressed down on the relay and it started. Now for the past couple of weeks sometimes it will start and sometimes it. The trick with the relay doesn't work anymore. I just tried to start it and it sits and sputters. I listen for the fuel pump but can't hear it but it's trying to start. 15 minutes before this it started just fine. I don't think it's the fuel pump. Could it be the sending unit, of the relay, or the fuel filter, I just changed the coil packs and spark plugs. Does anybody know what I might do to resolve this problem?
Joseph

Orlando, FL

#135 Feb 8, 2014
I have a 1999 Ford Expedition.It runs perfect in idle but as soon as I put some gas on it it starts to run rough.Does anybody have an idea of whats wrong.
Jimmy

Tucker, GA

#136 Feb 26, 2014
My 99 expedition wont crank. Help. Turn key, relay clicks but nothing!!!! New starter. Turn key interior lights go out. Headlights stay strong. Ive cleaned all conections including grounds. Started fine twice then next morning,nothing. Please help
Theo Moore

Parksley, VA

#137 Apr 8, 2014
My door open light is on when all doors are closed. I think its my trunk door because in the past its been the one that needed to be reclosed.
BofService

Las Vegas, NV

#138 Apr 28, 2014
alex wrote:
I have a 99 expedition and my door ajar sensor will not turn off once the doors are closed. This is causing my battery to die. Does anyone know how to disable that sensor or how to fix the problem?
My has been doing the same thing. I found that it was the running board lights draining my battery. I had them cut and taped up. Then the rubber at the top of one of my doors came off so if we didn't slam the door, dead battery. So with the slamming it stopped, but then my 5 year old pulled out the sensor on my trunk glass so now the truck thinks the door is open.... Dead battery. Ugh. Now looking to find out how yo fix that. Love my expedition, it runs great with new engine. Ugh
BofService

Las Vegas, NV

#139 Apr 28, 2014
Anyone know how to disconnect back sensor?? See thread below please.

alex wrote:
I have a 99 expedition and my door ajar sensor will not turn off once the doors are closed. This is causing my battery to die. Does anyone know how to disable that sensor or how to fix the problem?

BofService wrote:
My has been doing the same thing. I found that it was the running board lights draining my battery. I had them cut and taped up. Then the rubber at the top of one of my doors came off so if we didn't slam the door, dead battery. So with the slamming it stopped, but then my 5 year old pulled out the sensor on my trunk glass so now the truck thinks the door is open.... Dead battery. Ugh. Now looking to find out how yo fix that. Love my expedition, it runs great with new engine. Ugh
Cezar

United States

#140 Jul 6, 2014
Would a 97 expedition parts fit a 99?
Larry Ester

Gonzales, LA

#141 Aug 8, 2014
I have a 1999 Ford Expedition, while driving home doing about 70 mph on the interstate the vehicle shutdown for no reason. I tried starting it and it did nothing. It sounded like the engine was locked. I got home and turn the engine with a pipe wrench and it turned. Now when i trying starting it it is making a clicking noise like it's the starter but a bad starter would not make it stop while driving. have anyone had this problem and ifg so what didi you find out what the problem was. Thank You
Safraz

Bronx, NY

#142 Aug 15, 2014
alex wrote:
do a Tune up, replace oxygen sensor , replace a EGR Valve,
Both
Hannah

United States

#143 Aug 22, 2014
Well my truck is looking power, randomly when I am driving it cuts out. Not completely killing engine..but makes it jurk. Engine light is not on..what could it be? Anyone

Tell me when this thread is updated:

Subscribe Now Add to my Tracker

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Ford Expedition Discussions

Title Updated Last By Comments
1998 ford expedition troubleshooting question-h... (Nov '06) Jul 15 Anne 1,018
1997 Ford Expedition transmission problem (Mar '08) Jul 10 Juan Ramos 70
2003 Ford Expedition Warm and cold start diffic... (Sep '09) Jul 7 Dave 24
Fitment Question Jul 4 Anonymous 1
2016 suspension Jul 3 Dan Zoeller 1
mechanic stated correct oil for expedition dam... Jun 28 soalce30 1
99 exped electrical problem when it rains (Jul '07) Jun 27 Cirilossanchez 81
More from around the web