a/c air flow
dude

Statesville, NC

#1 Jul 26, 2010
My a/c does not let air out the front vents only out the defrost vent. rear a/c works fine. Please help!!!!!!
Cathi Eredia

El Monte, CA

#2 Feb 8, 2011
I am experiencing the same issue with my 2004 Expedition, A/C works fine, but only comes out of the defrost vent. Has anyone found a solution to this issue. My actuator is out in the back panel as well. Thought maybe that have caused the issue with the A/C in the front.

Any help would be greatly appreciated.

Thanks ;)
AC switch

Palo Alto, CA

#3 Jun 23, 2011
I have a similar problem. My ac works fine but when I accelerate the air flow would switch from the front vent to the defrost vent. Idle mode or constant speed (cruise control)works fine. I was told there maybe a leak in vacuum hose. How do I troubleshoot it?
billyb

Keller, TX

#4 May 12, 2013
Cathi Eredia wrote:
I am experiencing the same issue with my 2004 Expedition, A/C works fine, but only comes out of the defrost vent. Has anyone found a solution to this issue. My actuator is out in the back panel as well. Thought maybe that have caused the issue with the A/C in the front.
Any help would be greatly appreciated.
Thanks ;)
it is a vaccuum line mine did same thing there is a vaccuum line that controls the vents to open and close in ur dash board

Tell me when this thread is updated:

Subscribe Now Add to my Tracker

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Ford Expedition Discussions

Title Updated Last By Comments
97 expedition 4x4 5.4l XLT Sat Dhale90 1
Transmission not changing gears after using fou... Jan 12 Leon 1
Transmission Jan 8 Boomer 1
1999 Expedition will not start - not crank (Sep '13) Dec 31 Martyce 14
2002 ford expedition sunroof won't close (Jun '08) Dec 29 Jrc 26
1997 Ford Expedition transmission problem (Mar '08) Dec 27 Zjoyeelaine 74
2002 Ford Expedition turns over but won't start (Aug '08) Dec 27 Wendell 44
More from around the web