2003 Ford Expedition Questions

Posted in the Ford Expedition Forum

Dan Chicago Illinois

Chicago, IL

#1 Apr 30, 2007
I have a 2003 Ford Expedition bought new now has 153,000 miles on it. I have Door Ajar light on for last year. I just sprayed WD40 on latches. It is still on. Also, Airbag light flashes on and off sometimes. And, if I turn rear wiper on it drains the battery after expo is turned off. Although, these are minor problems, I do not want to take to dealer as it will be a rip off. In the last 2 years, I already spent $2100 with dealer relplacing coils for engine misfiring. Any advice ?

I forgot to add, the drivers heated seat does not come on but the passengers does. Also, my head lights will not go out. Now, I just found out middle seat in back somehow now will not fold down !?!
Tman

Syracuse, UT

#2 Aug 23, 2008
how to operate air suspension for 2003 expedition
Jeff

Gainesville, FL

#3 Jan 2, 2009
I have a 2003 Ford Expedition I bought new and it presently has 105,000 miles on it. My wife and I use it periodically to tow a horse trailer. We backed up to hook to the trailer, hooked up then loaded the horse. We then tried to place the SUV in Drive, but the gear shifter will not budge. The SUV is parked on level ground so there is no strain on the transmission. We've towed this trailer multiple times and have never experienced anything like this. I would appreciate any response to my problem at hand.
Vanessa

Cornwall, Canada

#4 Oct 26, 2009
I am having the exact same problems with my 2003 Exp. I had the battery changed twice. the mechanic disconnected basically every power option my truck has. Now my vehicle won't start makes loud buzzing sound from the fuze box. Need help!!
Dan Chicago Illinois wrote:
I have a 2003 Ford Expedition bought new now has 153,000 miles on it. I have Door Ajar light on for last year. I just sprayed WD40 on latches. It is still on. Also, Airbag light flashes on and off sometimes. And, if I turn rear wiper on it drains the battery after expo is turned off. Although, these are minor problems, I do not want to take to dealer as it will be a rip off. In the last 2 years, I already spent $2100 with dealer relplacing coils for engine misfiring. Any advice ?
I forgot to add, the drivers heated seat does not come on but the passengers does. Also, my head lights will not go out. Now, I just found out middle seat in back somehow now will not fold down !?!
Dan Schmittou

Liberty, SC

#5 Dec 31, 2009
Jeff, I don't have the same car, but had a similar problem. I started my car, but couldn't shift the gesrd. It was a blown fuse. there is an electrical switch on the transmission, and it was deactivated by the blown fuse. My radio and cigar lighter were on the same circuit.
Dan
nicky brown

United States

#6 Jan 7, 2010
i have a 2003 ford expedition and the gear shift want come out of park.what would be the problem.
trety

Fort Lauderdale, FL

#7 Feb 17, 2010
why is my 2003 leaning
Brett Gerring

Hopkins, MN

#8 Dec 21, 2010
In the past week my ADVTRAC on my 03' Expedition has turned itself off twice. The first time I was driving and I heard the "ding" and the message center said "check ADVTRAC". When I arrived at work I shut off the truck, when I left the ADVTRAC was back on. No issues for a week until today when I washed the car. I pulled it out of the car wash and parked it for a while. When I got back in and started it I heard the "ding" again and once again the message center said "check ADVTRAC", but this time the ABS light came on as well. What could be the problem? will I cause damage to the truck by driving it in this condition?
Penny

Ashtabula, OH

#9 Jan 16, 2011
My 2003 Ford Expedition back seats don't go down, is it possible blown fuse.
Steve

Somerville, MA

#10 Feb 11, 2012
why would i have a grinding noise in the left front when the vehicle is in two wheel drive but in awd the noise goes away
Don

San Francisco, CA

#12 May 23, 2012
Compass calibration bell rings constantly
Don

San Francisco, CA

#13 May 23, 2012
Compass calibration bell rings constantly.
Monica H

Peoria, IL

#14 Apr 7, 2013
Brett: Did you get this resolved? I have a 2003 Expedition that has just started doing this. As a single lady, I am leary of going to the dealership and getting ripped off. Any advise you can give would be greatly appreciated.
Brett Gerring wrote:
In the past week my ADVTRAC on my 03' Expedition has turned itself off twice. The first time I was driving and I heard the "ding" and the message center said "check ADVTRAC". When I arrived at work I shut off the truck, when I left the ADVTRAC was back on. No issues for a week until today when I washed the car. I pulled it out of the car wash and parked it for a while. When I got back in and started it I heard the "ding" again and once again the message center said "check ADVTRAC", but this time the ABS light came on as well. What could be the problem? will I cause damage to the truck by driving it in this condition?

Tell me when this thread is updated:

Subscribe Now Add to my Tracker

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Ford Expedition Discussions

Title Updated Last By Comments
2001 ford expedition electrical problems (Sep '07) Oct 27 DcFynest 76
2007 Expedition Oct 23 ford3653 1
99 Expedition 4x4 Issues (Nov '06) Oct 19 russman 104
2001 electrical problem Oct 15 Mulleroni 2
1998 ford expedition troubleshooting question-h... (Nov '06) Oct 12 netro94 964
2003 ford expedition electrical problem! Oct 11 Garry 1
Help! Oct 4 dean 2

Ford Expedition People Search

Addresses and phone numbers for FREE