2003 Ford Expedition electrical problems

2003 Ford Expedition electrical problems

Posted in the Ford Expedition Forum

First Prev
of 2
Next Last
Jcs

Grande Prairie, Canada

#1 Feb 10, 2009
The seats heater/air are not working, door ajar stays on, automatic headlights won't work, radio stays on after the door is opened and the vehicle is shut off.
Vanessa

Cornwall, Canada

#2 Oct 26, 2009
I am having the exact same problem. Took it to mechanic he disconnected my radio. Need to knowhow to fix this problem.
Tom

Sioux Falls, SD

#3 Nov 25, 2009
We just bought a 2003 Expedition with 146000 miles on it. The first thing I noticed that this vehicle had a custom radio in it, not factory. What made this more interesting that it belonged to a company and was used as a fleet vehicle. So I'm thinking if the radio (old one) as stated above was disconnected then maybe that is truely the issue. Old radio might be the problem, and replace with a new one, maybe there is some sort of cross wiring that is causing the issue and is related with the radio....
pops

Brazoria, TX

#4 Oct 19, 2010
2003 Ford Expedition 5.4 Eddie Bauer
Not cranked in @ 3 weeks, now have no electrical inside car runs but nothing comes on inside car...help...
Bobbie

Leesville, LA

#5 Oct 31, 2011
I have a 2003 Ford Expedition and it keeps blowing the SecurLock Transevir fuse #28. Has anyone experienced this problem and what could be causing it to do that.
James

North Fort Myers, FL

#6 Mar 12, 2012
Truck doesn't start, no notice,today didn't start first thing this morning, Last time after shopping stuck,towed n mechanic said it worked that next morning and couldn't duplicate problem. Do the chip in keys go bad ?
NeeC

Hattiesburg, MS

#7 Sep 3, 2012
My radio doesnt work, but makes a whining noise even when the truck is turned off. I have a 2003 Ford Expedition Eddie Bauer, White. Any suggestions??
Erosa

United States

#8 Jun 8, 2013
Did you fix the problems? I have the exact same problems
augustine botello

Dallas, TX

#9 Jul 16, 2013
Have a03 expedition... while driving, all gages go dead.radio turns off and almost instantly kills my battery...(New battery& alternator) any suggestions?
Troy

Knoxville, TN

#10 Oct 13, 2013
Have 03 expedition Eddie Bauer, when attempting to start before turning key over is starting itself. Have replaced starter, fuses, relay an ingnition switch. Might it b the actual switch going bad!
Beth

Summerville, SC

#11 Mar 19, 2014
03 expedition: sitting at red light, cut off. riding in traffic had to slow down or cost, cut off! No noise, no warning, just dead. Started back up almost immediately. What could it be?
Sara

Dubuque, IA

#12 Apr 15, 2014
2003 Eddie Bauer problem is electric windows radio heater does not work when the temperature gets cold need to get up to operating temperature before these components work any solutions to this have had it to 2 different Ford dealers and no solutions
Jimmy 03 expedition eddie

Fort Myers, FL

#13 May 16, 2014
Beth wrote:
03 expedition: sitting at red light, cut off. riding in traffic had to slow down or cost, cut off! No noise, no warning, just dead. Started back up almost immediately. What could it be?
I am having similar problems. First my interior lights stay on after the doors are shut so I manually turn off all interior lights. My door ajar light stays on. Also, my truck will, for no apparent reason, shut down without warning; however, it will restart shortly afterwards.
Any and all suggestions welcome. Thanks
Steve

Tampa, FL

#14 May 21, 2014
Beth wrote:
03 expedition: sitting at red light, cut off. riding in traffic had to slow down or cost, cut off! No noise, no warning, just dead. Started back up almost immediately. What could it be?
Follow the positive cable off your battery. It will come to a long black box.follow the wire that splits off towards the back. It is probably rubbing on ac tube and shorting out. Tape it up and fix it.
Tony

Fairfield, CA

#15 May 27, 2014
My Traction control light keeps blinking.....
Ricardo lopez

North Las Vegas, NV

#16 Nov 24, 2014
I have a 2003 Eddie Bauer edition my ignition starter doesn't seem to start the engine and a noise underneath the glove compartment starts every time I try to start the truck. What could it be ?
Marvin

Charlottesville, VA

#17 Jan 16, 2015
I have a 2003 expedition and while driving all my guages go out and windows don't work , after about 2-3 miles everything comes back on
Michael

Tampa, FL

#18 Jan 20, 2015
I have a 2003 ford expedition, occasionally my radio shorts out at my windows do not work, neither does my moon roof... problem used to fix itself after a short while now has been going for about 2 days my windows are stuck down, does anybody have an answer to this problem
jasonprater69

Toledo, OH

#19 Jan 20, 2015
Ricardo lopez wrote:
I have a 2003 Eddie Bauer edition my ignition starter doesn't seem to start the engine and a noise underneath the glove compartment starts every time I try to start the truck. What could it be ?
Relay

Since: Jan 15

Columbus, GA

#20 Jan 27, 2015
Jcs wrote:
The seats heater/air are not working, door ajar stays on, automatic headlights won't work, radio stays on after the door is opened and the vehicle is shut off.
Ever fix it u have the same problem

Tell me when this thread is updated:

Subscribe Now Add to my Tracker
First Prev
of 2
Next Last

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Ford Expedition Discussions

Title Updated Last By Comments
1998 ford expedition troubleshooting question-h... (Nov '06) Thu Edith522 1,002
2001 Expedition - Blower fan continues to run (Feb '07) Jul 27 Phyllis D 36
child safety lock rear passenger side (Jan '07) Jul 23 Navi-man 62
Transferred case problem Jul 14 Con 1
2002 Ford Expedition turns over but won't start (Aug '08) Jul 14 Just checking 28
2004 Expedition rear A/C noise (Feb '08) Jul 7 hejlman 88
1997 Ford Expedition transmission problem (Mar '08) Jun '15 Brime 66
More from around the web