03 Ford Expedition 4.6 won't start...

03 Ford Expedition 4.6 won't start...

Posted in the Ford Expedition Forum

Since: Feb 14

Scranton, PA

#1 Feb 22, 2014
I have a 03 Expedition 4.6 it 'died' as I was about to park. I had a co-workers brother who claims to be a mechanic that had me to try the basics. Had battery checked it was bad, changed it. Had starter checked, also bad, changed it. I'm also getting the 'clicking' noise from the fuse box area but now I noticed a puff of smoke when holding the key in the start position. I'm more than sure that this is above my area of expertise. I can see that when i'm trying to start it that the fan moves. This tells me (I think) that the motor is not locked up.All the interiors 'dim' a little when trying to start it, but after a few minutes of just setting, everything is bright again.

Thoughts?

Tell me when this thread is updated:

Subscribe Now Add to my Tracker

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Ford Expedition Discussions

Title Updated Last By Comments
98 expedition Tue Philw357 1
99 expedition Mon Cindy 1
2002 Ford Expedition turns over but won't start (Aug '08) Dec 11 Cindy 48
1999 Ford Expedition - Car Troubles (Sep '07) Dec 4 Robert Stroud 173
1998 ford expedition troubleshooting question-h... (Nov '06) Nov 30 ChevyGuyWithAFord 1,036
1999 Expeditions starts and shuts right off. (Nov '07) Nov 27 Ana 8
1999 Exp XLT 5.4L 2WD Oil Pump Failing? (Jul '08) Nov 26 Khary 14
More from around the web