97 Neon Idle rough
First Prev
of 2
Next Last
mike edwards

Anderson, SC

#1 Jan 18, 2007
I have a 97 Neon. The car ran fine, I took it in to a local shop and had the timing belt replaced and the water pump as well. While replacing the belt, they broke my harmonic balancer, but replaced it as well at no charge because they used the wrong balancer puller to begin with. Anyway, I picked up the car, drove it home, it idled and ran fine. The next day, I drove it about 10-15 miles, noticed an occasional miss at idle, I though, maybe bad gas. Next day, filled up with super unleaded, but idle got rougher. The car runs fine at speed, but anytime you stop, it almost dies. Idles very rough. Took the car back to the shop, they said it was the O2 sensor, replaced, nope. They then said it was the plug seals in the valve cover, nope. They now say its the computer...
Advice?
gord

Canada

#2 Jan 19, 2007
Does the check engine ligt come on? If so what codes.

Since: Jan 07

Lewisport, Ky

#3 Jan 24, 2007
97 4-cyl ? fowl in plug #3 cyl on mine pull plug wire look for oil.
brian duffy

Oconomowoc, WI

#4 Feb 17, 2007
my friend had this same prob with his 1995 chevy s10.but is it leaking oil cuase if it is its ur gaskets but .also u might wanna have ur idler valve replaced on it.
josh

Montréal, Canada

#5 Feb 19, 2007
I have the same problem, it idles rough the more throttle you give it even while driving.
Try turning the key off then on twice and then just leave it in the on position. You will then get a morse code signal from your 'check engine' lighton the dash. Record all the number of flashes. if you get a 1,2,4,3 it means that the computer has indicated error codes 12 and 43. You can find out what these error codes mean in any haynes or chilton service manuals. i have about 6 different codes flashing in, so i figure its got to do with a bad ground connection in the wiring circuit somewhere but havent been able to trace it yet.
I've changed the fuel filter spark plugs and tube seals, with no change in performance. If you find out what it is please spread the wealth! email me at [email protected],, thanks!
BUTCH

Chattanooga, TN

#6 Feb 24, 2007
mike edwards wrote:
I have a 97 Neon. The car ran fine, I took it in to a local shop and had the timing belt replaced and the water pump as well. While replacing the belt, they broke my harmonic balancer, but replaced it as well at no charge because they used the wrong balancer puller to begin with. Anyway, I picked up the car, drove it home, it idled and ran fine. The next day, I drove it about 10-15 miles, noticed an occasional miss at idle, I though, maybe bad gas. Next day, filled up with super unleaded, but idle got rougher. The car runs fine at speed, but anytime you stop, it almost dies. Idles very rough. Took the car back to the shop, they said it was the O2 sensor, replaced, nope. They then said it was the plug seals in the valve cover, nope. They now say its the computer...
Advice?
IF YOU BELT TENTIONER WAS NOT TORQED INTO PLACE BEFORE THE PIN WAS RELEASED THE BELT MAY HAVE SLIPPED. THE CHECK ENGINE LITE MAY NOT COME ON BECAUSE THE COMPUTER HAD NOT LEARNED THE NEW PARAMETERS. ONE TOOTH WOULD NOT BE NOTICEABLE AT HIGHER RPMS (ONLY AT IDLE)LETS US KNOW IF THE CHECK ENGINE LITE COMES ON AND GIVE US THE CODE NUMBER...
kelso

Madoc, Canada

#7 May 31, 2007
i got a 97 2door neon with the codes 12 and 27 cumming up can anyone tell me what they mean??
Steve

United States

#8 Jun 10, 2007
kelso wrote:
i got a 97 2door neon with the codes 12 and 27 cumming up can anyone tell me what they mean??
http://www.allpar.com/fix/80s-codes.html

Steve
lavafrogg

AOL

#9 Jul 9, 2007
My 99 DOHC had the same problem after timing belt replacement. According to the mechanic, one of the cam pulleys had no key in it and when the belt was changed, it must have been bumped and was slightly off. This was a ticking time bomb found by accident. He fixed if for free.
brian

Pittsburgh, PA

#10 Aug 3, 2007
check your egr valve but r/t did it to but then i cleaned the vent on the fill tube and it purrs like a kitten
same

Wilson, NC

#11 Mar 29, 2008
i got the same problem with the idling and it was right after this guy replaced my timing belt.

it idles rough but if i give it gas...its fine.
it seems as if the car only wants to go fast.

also while its idling rough...as long i put the car in neutral when stopping...the car operates fine. acceleration isn't at its best but car runs good.
marcos

United States

#12 Apr 1, 2008
gord wrote:
Does the check engine ligt come on? If so what codes.
I'm a new person, but I have the exact same problem and the "Service Engine Soon" light appeared once the problem started.
MUGGZ

Killeen, TX

#13 Dec 9, 2008
I HAVE THE SAME PROBLEM AFTER MY BELT WAS CHANGED. ONLY IT IDLES ROUGH NO MATTER IF IN NEU DRIVE OR REVERSE. I GOT CHECK ENGINE LIGHT WITH CODE P0108 P0203 P0303 P0204 PLEASE HELP I REPLACE INJECTERS, WIRES, SPARK PLUGS, MAP SENSOR,.
Daniel Archan

Roseville, CA

#14 Apr 18, 2009
yesterday 4-17-2009 I let my 1995 sohc Plymouth neon Idle for about 10 minutes and the car started to kinda stumble it was in park then it would almost turn off but it wouldnt then i went inside the car and push on the gas and the car would not don anything it engine stumble even more it eventually turned off then had to try several times to turn motor back on then left it alone because it was late next morning struggled to turn on and when it did it did the same stubling thing my motor with no power and almost completely turning off but i cant run it because of the problem can someone help me i need some help i am a college student low on cash and dont wanna go spending money on stuff that isnt going to work
sonnie

Sacramento, CA

#15 Jan 9, 2010
Got 97 neon,nothing but problems.Had the car about three years.Replaced timing belt and water pump twice.Transmission seals,radiator,relay switch for radiator,electronic cluster for speedometer.Nothing but problems,would never buy an american car again.
Brad

United States

#16 Mar 18, 2010
Ok, I see lots of complaints and no solutions. My 98 had the timing belt break over a year ago. I rebuilt the head and have checked the timing three times and its set right. It runs fine on the hwy. I get a map sensor error but I've replaced it. Also replaced the timing sensors and the EGR. Very frustrated. Got 280,000 out of my 95 but this things been a total pain. Idles rough, starts rough and 50% of the time it runs fine. I never know when I come up to a stop light if I'll have great acceleration or get stuck in front of oncoming traffic with a sputtering and backfiring car. Please someone help. The only person that posted a comment about getting theirs to run right said something about cleaning a port and it purring like a kitten. What the hewk did you clean and where is it?!?!?
twotoedtranny

Newark, OH

#17 Sep 21, 2010
to everyone on here comlaining, dont ask questions about your car if your check engine light is on, that is gonna tell you whats wrong. if your car is runin like crap but no codes, check fuel, is it old gas, do you have enough pressure? Also remember the basic needs for an engine and check for each, fuel/air, spark, timing, compression. Compression seems to be the important one with these cars for they have bad head gasket reps.
ashley

Greenville, SC

#18 Sep 30, 2012
same wrote:
i got the same problem with the idling and it was right after this guy replaced my timing belt.
it idles rough but if i give it gas...its fine.
it seems as if the car only wants to go fast.
also while its idling rough...as long i put the car in neutral when stopping...the car operates fine. acceleration isn't at its best but car runs good.
Did u ever figure out what was wrong with your car? Mine is doing the same thing
rlg

United States

#19 Jan 29, 2013
I have 1995 Plymouth Neon SOHC. My car ran a very rough idle when it is stopped by braking in reverse or one of the drive gears, like at a traffic light. It runs fine if accelerating at higher or low speeds as long as it is getting gas and open throttle. I used a fuel, catalytic converter, fuel injector, egr cleaner called Cataclean. It seems to dissolve any build up in the fuel and exhaust system to restore power and torque.
MoparGarage

Berkeley Springs, WV

#21 Feb 3, 2015
Not really sure if you tried this or not, but I wrote a article for the 97 Neon with your issues. http://mopar-garage.blogspot.com/2015/02/1997...

Tell me when this thread is updated:

Subscribe Now Add to my Tracker
First Prev
of 2
Next Last

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Dodge Neon Discussions

Title Updated Last By Comments
Oil pouring out then makinh very loud noise lik... Sep 24 Jeremynjenny 1
standard transmission Sep 22 dennis shipman 1
95 neon turns over but wont start (Sep '06) Sep 22 Sexypr22 29
00 Plymouth Neon Turns over but no spark (Feb '11) Sep 20 ABrown 12
2004 Dodge Neon SXT Problems (Sep '07) Sep 18 josh 328
98 dodge neon fuel pump fuse/wiring (Aug '09) Sep 17 Bill S 17
2005 Dodge neon sxt will not start. Lights and ... (Aug '09) Sep 16 Fedup 189
More from around the web